質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.91%

ディストリビューションについて

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 2,580

score 25

有識者の皆様

よろしくお願いします。

「CentOS Linux release 7.2.1511 (Core)」を利用しています。
脆弱性対応のため、squidのバージョンを「3.3.8 → 4.0.12」にアップグレードを検討しています。

拡張レポジトリよりアップデートを試みましたが、以下の依存関係によりアップデートが完了しません。
///////////////////////////////////////////////////////////////////////////////////////////////
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> パッケージ squid.x86_64 7:3.3.8-26.el7_2.4 を 更新
---> パッケージ squid.x86_64 7:4.0.12-1.el7.centos を アップデート
--> 依存性の処理をしています: libecap.so.3()(64bit) のパッケージ: 7:squid-4.0.12-1.el7.centos.x86_64
--> 依存性解決を終了しました。
エラー: パッケージ: 7:squid-4.0.12-1.el7.centos.x86_64 (squid)
要求: libecap.so.3()(64bit)
問題を回避するために --skip-broken を用いることができます。
///////////////////////////////////////////////////////////////////////////////////////////////

libecap.so.3について、epel、remi、RepoForgeのレポジトリから検索しましたが、見つけることができませんでした。
そこで、rpmによるインストールを検討していますが、ディストリビューションについて疑問が出てきました。

以下のサイトでrpmパッケージを検索すると各ディストリビューションのパッケージが検索されます。
https://www.rpmfind.net/linux/rpm2html/search.php

以下、ご質問です。

ディストリビューションが異なっても、同じRedhat系のrpmパッケージであれば、異なるOS(CentOSでFedoraを使うとか)であっても共用利用できるものなのか?

以上です。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

ディストリビューションが異なっても、同じRedhat系のrpmパッケージであれば、異なるOS(CentOSでFedoraを使うとか)であっても共用利用できるものなのか?

RHEL と互換性のある CentOS などは、同じバージョン(RHEL 7 と CentOS 7)であれば RPM を共用利用できます(サブスクリプションの問題は除く)。

しかし、他のディストリビューションの RPM は基本的には動かないと思った方がいいです。
ディストリビューションによってライブラリ環境が異なるので、その環境でコンパイルされた RPM でないと動きません(noarch.rpm であれば利用できるかもしれません)。
また、サービス起動方法の違い(SysVinit, Upstart, Systemd など)もあります。

他のディストリビューションの src.rpm をリビルドすれば動かせる場合もあります。
ただし、リビルドに必要なライブラリが無かったり、前述のサービス起動方法の違いもありますので、その src.rpm によります。

エラー: パッケージ: 7:squid-4.0.12-1.el7.centos.x86_64 (squid)
要求: libecap.so.3()(64bit)

「el7.centos」と付いているので、CentOS 7 環境でビルドされたものと推測されます。
libecap.so.3 を提供する RPM も同じ場所にありませんか?
インターネットで検索すると、squid-4.0.12 は「beta/」にありますが、「beta/」じゃないところに libecap-1.0.0 がありました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/07/19 10:21

    ご回答ありがとうございます。
    ご指摘の通り、レポジトリの取得先が/betaでした。
    squidのレポジトリ先を変更することでlibcap-1.0.0もyumで見つけられました。
    updateすると一部で競合しているファイルが見つかりましたので、一旦removeしてインストールするか、rpmで競合を無視するか検討してみます。

    ディストリビューションについてもありがとうございます。
    疑問が解決しました!
    rpmパッケージの利用には注意してまいります!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.91%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る