質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.06%

MySQLサーバへの接続ができません。mysqli::mysqli(): (HY000/2002): Permission denied

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 8,659

WebDesigner

score 11

PHPから外部MySQLに接続できません。

GCP(Google Cloud Platform)でWEB環境を構築したいと思い 
以下のページを参考にGCEでサーバ(centos7)を立ち上げ、ApacheとPHP5.6をインストールしました。 
http://weblabo.oscasierra.net/centos7-php56-install/

続けてGoogle Cloud SQLでMySQLサーバ(第二世代)を作成し
アクセス制御ページでGCEの外部IPを追加しました。

GCEで立てたサーバから以下のコマンドでMySQLサーバに接続しDBを作成
mysql -uroot -p -h 'MySQLサーバIP'

WEBサーバに以下のPHPファイルを置きmysqliでDB接続できるか確認したところ
エラーが発生してしまい接続ができませんでした。

<?php

define("dbHOST","255.255.255.255");    // 仮)GECインスタンス外部IP
define("dbUSER","root");        // アクセスユーザー名
define("dbPASS","password");        // アクセスパスワード
define("dbNAME","database");        // database名

// database接続
$mysqli = new mysqli(dbHOST, dbUSER, dbPASS, dbNAME);

// 接続の状況をチェックします
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}
$stmt = $mysqli->prepare('SET NAMES utf8');
$stmt->execute();

エラーメッセージ

mysqliを実行した際のエラー文

Warning: mysqli::mysqli(): (HY000/2002): Permission denied
Connect failed: Permission denied

疑問点

どうやればPHPから外部のMySQLへ接続できるのでしょうか?
また、なぜコマンドでは接続ができてPHPからは接続できないのでしょうか?
MySQLへのログインユーザーは同じものを利用しています。

サーバに関しての知識がまだ乏しいのですが、どなたかご教授お願い致します。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+3

SELinuxをoffにすれば接続できると思います。

$ sudo setenforce 0

OS再起動時も反映するために /etc/selinux/config も変更してください

SELINUX=enforcing
↓
SELINUX=disabled

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/07/06 14:48

    ご回答ありがとうございます。

    ありがとうございました!
    $ sudo setenforce 0
    を実行すると接続できました!!

    ただ、configディレクトリやselinuxファイルが無いので只今検索中です。

    キャンセル

  • 2016/07/06 15:15

    すみません。
    /etc/selinux/config
    に教えていただいた変更箇所を発見できました!
    ありがとうございました!

    キャンセル

  • 2016/07/06 15:19

    すみません。
    私がパスを間違えていました。

    キャンセル

+1

Hogeで行こう
これじゃないですかね。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/07/06 14:31

    ご回答ありがとうございます。

    少し症状が違うかもしれません。
    PHPからMySQLへの接続ができずにいます。

    キャンセル

  • 2016/07/06 14:37

    phpからも確認していたんですね。
    > WEBサーバに以下のPHPファイルを置きmysqliでDB接続できるか確認したところ
    とあったので、httpd経由の確認のみだと思ってました。

    ってことは SELinux が原因ではなさそうですね。

    キャンセル

  • 2016/07/06 15:16

    質問文がわかりにくく申し訳ございませんでした。
    ご回答いただきありがとうございました!!

    キャンセル

  • 2016/07/06 20:29

    せっかくなので確認してみました。
    リンク先の設定よりもより精緻な範囲での設定がありました。
    sudo setsebool -P httpd_can_network_connect_db 1
    これが一番範囲が絞り込めそうです。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.06%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る