質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.92%

Cisco 841MとBHR-4GRV2とのPPTP LAN間接続について

解決済

回答 1

投稿

  • 評価
  • クリップ 2
  • VIEW 2,786

wyonaha478

score 18

前提・実現したいこと

非固定アドレス間でPPTPを利用してLAN間接続を行いたい。

発生している問題・コンフィグ

VPN接続は確立できたが、RIPのやり取りができない。

・VPNサーバ側:Cisco 841M Jシリーズ(192.168.0.0/24)
・VPNクライアント側:Buffalo BHR-4GRV2(192.168.3.0/24)
※ともにRIP Version2が有効になっている。

また、設定値はDDNSを利用しているため、IPアドレスでの設定は行っておりません。

Cisco側には以下のコンフィグを入れております。

aaa new-model
!
aaa authentication login default local
aaa authentication login local_access local
aaa authentication ppp default local
aaa authorization exec default local 
aaa authorization network default if-authenticated 
!
aaa session-id common
ethernet lmi ce
ppp packet throttle 20 1 30
!
no ip domain lookup
ip domain name ******
ip name-server ******
ip name-server ******
ip multicast-routing 
ip cef
no ipv6 cef
!
vpdn enable
!
vpdn-group 1
 ! Default PPTP VPDN group
 accept-dialin
  protocol pptp
  virtual-template 1
!
license udi pid C841M-4X-JSEC/K9 sn ******
!
!
username ****** password 7 ******
!
interface GigabitEthernet0/0
 no ip address
!
interface GigabitEthernet0/1
 no ip address
!
interface GigabitEthernet0/2
 no ip address
!
interface GigabitEthernet0/3
 no ip address
!
interface GigabitEthernet0/4
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/5
 no ip address
 ip tcp adjust-mss 1412
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface Virtual-Template1
 ip unnumbered Dialer1
 ip mtu 1280
 ip nat inside
 ip virtual-reassembly in
 peer default ip address pool pptpPool
 ppp encrypt mppe auto
 ppp authentication ms-chap-v2
 ppp authorization auth
 ppp ipcp dns ****** *******
!
interface Vlan1
 description $ETH_LAN$
 ip address 192.168.0.254 255.255.255.0
 ip nat inside
 ip rip send version 2
 ip rip receive version 2
 ip virtual-reassembly in
 ip tcp adjust-mss 1412
!
interface Dialer1
 mtu 1454
 ip address negotiated
 ip access-group 100 in
 ip mtu 1452
 ip nat outside
 ip rip receive version 2
 ip virtual-reassembly in max-reassemblies 50
 ip virtual-reassembly out max-reassemblies 50
 encapsulation ppp
 ip tcp adjust-mss 1412
 dialer pool 1
 dialer-group 1
 ppp mtu adaptive
 ppp authentication chap callin
 ppp chap hostname ******
 ppp chap password 7 ******
 ppp ipcp dns request
 no cdp enable
 crypto map CRYPTO_MAP
!
router rip
 version 2
 network 192.168.0.0
 no auto-summary
!
ip local pool pptpPool 10.255.255.1 10.255.255.10
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip pim bidir-enable
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source list nat-list interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
~以下割愛~

試したこと

手動で以下のルートを入れることで通信はできました。

ip route 192.168.3.0 255.255.255.0 [pptpPoolから振られたIP]

ただ、上記だとDDNSなので不測の事態でIPが再付番された際に、
手で書き換えないといけなくなるので、どうにかしたいと思っております。

補足情報(F/Wバージョン)

15.5(3)M3 (2016/06リリース版)

足りない情報などあればご指摘願います。
皆様お忙しい中、お手数ですがご意見ください。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • over

    2016/07/08 10:59

    >また、設定値はDDNSを利用しているため、IPアドレスでの設定は行っておりません。
    上記とありますが、双方DDNSでしょうか?
    ご提示頂いているCisco コンフィグにはDDNSの設定が見当たらないようですが。

    > VPN接続は確立できたが、RIPのやり取りができない。
    RIPのやり取りができないの根拠はなんでしょうか?
    また、RIPが必要なネットワーク環境のために意図的に設定しているという理解であっていますか。

    キャンセル

  • wyonaha478

    2016/07/11 13:01

    自己解決しましたが、情報の追加・修正を行います。

    接続先、元ともにDDNSとなります。ですが、PPTP接続の為、DDNSは接続元のみの利用です。
    Ciscoコンフィグはサーバ側なので、上記により記載がありません。あくまで待ち受け側としての動作です。

    RIPのやり取りができていない件については、debug ip ripを仕掛けて確認したところ、PPTPクライアント側からのRIPがなかったことで判断しております。
    これに関しては、GREトンネルがなかったことによるもので、リモートアクセスのみなら問題なく出来るが、LAN間接続の場合はGREトンネルがないとRIPなどのダイナミックルーティングが転送できないことを思い出しました。

    今、書き込んでいる場所がルータを見ることができないので、後程、変更したコンフィグを記載します。

    本件、修正の依頼をしてもらい本当にありがとうございました。

    キャンセル

回答 1

check解決した方法

0

自己解決致しました。

内容としては、PPPoE接続を行っており、WAN側のネットワークがRouter Ripの中に入っていないために、RIP転送がされないことが分かりました。

PPPoEで固定IPサービスではないので、ルータ再起動や何等かの通信以上でグローバルIPが変わってしまった際は、Cisco EEMを作成し、Dialer 1のStateがDownし、Upになると自動的にグローバルIPを取得して、Router Ripの中に設定を入れるようにしたところ解決しました。

over様、補足依頼を送っていただきありがとうございました。
内容としては以上となります。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.92%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る