質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.05%

Rails にて,bundle install を実行しようとすると、エラーが出てしまいます。

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 4,124

score 8

前提・実現したいこと

Railsを使用して、アプリを作成しようとしているのですが、エラーが発生してしまいます。
ターミナル上で、bundle installを実行しようとすると以下の表示が出ます。

発生している問題・エラーメッセージ

Fetching gem metadata from https://rubygems.org/
Fetching version metadata from https://rubygems.org/
Fetching dependency metadata from https://rubygems.org/
Resolving dependencies...
Bundler could not find compatible versions for gem "sprockets":
In snapshot (Gemfile.lock):
sprockets (= 3.6.2)

In Gemfile:
sass-rails (~> 4.0.2) was resolved to 4.0.2, which depends on
sprockets (<= 2.11.0, ~> 2.8)

web-console (~> 2.0) was resolved to 2.3.0, which depends on
sprockets-rails (< 4.0, >= 2.0) was resolved to 3.0.4, which depends on
sprockets (>= 3.0.0)

Running bundle update will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.

該当のソースコード

Rails
ここにご自身が実行したソースコードを書いてください
bundle install

試したこと

課題に対してアプローチしたことを記載してください

補足情報(言語/FW/ツール等のバージョンなど)

より詳細な情報

回答ありがとうございます。

rubyのバージョンは以下の様になっています。
ruby 2.1.3p242 (2014-09-19 revision 47630) [x86_64-darwin15.0]

これがGemfileの中身です。

source 'https://rubygems.org'

 Bundle edge Rails instead: gem 'rails', github: 'rails/rails'

gem 'rails', '4.2.6'

 Use mysql as the database for Active Record

gem 'mysql2', '0.3.18', 

 Use SCSS for stylesheets

gem 'sass-rails', '~> 4.0.2'

 Use Uglifier as compressor for JavaScript assets

gem 'uglifier', '>= 1.3.0'

 Use CoffeeScript for .coffee assets and views

gem 'coffee-rails', '~> 4.1.0'

 See https://github.com/rails/execjs#readme for more supported runtimes

 gem 'therubyracer', platforms: :ruby

 Use jquery as the JavaScript library

gem 'jquery-rails'

 Turbolinks makes following links in your web application faster. Read more: https://github.com/rails/turbolinks

gem 'turbolinks'

 Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder

gem 'jbuilder', '~> 2.0'

 bundle exec rake doc:rails generates the API under doc/api.

gem 'sdoc', '~> 0.4.0', group: :doc

 Use ActiveModel has_secure_password

 gem 'bcrypt', '~> 3.1.7'

 Use Unicorn as the app server

 gem 'unicorn'

 Use Capistrano for deployment

 gem 'capistrano-rails', group: :development

group :development, :test do

 Call 'byebug' anywhere in the code to stop execution and get a debugger console

gem 'byebug'
end

group :development do

 Access an IRB console on exception pages or by using <%= console %> in views

gem 'web-console', '~> 2.0'

 Spring speeds up development by keeping your application running in the background. Read more: https://github.com/rails/spring

gem 'spring'
end

gem 'pry-rails'
gem 'compass-rails', '~> 2.0'
gem 'sprockets' , '2.11.0'

申し訳ございませんが、よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • raccy

    2016/06/25 21:12

    "Gemfile"の中身やRubyのバージョン(ruby -vの結果)などがあると、何かわかるかも知れません。もしよろしければ、質問に追記してください。

    キャンセル

  • kanjin

    2016/06/28 15:06

    raccy様 ご回答ありがとうございます。 ご指摘の内容を追記しました。申し訳ございませんが、ご教授よろしくお願いいたします。

    キャンセル

回答 1

0

ご使用の「gem」のバージョンの整合性が取れていないためのエラーのようですが、メッセージに示さてれいるように bundle update を実行しても改善しませんか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/06/25 18:13

    回答本当にありがとうございます。
    ターミナル上にて、bundle updateを実行したのですが、以前エラー表示が発生します。
    エラー表示は以下のようになっています。

    bundle update

    [!] There was an error parsing `Gemfile`: syntax error, unexpected tSTRING_BEG, expecting keyword_do or '{' or '(' - gem 'sass-rails', '~> 4.0.2'
    ^
    /Users/hiroto/projects/domesday/Gemfile:9: syntax error, unexpected ',', expecting end-of-input
    gem 'sass-rails', '~> 4.0.2'
    ^. Bundler cannot continue.

    # from /Users/hiroto/projects/domesday/Gemfile:9
    # -------------------------------------------
    # # Use SCSS for stylesheets
    > gem 'sass-rails', '~> 4.0.2'
    # # Use Uglifier as compressor for JavaScript assets
    # -------------------------------------------

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.05%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る