ClassNotFoundExceptionのエラーで困っています

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 2,106

kt3302y

score 25

javaを使用してロボットを操作するプログラミングを行っています.そこで私はゲームパッドをリモコンにするためにjinput-2.0.6.jarファイルをビルドパスに通して実行したところ以下のエラーが表示されたのですがどうしたらよいのでしょうか
Caused by: java.lang.ClassNotFoundException: net.java.games.util.plugins.Plugins
at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

net.java.games.util.plugins.Pluginsは、Jutilsというライブラリーに含まれているクラスで、jinputJutilsに依存しているために発生しているエラーです。
jinputを使用するには、他にもnativeコードが含まれるJarが必要になります。

こういう問題を避けるためには、MavenとかGradleを使った方が良いですよ。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/06/25 09:34

    Gradleというのが分からなくて調べたところビルドツールであるとわかりました.
    私はeclipseを使用しているのでgradleプロジェクトを作成してそのプロジェクトでjinputを用いたプロジェクトを作成していけばよいということでよろしいのでしょうか?

    キャンセル

  • 2016/06/25 09:42

    そうですね。
    > gradleプロジェクトを作成して...
    で良いです。

    Gradleプロジェクトという言葉が出てくるということは、きっとEclipseはおそらくAll-In-Oneをお使いですね?
    だとしたらMavenもGradleも使える環境になっていると思いますので、いずれか好きな方でプロジェクトを作っていくのが早いと思います。
    今から始めるならGradleの方がおすすめです。

    キャンセル

  • 2016/06/27 15:07

    Gradleプロジェクトで実行したらエラーはなくなりました
    ありがとうございました
    新たな問題点が発生しましたのでそちらの方にも回答していただければ幸いです

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.21%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る