質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.40%

  • Ruby on Rails

    7919questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

rvmを削除して、rbenvを再インストールしたらrails serverが動かなくなってしまいました。

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 839

yoshi9n4

score 1

プログラミング初心者です。
rails tutorialを進めており、初期の段階でrvmをいれてrubyのバージョン管理をしていたのですが、rvmを削除したらterminalでrails serverのコマンドが使えなくなってしまいました。

混乱してしまったので、rvenbも下記のコマンドを使い再インストールしました。
コレがいけなかったのでしょうか?
ご教授いただけたら幸いです。
お願い致します。

% rm -rf ~/.rbenv
% rm -rf /usr/local/bin/rbenv
% rm -rf /usr/local/Cellar/rbenv

以下が私のGemfileの設定です。

source 'https://rubygems.org'

gem 'rails',                '4.2.2'
gem 'bootstrap-sass',       '3.2.0.0'
gem 'bcrypt',               '3.1.7'
gem 'sass-rails',   '5.0.2'
gem 'uglifier',     '2.5.3'
gem 'coffee-rails', '4.1.0'
gem 'jquery-rails', '4.0.3'
gem 'turbolinks',   '2.3.0'
gem 'jbuilder',     '2.2.3'
gem 'sdoc',         '0.4.0', group: :doc

group :development, :test do
  gem 'sqlite3',     '1.3.9'
  gem 'byebug',      '3.4.0'
  gem 'web-console', '2.0.0.beta3'
  gem 'spring',      '1.1.3'
  gem 'minitest-reporters'
end

group :production do
  gem 'pg',             '0.17.1'
  gem 'rails_12factor', '0.0.2'
  gem 'puma',           '2.11.1'
end

エラーメッセージが下記になります。

Fetching gem metadata from https://rubygems.org/
Fetching version metadata from https://rubygems.org/
Fetching dependency metadata from https://rubygems.org/
Using rake 11.2.2
Using i18n 0.7.0
Using json 1.8.3
Using minitest 5.9.0
Using thread_safe 0.3.5
Using builder 3.2.2
Using erubis 2.7.0
Using mini_portile2 2.1.0
Using pkg-config 1.1.7
Using rack 1.6.4
Using mime-types-data 3.2016.0521
Using arel 6.0.3
Using ansi 1.5.0
Using bcrypt 3.1.7
Using debug_inspector 0.0.2
Using sass 3.4.22
Using columnize 0.9.0
Using debugger-linecache 1.2.0
Using slop 3.6.0
Using coffee-script-source 1.10.0
Using execjs 2.7.0
Using thor 0.19.1
Using concurrent-ruby 1.0.2
Using multi_json 1.12.1
Using ruby-progressbar 1.8.1


Your user account isn't allowed to install to the system Rubygems.
  You can cancel this installation and run:

      bundle install --path vendor/bundle

  to install the gems into ./vendor/bundle/, or you can enter your password
  and install the bundled gems to Rubygems using sudo.

  Password: 
Installing pg 0.17.1 with native extensions

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /private/var/folders/zy/jy2_1r6n7g105mvl7q53z3wr0000gn/T/bundler20160620-84021-15rbwonpg-0.17.1/gems/pg-0.17.1/ext
/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby -r ./siteconf20160620-84021-dhbkom.rb extconf.rb --with-pg-config=/usr/pgsql-9.3/bin/pg_config
Using config values from /usr/pgsql-9.3/bin/pg_config
sh: /usr/pgsql-9.3/bin/pg_config: No such file or directory
sh: /usr/pgsql-9.3/bin/pg_config: No such file or directory
checking for libpq-fe.h... yes
checking for libpq/libpq-fs.h... yes
checking for pg_config_manual.h... yes
checking for PQconnectdb() in -lpq... no
checking for PQconnectdb() in -llibpq... no
checking for PQconnectdb() in -lms/libpq... no
Can't find the PostgreSQL client library (libpq)
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby
    --with-pg
    --without-pg
    --with-pg-config
    --with-pg-dir
    --without-pg-dir
    --with-pg-include
    --without-pg-include=${pg-dir}/include
    --with-pg-lib
    --without-pg-lib=${pg-dir}/
    --with-pqlib
    --without-pqlib
    --with-libpqlib
    --without-libpqlib
    --with-ms/libpqlib
    --without-ms/libpqlib

To see why this extension failed to compile, please check the mkmf.log which can be found here:

  /var/folders/zy/jy2_1r6n7g105mvl7q53z3wr0000gn/T/bundler20160620-84021-15rbwonpg-0.17.1/extensions/universal-darwin-15/2.0.0/pg-0.17.1/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in /var/folders/zy/jy2_1r6n7g105mvl7q53z3wr0000gn/T/bundler20160620-84021-15rbwonpg-0.17.1/gems/pg-0.17.1 for inspection.
Results logged to /var/folders/zy/jy2_1r6n7g105mvl7q53z3wr0000gn/T/bundler20160620-84021-15rbwonpg-0.17.1/extensions/universal-darwin-15/2.0.0/pg-0.17.1/gem_make.out
Using bundler 1.12.5
Using rails_serve_static_assets 0.0.5
Using rails_stdout_logging 0.0.5
Using tilt 1.4.1
Using spring 1.1.3
Using sqlite3 1.3.9
Using rdoc 4.2.2
Using tzinfo 1.2.2
Using nokogiri 1.6.8
Using rack-test 0.6.3
Installing puma 2.11.1 with native extensions

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /private/var/folders/zy/jy2_1r6n7g105mvl7q53z3wr0000gn/T/bundler20160620-84021-rtr08jpuma-2.11.1/gems/puma-2.11.1/ext/puma_http11
/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby -r ./siteconf20160620-84021-al1bw0.rb extconf.rb
checking for BIO_read() in -lcrypto... yes
checking for SSL_CTX_new() in -lssl... yes
creating Makefile

To see why this extension failed to compile, please check the mkmf.log which can be found here:

  /var/folders/zy/jy2_1r6n7g105mvl7q53z3wr0000gn/T/bundler20160620-84021-rtr08jpuma-2.11.1/extensions/universal-darwin-15/2.0.0/puma-2.11.1/mkmf.log

current directory: /private/var/folders/zy/jy2_1r6n7g105mvl7q53z3wr0000gn/T/bundler20160620-84021-rtr08jpuma-2.11.1/gems/puma-2.11.1/ext/puma_http11
make "DESTDIR=" clean

current directory: /private/var/folders/zy/jy2_1r6n7g105mvl7q53z3wr0000gn/T/bundler20160620-84021-rtr08jpuma-2.11.1/gems/puma-2.11.1/ext/puma_http11
make "DESTDIR="
compiling http11_parser.c
compiling io_buffer.c
io_buffer.c:119:21: warning: passing 'uint8_t *' (aka 'unsigned char *') to parameter of type 'const char *' converts between pointers to integer types with different sign [-Wpointer-sign]
  return rb_str_new(b->top, b->cur - b->top);
                    ^~~~~~
/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/include/ruby-2.0.0/ruby/intern.h:674:29: note: passing argument to parameter here
VALUE rb_str_new(const char*, long);
                            ^
1 warning generated.
io_buffer.c:119:21: warning: passing 'uint8_t *' (aka 'unsigned char *') to parameter of type 'const char *' converts between pointers to integer types with different sign [-Wpointer-sign]
  return rb_str_new(b->top, b->cur - b->top);
                    ^~~~~~
/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/include/ruby-2.0.0/ruby/intern.h:674:29: note: passing argument to parameter here
VALUE rb_str_new(const char*, long);
                            ^
1 warning generated.
compiling mini_ssl.c
In file included from mini_ssl.c:3:
/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/include/ruby-2.0.0/ruby/backward/rubyio.h:2:2: warning: use "ruby/io.h" instead of "rubyio.h" [-W#warnings]
#warning use "ruby/io.h" instead of "rubyio.h"
 ^
mini_ssl.c:4:10: fatal error: 'openssl/bio.h' file not found
#include <openssl/bio.h>
         ^
1 warning and 1 error generated.
make: *** [mini_ssl.o] Error 1

make failed, exit code 2

Gem files will remain installed in /var/folders/zy/jy2_1r6n7g105mvl7q53z3wr0000gn/T/bundler20160620-84021-rtr08jpuma-2.11.1/gems/puma-2.11.1 for inspection.
Results logged to /var/folders/zy/jy2_1r6n7g105mvl7q53z3wr0000gn/T/bundler20160620-84021-rtr08jpuma-2.11.1/extensions/universal-darwin-15/2.0.0/puma-2.11.1/gem_make.out
Using mime-types 3.1
Using binding_of_caller 0.7.3.pre1
Using bootstrap-sass 3.2.0.0
Using byebug 3.4.0
Using coffee-script 2.4.1
Using uglifier 2.5.3
Using sprockets 3.6.1
Using minitest-reporters 1.1.9
An error occurred while installing pg (0.17.1), and Bundler cannot continue.
Make sure that `gem install pg -v '0.17.1'` succeeds before bundling.
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

まずは、エラーメッセージをチェックしましょう。

checking for PQconnectdb() in -lpq... no
checking for PQconnectdb() in -llibpq... no
checking for PQconnectdb() in -lms/libpq... no
Can't find the PostgreSQL client library (libpq)

と エラーがでているので、PostgreSQL のライブラリが、見つからないようです。

その次の行に「You may need configuration options.」と言われているので、オプションで、必要なファイルの位置を指定してください。

Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby
    --with-pg
    --without-pg
    --with-pg-config
    --with-pg-dir
    --without-pg-dir
    --with-pg-include
    --without-pg-include=${pg-dir}/include
    --with-pg-lib
    --without-pg-lib=${pg-dir}/
    --with-pqlib
    --without-pqlib
    --with-libpqlib
    --without-libpqlib
    --with-ms/libpqlib
    --without-ms/libpqlib

あと、システムの ruby が、使われているようですが、使用する予定なのは、この ruby で正しいですか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/06/20 21:26

    迅速な回答ありがとうございます。

    PostgresSQLのライブラリをオプションで指定するということでしょうか(??)

    $ rbenv versions
    system
    * 2.0.0-p648 (set by /Users/myname/.rbenv/version)
    で一応インストールしたrubyを指定したつもりなんですが、systemのrubyになってしまっていますね・・・。もう一度設定してみます!

    キャンセル

  • 2016/06/20 21:38 編集

    gem install pg --with-pg-config=pg_configのパス

    という感じで、gem コマンドでインストールします。

    キャンセル

同じタグがついた質問を見る

  • Ruby on Rails

    7919questions

    Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。