質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.34%

cocoapods ld: file not found: /Pods/GoogleUtilities/Libraries/libGTM_NSData+zlib.a

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,881

dondoko_susumu

score 11

前提・実現したいこと

cocoapodsでGoogle/Analyticsをインストールしたが
Xcodeでビルドエラーになる
原因と解決方法を知りたい。

発生している問題・エラーメッセージ

pod install後、.xcworkspaceファイルで開いてBuildするとビルドエラーとなる

ld: file not found: /SamplePods/Pods/GoogleUtilities/Libraries/libGTM_NSData+zlib.a
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Podfile

platform :ios, '8.0'
use_frameworks!

target 'SamplePods' do
  pod 'Google/Analytics', '~> 1.3.2'
end

試したこと

  • pod install
    pod repo remove master
    pod setup
    pod install
  • cocoapodsのバージョンUP(1.0.1)
  • Manage SchemeからPodsプロジェクトのShareにチェックを入れてClean → Build
  • Edit Schemes > BuildからPodsプロジェクトを追加してClean → Build

補足情報(言語/FW/ツール等のバージョンなど)

Xcode 7.3.1
OS X 10.11.5 (El Capitan)
cocoapods 0.39

※暫定の回避方法
Pods-SamplePods.debug.xcconfigファイルのOTHER_LDFLAGSの下記1行を手動で削除すると一応、ビルドは成功する。
再度pod installすると、また下記1行が生成されるので、根本的な解決ではない。

-force_load $(PODS_ROOT)/GoogleUtilities/Libraries/libGTM_NSData+zlib.a
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

check解決した方法

+1

fuzzballさんのおっしゃられてたようにGoogle/Analyticsでinstallすると、GoogleAnalytics以外のライブラリがインストールされるのですが、その中のGoogleUtilitiesのバージョン1.3.1がインストールされると、ビルドエラーが起きることがわかりました。(GoogleのCocoaPodsのバグ?)

GoogleUtilitiesのバージョンを1.1.0固定でインストールするようにPodfileを書き換えてpod installすればビルド成功するようになりました。

platform :ios, '8.0'
use_frameworks!

target 'SamplePods' do
  pod 'Google/Analytics', '~> 1.3.2'
  pod 'GoogleUtilities', '1.1.0'
end

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

Google/Analyticsでinstallすると、GoogleAnalytics以外にも下記のライブラリがインストールされるようですが、全て必要なのでしょうか?

Google (1.3.2)
GoogleInterchangeUtilities (1.2.1)
GoogleNetworkingUtilities (1.2.1)
GoogleSymbolUtilities (1.1.1)
GoogleUtilities (1.3.1)

GoogleAnalyticsだけでいいのならGoogleAnalyticsでインストールして下さい。

platform :ios, '8.0'
use_frameworks!

target 'SamplePods' do
  pod 'GoogleAnalytics', '~> 3.14'
end

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.34%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る