質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.96%

gulp-pleeeaseがうまくインストールできません。

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,797
退会済みユーザー

退会済みユーザー

gulp-pleeeaseがうまくインストールできません。
postcss、cssnextはできました。
これらは別ファイルにしないといけないのでしょうか?

・npm install --save-dev gulp-pleeease

C:\Users\usr\Desktop\images\gulp-folder\postcss>npm install --save-dev gulp-pleeease
npm WARN deprecated graceful-fs@3.0.8: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use 'npm ls graceful-fs' to find it in the tree.
npm WARN deprecated npmconf@2.1.2: this package has been reintegrated into npm and is now out of date with respect to npm
npm WARN deprecated cross-spawn-async@2.2.4: cross-spawn no longer requires a build toolchain, use it instead!
npm WARN prefer global node-gyp@3.3.1 should be installed with -g

> node-sass@3.4.2 install C:\Users\usr\Desktop\images\gulp-folder\postcss\node_modules\node-sass
> node scripts/install.js

Cannot download "https://github.com/sass/node-sass/releases/download/v3.4.2/win32-x64-48_binding.node":

HTTP error 404 Not Found

Hint: If github.com is not accessible in your location
      try setting a proxy via HTTP_PROXY, e.g.

      export HTTP_PROXY=http://example.com:1234

or configure npm proxy via

      npm config set proxy http://example.com:8080

> spawn-sync@1.0.15 postinstall C:\Users\usr\Desktop\images\gulp-folder\postcss\node_modules\spawn-sync
> node postinstall


> node-sass@3.4.2 postinstall C:\Users\usr\Desktop\images\gulp-folder\postcss\node_modules\node-sass
> node scripts/build.js

〜

・gulpfile.js

//gulpfile.js
var gulp = require('gulp');              //gulpをインポート
var postcss = require('gulp-postcss');   //gulp-postcssをインポート
var cssnext = require('postcss-cssnext'); //cssnextをインポート
var plumber = require('gulp-plumber');
var pleeease = require('gulp-pleeease');

gulp.task('css', function () {
           //”css”タスクを登録
  var plugins = [  
  cssnext                      //一旦空の配列を作成
  ];
  return gulp.src('./src/*.css')         //src下にある.cssファイルを指定
    .pipe(postcss(plugins))              //PostCSSにファイルを処理してもらう
    .pipe(gulp.dest('./dest'))         //生成されたCSSをdest下に配置
    .pipe(plumber())
    .pipe(pleeease({
      autoprefixer:true,
      minifier: true,
      mqpacker: true
    }));
});

・gulp cssコマンドでgulpfile.jsを実行すると下記のようになります。

C:\Users\usr\Desktop\images\gulp-folder\postcss>gulp css
(node:6348) fs: re-evaluating native module sources is not supported. If you are using the graceful-fs module, please update it to a more recent version.
module.js:442
    throw err;
    ^

Error: Cannot find module 'gulp-pleeease'
    at Function.Module._resolveFilename (module.js:440:15)
    at Function.Module._load (module.js:388:25)
    at Module.require (module.js:468:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (C:\Users\usr\Desktop\images\gulp-folder\postcss\gulpfile.js:6:16)
    at Module._compile (module.js:541:32)
    at Object.Module._extensions..js (module.js:550:10)
    at Module.load (module.js:458:32)
    at tryModuleLoad (module.js:417:12)
    at Function.Module._load (module.js:409:3)
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

先ほど同じ内容でハマりました。
以下によると、node.jsのバージョンを4.4.4にすると解決するということなので試してみたところ
うまくインストールできました。

https://forum.ionicframework.com/t/cant-install-ionic-on-windows/51763

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/06/19 14:02

    そんな理由だったのですね。gulpもnodeも常に最新版が良いのですね。

    キャンセル

  • 2016/06/19 14:04

    node -v
    v6.2.0

    なのですが新しすぎるということでしょうか?

    キャンセル

  • 2016/06/19 15:56

    以下の情報によると、gulp-pleeeaseが依存関係で一緒にインストールしようとするnode-sassのバージョンがv3.4.2なのですが、node.jsが6以上だと、最低でもnode-sassのバージョンが3.7.0以上必要なのでインストールできないという事のようです。

    https://github.com/sass/node-sass/issues/1559

    このようなこともあるので、必ずしも最新版にしなくてはいけないというわけではなく
    依存関係などに注意しながらバージョンを選択する必要があるでしょう。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.96%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる