質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.63%

環境構築:eclipseでmysqlが使えない。(ruby on Rails)

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,086

oshiaki

score 15

毎度お世話になっております。

ruby on Railsをeclipse(mars)であつかっております。
今までSQLをsqliteに設定していたのですが今回はmySQLに設定します。

mysqlは有償ということで体験版をインストールしました。

eclipseの新規作成からrailsプロジェクトを選択すると、
webで調べた情報では

イメージ説明

という画面が出てmysqlを選択すればよいということでしたが、、、
私が使用しているeclipseは

イメージ説明

が出てきてmysqlを使用できません。

eclipse marsでは使用できないのでしょうか。
それとも別の操作が必要なのでしょうか。

IDEを使用しない状況、他のIDE(rubymine)では使用できることは確認いたしました。
ご教授よろしくお願いします。

~~~追加~~~
webで調べた情報ではradrailsを導入しておりましたが私が使用しているのはaptanaです。
radrailsをインストールしようとしましたがaptanaをアンインストールしなければなりません。
そしてエラー
1 つ以上の必須項目が見つからないため、インストールを完了できません。
Software currently installed: org.radrails.rails-feature 0.7.2 (org.radrails.rails_feature.feature.group 0.7.2)
Missing requirement: Rails Core Plug-in 0.7.2 (org.radrails.rails.core 0.7.2) requires 'bundle org.eclipse.update.core 0.0.0' but it could not be found
Cannot satisfy dependency:
From: org.radrails.rails-feature 0.7.2 (org.radrails.rails_feature.feature.group 0.7.2)
To: org.radrails.rails.core [0.7.2]
というものがでます。
解決方法を教えてください。

またaptanaでできる方法があればベストです。
すいません。よろしくお願いします。

~~~さらに追加~~~
力技になりますが
コマンドプロンプトで作ったmysqlのrailsシステムを
インポート・新規プロジェクトとして既存のフォルダーを使用で無理やりeclipseで使用できるようにはなりました。

もっとスマートに使用できないものでしょうか。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • matobaa

    2016/05/25 13:55

    Eclipse Mars をパッケージでインストールした場合、プラグインを入れなければ Rails を直接は使えないので、何らかのEclipseプラグインを導入しているはずです。
    調査したWebページがどこだかはわかりませんが、画面キャプチャを見る限り、別種のRailsプラグインを使っているように思えます。

    調査したWebページがどこか、そしてoshiakiさんが使っているEclipseにはどんなプラグインを入れたのかがわかれば、もうちょっとわかるかもしれません。

    キャンセル

  • oshiaki

    2016/05/25 14:02

    早いお答えありがとうございます。
    私はAptana Studio 3 Pluginを導入しております。調査したwebではradrailsでした。

    キャンセル

  • oshiaki

    2016/05/25 14:19

    radrailsをインストールしてみます。

    キャンセル

回答 1

0

すいません。
さらに追加というところで記入した方法でとりあえず進めます。
ご覧になってくださった方々ありがとうございました。

今後ともよろしくお願いします。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.63%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる