質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.61%

Vs CodeのバージョンとIDLEのpythonのバージョンを合わせたい

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 167

score 13

Vs CodeのバージョンとIDLEのpythonのバージョンが違うので統一したいのですがどのようにしたら良いでしょうか?

同じにしたい理由としてはpipでライブラリをインストールしてもIDLEを使用する時に以下のようなコマンドを叩いてIDLEのパスに再度インストールしているので二度手間になっております。

python IDLEフルパス -m pip install ライブラリ名

どのようにしたらバージョンを統一してインストールを1回で済ませることができますでしょうか。
普通はインストールは一回で済む認識ですが、もしこのように2回インストールするのが普通であればその理由も教えていただきまいです。

VS Codeの左下に以前は出ていたのですがpythonのバージョンは出ておりません。最近、VS Codeをアップデートしたのが原因かもしれません。
ターミナルでpythonのバージョンを確認すると3.8.5でしたが以前、アップデートしているので3.9~以降のものがインストールされていたと思いますが何故か3.8.5に戻ってました。IDLEのバージョンは3.9.2です。
sys.executableでVS Code上のパスを確認したら/Users/ユーザー名/opt/anaconda3/bin/python3となっていてアナコンダになっておりました。(以前は最新のpythonのバージョンを指定しておりました)
VS Codeのコマンドパレットでinterpreterでバージョン指定しよとしたのですが何故かinterpreterが出てきませんでした。

元々はIDLEのバージョンとVS COdeのバージョンを統一してライブラリのインストールを1回で済ませたいというのが目的でしたが、何故かVS Code上ではアナコンダが使用されているという疑問も出てきました。この件に関しては現状は問題はないのですがVs Codeのinterpreterや設定のpython.pythonPathの検索結果が表示されなくなっている(VS Codeのアップデートで仕様が変わった?)は後で困るかなとも思いました。

あまり関係ないかもしれませんがVS codeのバージョンは1.57.1でM1Macbook Proを仕様しております。Activity Monitorで見るとVS Codeはinterで動いているようです。

よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • yakitorii

    2021/07/08 13:49

    VSCodeのターミナルでインストールしてもIDLEで再度インストールしないといけない、ということでしょうか?
    IDLEで使っているpythonはどうやってインストールしましたか?

    キャンセル

  • asianLad

    2021/07/08 13:54

    ご回答ありがとうございます。
    VSCodeのターミナルでインストールしてもIDLEで再度インストールしないといけない、ということでしょうか?
    →はい、左様でございます。ターミナルでpythonのバージョンを確認すると3.8.5でしたが以前、アップデートしているので3.9~以降のものがインストールされていたと思いますが何故か3.8.5に戻ってました。IDLEは3.9.2です。
    sys.executableでVS Code上のパスを確認したら/Users/ユーザー名/opt/anaconda3/bin/python3となっていてアナコンダになっておりました。コマンドパレットでinterpreterでバージョン指定しよとしたのですが何故かinterpreterが出てきませんでした。
    IDLEで使っているpythonはどうやってインストールしましたか?
    →だいぶ前なので覚えていないですが、公式のインストーラーでしたと思います。
    よろしくお願いします

    キャンセル

  • yakitorii

    2021/07/08 17:28

    > コマンドパレットでinterpreterでバージョン指定しよとしたのですが何故かinterpreterが出てきませんでした。

    pythonの拡張機能が削除されている可能性があるのでインストールされているか確認してみてください。

    また今回はターミナルの問題なのでVSCodeにIDLEのpythonを設定しても意味がない気がしますが。。

    キャンセル

  • asianLad

    2021/07/08 17:55

    ご回答ありがとうございます。
    Extensionで確認しましたがpythonの拡張機能は問題なくインストールされているようです。
    他に考えられる原因はありますでしょうか。

    キャンセル

回答 1

-3

VSCodeでpythonファイルを開いて、画面の左下にpythonのバージョンが表示されてませんか。
こいつをクリックしたらpythonの選択表示が出てきますんで、それをお望みのものに変更してやればいいかと

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2021/07/08 13:50

    pythonのバージョンは出ていません。前は出ていたのですがVS Codeをアップデートしたのが原因かもしれません。
    ターミナルでバージョンを確認すると3.8.5でしたがアップデートしているので3.9~以降のものがインストールされていたと思いますが戻ってました。IDLEは3.9.2です。
    VS Code上でパスを確認したら/Users/ユーザー名/opt/anaconda3/bin/python3となっていてアナコンダになっておりました。コマンドパレットでinterpreterでバージョン指定しよとしたのですが何故か出てきませんでした。

    キャンセル

  • 2021/07/08 13:51

    @asianLad
    こちらの情報を質問にも追記していただけますか?

    キャンセル

  • 2021/07/08 14:02 編集

    なら、コマンドパレットを選択して、その中の python:インタプリタを選択、を選んでみてください
    そこで出てこないなら、お望みのpythonのパスを入れてやればいいかと

    キャンセル

  • 2021/07/08 14:11

    コマンドパッレットでpythonと打つと結果が何も出ない状況です。パスを直接入れても何も起きませんでした。M1macbookでVs Codeは1.57.1を使用しております。interのコアで動いているのと何か関係があったりましすかね。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.61%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る