質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.49%

  • Linux

    3889questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

  • Amazon EC2

    129questions

    Amazon EC2は“Amazon Elastic Compute Cloud”の略称です。Amazon Web Services(AWS)の一部であり、仮想化されたWebサーバーのコンピュータリソースをレンタルできるサービスです。

F-secure Linuxセキュリティの依存関係が解決できずインストール出来ない

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,349

yu_1985

score 10

Amazon Linuxのデフォルトインスタンス上にF SecureのLinuxセキュリティをインストールしようとしています。

https://www.f-secure.com/ja_JP/web/business_jp/downloads/linux-security/latest

バージョンは11.00
上記サイトからダウンロードしたgzファイルをサーバ上で解凍し、
fsls-11.00.79-rtm
を実行したところ、/opt/f-secure/fsav/install.logに下記のような依存関係のエラーが出てしまい、インストールに失敗してしまいます。
※最下部にあるのは恐らく依存関係のエラーではありませんが…。

以下抜粋です。

error: Failed dependencies:
    libc.so.6 is needed by f-secure-automatic-update-agent-8.36.72-1.i386
    libc.so.6(GLIBC_2.0) is needed by f-secure-automatic-update-agent-8.36.72-1.i386
    libc.so.6(GLIBC_2.1) is needed by f-secure-automatic-update-agent-8.36.72-1.i386
    libc.so.6(GLIBC_2.1.3) is needed by f-secure-automatic-update-agent-8.36.72-1.i386
    libc.so.6(GLIBC_2.2) is needed by f-secure-automatic-update-agent-8.36.72-1.i386
    libc.so.6(GLIBC_2.3) is needed by f-secure-automatic-update-agent-8.36.72-1.i386
    libdl.so.2 is needed by f-secure-automatic-update-agent-8.36.72-1.i386
    libdl.so.2(GLIBC_2.0) is needed by f-secure-automatic-update-agent-8.36.72-1.i386
    libdl.so.2(GLIBC_2.1) is needed by f-secure-automatic-update-agent-8.36.72-1.i386
    libpthread.so.0 is needed by f-secure-automatic-update-agent-8.36.72-1.i386
    libpthread.so.0(GLIBC_2.0) is needed by f-secure-automatic-update-agent-8.36.72-1.i386
    libpthread.so.0(GLIBC_2.1) is needed by f-secure-automatic-update-agent-8.36.72-1.i386
    libc.so.6 is needed by f-secure-management-agent-unix-4.77.1345-1.i386
    libc.so.6(GLIBC_2.0) is needed by f-secure-management-agent-unix-4.77.1345-1.i386
    libc.so.6(GLIBC_2.1) is needed by f-secure-management-agent-unix-4.77.1345-1.i386
    libc.so.6(GLIBC_2.1.3) is needed by f-secure-management-agent-unix-4.77.1345-1.i386
    libc.so.6(GLIBC_2.3) is needed by f-secure-management-agent-unix-4.77.1345-1.i386
    libpthread.so.0 is needed by f-secure-management-agent-unix-4.77.1345-1.i386
    libpthread.so.0(GLIBC_2.0) is needed by f-secure-management-agent-unix-4.77.1345-1.i386
    libpthread.so.0(GLIBC_2.1) is needed by f-secure-management-agent-unix-4.77.1345-1.i386
rm: missing operand
Try 'rm --help' for more information.

glibcはデフォルトでインストールされており、上記ライブラリも存在するように思えるのですが、上記を解消してインストールを完了させるにはどうすればよろしいか、どなたかご教示いただけますでしょうか。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

RPM が i386 のようですので、glibc.i686 を追加でインストールすればいいのではないでしょうか。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/05/11 18:08

    仰るようにglibc.i686をインストールしたら依存関係の問題は解決しました。
    助かりました。ありがとうございます!

    キャンセル

関連した質問

  • 解決済

    共有ライブラリのバージョン依存問題を解決したい

    Qtをソースからビルドしてみたところ、Qtの共有ライブラリが下のような状態になっていて、Qtアプリが起動しませんでした。 root@beaglebone:/tmp# ldd /o

  • 解決済

    /varの容量が事前に増えないようにする対策

    /dev/sda1     ext4     8.1G   4.6G   3.1G  60% / rootしかパティーション切ってないサーバが30台があります。(esx

  • 解決済

    「Debian系」nginxのインストール方法

    お世話になっております。Ezです。 この度、Debian系のOSを初めていじることとなり、色々と苦戦しております。 よろしければお力を貸して頂けないでしょうか? # apt-g

  • 解決済

    linuxでのGUIアプリについて

    linux上でJavaで作ったGUIアプリケーションを起動することは出来るでしょうか サーバはVPSサーバ、PCはMACです。 接続にはターミナルからsshで接続します。

  • 解決済

    vi?それともvim

    今linuxにviが入っていますが、vimというものもあり、どちらをおすすめしますか?  vimとうったら下のパッケージがでてきました。 できればおすすめのパッケージも教えてい

  • 解決済

    opensslの脆弱性対応(CVE-2016-2105~CVE-2016-2109)について

    初めてこのサイトを利用させていただきます。 初歩的な内容となり申し訳ありません。 opensslの脆弱性対応(CVE-2016-2105~CVE-2016-2109)につい

  • 解決済

    【LINUX】lsofコマンドについて

    /use/sbin/lsof -i TCP -n -P を実行して出てくるDEVICE項目は何を表しているのか教えてください。 現在APサーバのメモリが上昇しており、それに

  • 解決済

    Linuxの共有グループ設定

    Linuxマシンを3人で共有しており、以下のようにPermissionを設定したいと思っています。 Linuxでのファイル共有をしたことがないので、基本的なことかもしれませんがやり

同じタグがついた質問を見る

  • Linux

    3889questions

    Linuxは、Unixをベースにして開発されたオペレーティングシステムです。日本では「リナックス」と呼ばれています。 主にWebサーバやDNSサーバ、イントラネットなどのサーバ用OSとして利用されています。 上位500のスーパーコンピュータの90%以上はLinuxを使用しています。 携帯端末用のプラットフォームAndroidは、Linuxカーネル上に構築されています。

  • Amazon EC2

    129questions

    Amazon EC2は“Amazon Elastic Compute Cloud”の略称です。Amazon Web Services(AWS)の一部であり、仮想化されたWebサーバーのコンピュータリソースをレンタルできるサービスです。