質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
Ruby

Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

RubyGems

RubyGemsはRubyによるプログラミングのためのパッケージマネジメントツールです。ユーザはこれを使用することで、Rubyライブラリのダウンロードやアップデートや、依存関係の自動解決が可能になります。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

受付中

gem install コマンドでのSSL認証エラーを解決したい

itis_no_matter
itis_no_matter

総合スコア0

Ruby

Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

RubyGems

RubyGemsはRubyによるプログラミングのためのパッケージマネジメントツールです。ユーザはこれを使用することで、Rubyライブラリのダウンロードやアップデートや、依存関係の自動解決が可能になります。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

1回答

0評価

0クリップ

1294閲覧

投稿2021/06/04 04:45

前提・実現したいこと

unixで、gem installコマンドが通るようにしたい

発生している問題・エラーメッセージ

unix

% gem install rails ERROR: SSL verification error at depth 0: ok (0) ERROR: SSL verification error at depth 0: ok (0) ERROR: SSL verification error at depth 0: ok (0) ERROR: Could not find a valid gem 'rails' (>= 0), here is why: Unable to download data from https://rubygems.org/ - SSL_connect returned=1 errno=0 state=error: certificate verify failed (certificate rejected) (https://rubygems.org/specs.4.8.gz) ERROR: SSL verification error at depth 0: ok (0) ERROR: SSL verification error at depth 0: ok (0)

試したこと

rubyやgemの入れ直しはやりましたが効果なし。

こちらを参考に自動SSLチェックを行ったところ、以下のように言われました

curl -Lks 'https://git.io/rg-ssl' | ruby Here's your Ruby and OpenSSL environment: Ruby: 2.7.2p137 (2020-10-01 revision 5445e0435260b449decf2ac16f9d09bae3cafe72) [x86_64-darwin19] RubyGems: 3.1.4 Bundler: 2.1.4 Compiled with: OpenSSL 1.1.1k 25 Mar 2021 Loaded version: OpenSSL 1.1.1k 25 Mar 2021 SSL_CERT_FILE: /Users/myname/.rbenv/versions/2.7.2/openssl/ssl/cert.pem SSL_CERT_DIR: /Users/myname/.rbenv/versions/2.7.2/openssl/ssl/certs With that out of the way, let's see if you can connect to rubygems.org... Bundler connection to rubygems.org: failed ❌ (certificate verification) ERROR: SSL verification error at depth 0: ok (0) RubyGems connection to rubygems.org: failed ❌ (certificate verification) Ruby net/http connection to rubygems.org: failed ❌ Unfortunately, this Ruby can't connect to rubygems.org. ???? Your Ruby can't connect to rubygems.org because you are missing the certificate files OpenSSL needs to verify you are connecting to the genuine rubygems.org servers.

そのまま上記サイトのCA証明書の更新を行いましたが、gem installコマンドを叩くと依然上記のエラーが出ます。

Chromeでもhttps://rubygems.orgにアクセスできず、プライバシー面で怒られます。
chromeに怒られている様子
developerツールでセキュリティ周りを確認したところ、SSL証明書が悪いようなのですが、
view certificateをクリックすると「この証明書は有効です」と表示されます。
証明書が良いか悪いのかよくわからない様子
この方と同じ症状だと思うのですが、証明書の配置を変える方法がわかりませんでした。

補足情報(FW/ツールのバージョンなど)

MacOS catalinaです。

gem --version 3.1.4
ruby --version ruby 2.7.2p137 (2020-10-01 revision 5445e04352) [x86_64-darwin19]

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Ruby

Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

RubyGems

RubyGemsはRubyによるプログラミングのためのパッケージマネジメントツールです。ユーザはこれを使用することで、Rubyライブラリのダウンロードやアップデートや、依存関係の自動解決が可能になります。

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。