質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.92%

CentOS7 にbrewをインストールする方法を教えてください

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 199

score 7

以下のドキュメントに沿ってlinuxbrewをインストールしたいのですがエラーが出て進むことができません。
原因がわかる方、ご教授いただけないでしょうか?

https://hacknote.jp/archives/54176/
https://github.com/Homebrew/brew/blob/master/docs/Homebrew-on-Linux.md
https://brew.sh/

そもそもbrewはPHP7.4を入れるためにインストールしたいです。

環境

さくらのvps
CentOS Linux release 7.9.2009 (Core)

試したこと

//homebrewをインストールするのに必要なものをインストール
$ sudo yum groupinstall 'Development Tools' && sudo yum install curl file git

読み込んだプラグイン:aliases, changelog, fastestmirror, kabi, langpacks, tmprepo, verify, versionlock
Loading support for Red Hat kernel ABI
Loading mirror speeds from cached hostfile
 * base: mirrors.cat.net
 * epel: ftp.jaist.ac.jp
 * extras: mirrors.cat.net
 * remi-safe: ftp.riken.jp
 * updates: mirrors.cat.net
Maybe run: yum groups mark install (see man yum)
インストールまたは更新に利用できるいくつかの要求されたグループにパッケージがありません
読み込んだプラグイン:aliases, changelog, fastestmirror, kabi, langpacks, tmprepo, verify, versionlock
Loading support for Red Hat kernel ABI
Loading mirror speeds from cached hostfile
 * base: mirrors.cat.net
 * epel: ftp.jaist.ac.jp
 * extras: mirrors.cat.net
 * remi-safe: ftp.riken.jp
 * updates: mirrors.cat.net
パッケージ curl-7.76.1-2.0.cf.rhel7.x86_64 はインストール済みか最新バージョンです
パッケージ file-5.11-37.el7.x86_64 はインストール済みか最新バージョンです
パッケージ git-1.8.3.1-23.el7_8.x86_64 はインストール済みか最新バージョンです
何もしません
//homebrewのインストール
$ sh -c "$(curl -fsSL https://raw.githubusercontent.com/Linuxbrew/install/master/install.sh)"

curl: ??l?: ELF: x: Error 1644151959
-bash: $: コマンドが見つかりません


のようになります。

そもそもhomebrewのインストールをしようと上記のコマンドを実行した際に

https://k-kuro.hatenadiary.jp/entry/20201210/1607573212
のように

Error: Please update your system cURL.
Minimum required version: 7.41.0
Your cURL version: 7.29.0
Your cURL executable: /usr/bin/curl
Error: Please update your system Git.
Minimum required version: 2.7.0
Your Git version: 1.8.3.1
Your Git executable: /usr/bin/git
Error: Curl must be installed and in your PATH!


↑エラーが出ていたため、

$ sudo yum install epel-release
$ sudo yum install libnghttp2

$ sudo nano /etc/yum.repos.d/city-fan.repo
$sudo yum clean all
$ sudo yum install curl 


↑を実行しました。

そこで、curlのバージョンを見ようとすると、こちらも意味不明なエラーが出ています。
(おそらくその他にもコマンドを実行したため、こうなったんだと思います。)

curl -V

curl: 0h??: ELF: x: Error 93410455

質問としては、

curl: ??l?: ELF: x: Error 1644151959 
curl: 0h??: ELF: x: Error 93410455 

の直し方と、本来の目的であるbrewのインストールまでの方法を教えていただきたいです。
3日ほどずっとハマっております。
助けていただけると幸いです。

追記1

Executable and Linkable Format (ELF) とは、コンパイラが生成するオブジェクト、および、ライブラリとリンクされた実行ファイルのファイルフォーマット であるということはわかりました。

追記2

↓以下の記事では、lsやmvコマンドも使用できないとありますが、僕の環境では利用できます。
上述のようにcurl -Vが使えない?glibcと競合?してるみたいです。

https://rcmdnk.com/blog/2019/11/26/computer-linux-homebrew/#google_vignette

追記3

glibcが悪さをしている?のかもしれませんが、現在の状況として載せておきます。

$ brew info glibc
Error: Please update your system Git.
Minimum required version: 2.7.0
Your Git version: ...
Your Git executable: /usr/bin/git
glibc: stable 2.23 (bottled)
GNU C Library
https://www.gnu.org/software/libc/
/home/linuxbrew/.linuxbrew/Cellar/glibc/2.23 (1,366 files, 85.7MB) *
  Poured from bottle on 2021-05-17 at 07:27:40
From: /home/linuxbrew/.linuxbrew/Homebrew/Library/Taps/homebrew/homebrew-core/Formula/glibc.rb
License: GPL-2.0-or-later and LGPL-2.1-or-later
==> Dependencies
Build: binutils ✔, linux-headers ✔
==> Requirements
Build: gawk 3.1.2 (or later) ✔, make 3.79 (or later) ✔, sed ✔
Required: System glibc < 2.23 ✔, Linux ✔, Linux kernel 2.6.32 (or later) ✔
==> Analytics
install: 301 (30 days), 900 (90 days), 5,464 (365 days)
install-on-request: 110 (30 days), 238 (90 days), 1,788 (365 days)
build-error: 0 (30 days)
$ brew info gcc
Error: Please update your system Git.
Minimum required version: 2.7.0
Your Git version: ...
Your Git executable: /usr/bin/git
gcc: stable 11.1.0 (bottled), HEAD
GNU compiler collection
https://gcc.gnu.org/
Not installed
From: /home/linuxbrew/.linuxbrew/Homebrew/Library/Taps/homebrew/homebrew-core/Formula/gcc.rb
License: GPL-3.0-or-later with GCC-exception-3.1
==> Dependencies
Required: gmp ✔, isl ✘, libmpc ✔, mpfr ✔, zlib ✔, binutils ✔
==> Options
--HEAD
    Install HEAD version
==> Analytics
install: 12,826 (30 days), 36,075 (90 days), 128,355 (365 days)
install-on-request: 10,027 (30 days), 28,909 (90 days), 92,619 (365 days)
build-error: 0 (30 days)
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • hoshi-takanori

    2021/05/18 07:12

    brew は消して、php 7.4 を直接入れれば良いのでは。
    https://qiita.com/109s/items/c612eba9ebaf315df1fc

    キャンセル

  • rapsody

    2021/05/18 07:27

    迅速な対応ありがとうございます。やってみます。

    キャンセル

  • rapsody

    2021/05/18 07:43

    ありがとうございます。直接入れる方法をやってみたところ、php7.4をインストールすることができました。glibcの箇所は複雑そうですね、、、時間があるときにまた再トライしてみます。
    勉強になりました。

    キャンセル

回答 1

check解決した方法

0

hoshi-takanori
2021/05/18 07:12

brew は消して、php 7.4 を直接入れれば良いのでは。
https://qiita.com/109s/items/c612eba9ebaf315df1fc

↑と https://www.geekfeed.co.jp/geekblog/centos-remi-epel-php によって解決しました。brewでのインストールはできませんでしたが、サードパーティリポジトリであるremiを使って直接php7.4をインストールすることで目的は果たすことができました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.92%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る