質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.79%

pipコマンドで"invalid syntax"エラーが発生する。

解決済

回答 3

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 709

score 28

やりたいこと

pipを削除したい。
pipのバージョンをアップグレードしたところ,python2.7で使用できなくなりました。
環境の都合上python2.7でpipを実行するため,現在のpipを一度削除し,古いバージョンのpipをインストールしたい。

躓いている点

pipを削除しようと以下のコマンドを打つとエラーが発生します。
エラー内容をコマンドの下に示します。
本エラーは、pipのバージョンを21.1.1にしたところ発生しました。
調べたところエラーは、pythonのバージョンが3.6よりも低い場合に発生するようです。
そこで、pipを削除しようと考えたのですが、削除する方法が分かりません。
有識者の方々互助力よろしくお願いします。

コマンド

 python -m pip uninstall pip

エラー内容

  File "/home/xxx/.local/lib/python2.7/site-packages/pip/_internal/cli/main.py", line 60
    sys.stderr.write(f"ERROR: {exc}")
                                   ^
SyntaxError: invalid syntax

環境

OS:Ubuntu16.04
Python:python2.7

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 3

checkベストアンサー

+1

get-pip.py returns SyntaxError: invalid syntax [duplicate]の回答に記載されているように
pip install --upgrade pip==20.3と古いバージョンに更新してみてはどうでしょうか。

あるいは同じく回答に記載されているとおり
curl https://bootstrap.pypa.io/2.7/get-pip.py --output get-pip.pyなりで
get-pip.pyをとってきてpython get-pip.pyを実行してみてはいかがでしょうか。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2021/03/04 20:22

    can110さん返信ありがとうございます。
    pipコマンドを使用するとエラーが出力されるため,pip install --upgrade pip==20.3はできませんでした。

    また,質問なのですが,"curl https://bootstrap.pypa.io/2.7/get-pip.py --output get-pip.py"でダウンロードしたget-pip.pyはどこに保存されるのでしょうか?

    キャンセル

  • 2021/03/04 20:25

    一般的にはカレントディレクトリに保存されます。

    キャンセル

  • 2021/03/04 20:30

    can110さん回答ありがとうございます。
    提案いただいた方法で,エラーを解消することができました。
    ありがとうございます。

    キャンセル

0

python3のpipをpython2で削除しようとしているからでは?

python3 -m pip uninstall pip

でどうでしょう?

ちなみになんでpipを削除したいのでしょう?
もともとの問題は、python2 と python3 で混乱しているのが原因ではないですか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2021/03/04 15:20

    TakaiYさん回答ありがとうございます。
    提示していただいたコマンドを打ったところ以下のように出力されました。
    /usr/bin/python3: No module named pip

    削除したい理由としては,環境の都合上python2.7を使用したいのですが,pipをアップグレードしたところ2.7では使用できなくなったため,一度削除し,古いバージョンのpipをインストールしようと考えていました。

    キャンセル

  • 2021/03/04 17:08

    そういうことでしたか。 残念ながら僕にはよくわかりません。

    この削除したい理由、python2.7でpipを使いたいというところ、を質問に加えたほうがいいと思います。

    キャンセル

  • 2021/03/04 17:58

    返信ありがとうございます。
    質問に付け加えました。

    キャンセル

0

ubuntuは、pipコマンドは明示的にインストールしないと使えないはずです。
どのようにインストールしましたか?

上記のサイトのようにaptpython-pipパッケージでインストールしたならば、再インストールを試してみてください。

sudo apt --reinstall install python-pip

なお、aptでインストールしたものは、apt以外でアップグレードしない方がいいです。

get-pip.pypipをインストールしたのであれば、can110さんの言うとおりで。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2021/03/04 20:28

    katsukoさん回答ありがとうございます。
    インストールは以下のコマンドで行いました。
    "sudo apt-get install python-pip"
    また,アップグレードは"sudo pip install --upgrade pip"で行いました。

    ご提示いただいたreinstallを行いましたがエラーは解消されませんでした。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.79%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る