質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.60%

Mac でpip intallがうまくいかない

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 639

score 10

前提・実現したいこと

macでgwpyというモジュールをpip installしたいです。

発生している問題・エラーメッセージ

import requests, os
import matplotlib.pyplot as plt
%config InlineBackend.figure_format = 'retina'

try:
    from gwpy.timeseries import TimeSeries
except:
    ! pip install -q gwpy
    from gwpy.timeseries import TimeSeries   


としましたところ,

Traceback (most recent call last):
  File "/usr/local/bin/pip", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 3241, in <module>
    @_call_aside
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 3225, in _call_aside
    f(*args, **kwargs)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 3254, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 585, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 598, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pip==20.3.1' distribution was not found and is required by the application
---------------------------------------------------------------------------
ModuleNotFoundError                       Traceback (most recent call last)
<ipython-input-14-140a1446a3c5> in <module>
      5 try:
----> 6     from gwpy.timeseries import TimeSeries
      7 except:

ModuleNotFoundError: No module named 'gwpy'

During handling of the above exception, another exception occurred:

ModuleNotFoundError                       Traceback (most recent call last)
<ipython-input-14-140a1446a3c5> in <module>
      7 except:
      8     get_ipython().system(' pip install -q gwpy')
----> 9     from gwpy.timeseries import TimeSeries

ModuleNotFoundError: No module named 'gwpy'


というエラーが出てしまいます。

https://github.com/pypa/pip/issues/6399
の方法でpipを入れ直してみたりしましたが同様のエラーが変わらず出ました。

pip installについての知識が浅いため,他にどうすれば良いのか分かりません。
よろしくお願いいたします。

補足

ちなみに単純にmacのターミナルで
$pip install gwpy
を行うと,

Traceback (most recent call last):
  File "/usr/local/bin/pip", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 3241, in <module>
    @_call_aside
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 3225, in _call_aside
    f(*args, **kwargs)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 3254, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 585, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 598, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources/__init__.py", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pip==20.3.1' distribution was not found and is required by the application

となりました。

環境

Catalina 10.15.7
VS code
Python 3.7.3 64-bit('base':conda)
~/anaconda3/bin/python に変更しました

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • jbpb0

    2021/01/07 15:09

    まず、自分が今後使ってくPython 3.xをどれにするのかを決めます
    それ以外のものは、可能なものは削除します
    MacOS付属のものは削除できないけど、AnacondaとVS Codeのために入れたのは、要らない方は削除する

    それから、今後使うと決めたものだけを確実に使えるように、全ての設定を確認して、設定を直す
    環境変数pathがどうなっているのか?
    (python3とかpip3とか実行した場合に、自分が使いたいものが動くように)
    VS Codeからpython起動することがあるなら、その設定も
    jupyter使うなら、その設定も
    そういうことを全部確認して、間違っているところがあれば直す

    そこまで終わって、やっとスタートラインです
    pip3で何か追加したりできるのは、その後

    キャンセル

  • jbpb0

    2021/01/07 15:15

    ここの上の方で手順書いたのは、Anaconda版のPythonを使ってると思ったから、それでの手順(conda...)を書きました
    Anacondaではない方を今後使っていくのなら、pip3のアップデートのやり方とか違います

    キャンセル

  • Lily1007

    2021/01/07 21:43

    複数のPythonについての違いがよく分かりました。
    色々入っていたPythonを削除してAnaconda3にあるPython 3.7.3を使用することにしました。そしてcondaを使用して無事gwpyを入れる事が出来ました!
    パッケージ1つのインストールですが,多くのことをjbpb0様から知ることができました。本当にありがとうございます。今後ともよろしくお願いいたします。

    キャンセル

回答 1

checkベストアンサー

0

別の質問にお書きの内容からして、AnacondaのPython 3.xを入れてお使いなのですね
その場合は、pipではなくpip3を実行します
(コマンドの最初にsudoを付ける必要があるかも)

この質問に挙げられてるエラーはPython 2.7のものなので、pip3ではなくpipを実行したために、OS付属のPython 2.xに入れようとしてることになってるのだと思います

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.60%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る