質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.37%

colabでSONYのnnablaをインストールができているのか分かりません

受付中

回答 0

投稿

  • 評価
  • クリップ 0
  • VIEW 414

score 12

colabでSONYのnnablaをインストールしようとすると以下のような画面が出てきました。
下から5行目にERROR: botocore 1.19.47 has requirement urllib3<1.27,>=1.25.4; python_version != "3.4", but you'll have urllib3 1.24.3 which is incompatible. と書いてあるのですがこれは無事にインストールができていないのでしょうか。

Collecting nnabla
Downloading https://files.pythonhosted.org/packages/4a/88/079f50147709f86066a20c37f64f4732df9ca83c873e0fdbb8fdb934eacf/nnabla-1.15.0-cp36-cp36m-manylinux1_x86_64.whl (16.7MB)
|████████████████████████████████| 16.7MB 223kB/s 
Requirement already satisfied: setuptools in /usr/local/lib/python3.6/dist-packages (from nnabla) (51.0.0)
Collecting boto3
Downloading https://files.pythonhosted.org/packages/28/78/4067ce89180daf0b2027df4b3e4c4734d73b99c3a664d262a4c4d5ac1021/boto3-1.16.47-py2.py3-none-any.whl (130kB)
|████████████████████████████████| 133kB 47.8MB/s 
Requirement already satisfied: Cython in /usr/local/lib/python3.6/dist-packages (from nnabla) (0.29.21)
Requirement already satisfied: numpy in /usr/local/lib/python3.6/dist-packages (from nnabla) (1.19.4)
Collecting configparser
Downloading https://files.pythonhosted.org/packages/08/b2/ef713e0e67f6e7ec7d59aea3ee78d05b39c15930057e724cc6d362a8c3bb/configparser-5.0.1-py3-none-any.whl
Requirement already satisfied: requests in /usr/local/lib/python3.6/dist-packages (from nnabla) (2.23.0)
Requirement already satisfied: contextlib2 in /usr/local/lib/python3.6/dist-packages (from nnabla) (0.5.5)
Collecting onnx<1.9.0
Downloading https://files.pythonhosted.org/packages/2a/82/e8d0fb64df623a3b716145192ed50604f444889778b37e0e9262753d5046/onnx-1.8.0-cp36-cp36m-manylinux2010_x86_64.whl (7.7MB)
|████████████████████████████████| 7.7MB 30.8MB/s 
Requirement already satisfied: protobuf>=3.6 in /usr/local/lib/python3.6/dist-packages (from nnabla) (3.12.4)
Requirement already satisfied: scipy in /usr/local/lib/python3.6/dist-packages (from nnabla) (1.4.1)
Requirement already satisfied: tqdm in /usr/local/lib/python3.6/dist-packages (from nnabla) (4.41.1)
Requirement already satisfied: pyyaml in /usr/local/lib/python3.6/dist-packages (from nnabla) (3.13)
Requirement already satisfied: pillow in /usr/local/lib/python3.6/dist-packages (from nnabla) (7.0.0)
Requirement already satisfied: six in /usr/local/lib/python3.6/dist-packages (from nnabla) (1.15.0)
Requirement already satisfied: h5py in /usr/local/lib/python3.6/dist-packages (from nnabla) (2.10.0)
Requirement already satisfied: imageio in /usr/local/lib/python3.6/dist-packages (from nnabla) (2.4.1)
Collecting botocore<1.20.0,>=1.19.47
Downloading https://files.pythonhosted.org/packages/8f/4a/16ffdfc33d93f02604ae9ed1ddb6369030b6f61b583f31dc84e0d0da05c1/botocore-1.19.47-py2.py3-none-any.whl (7.2MB)
|████████████████████████████████| 7.2MB 40.0MB/s 
Collecting jmespath<1.0.0,>=0.7.1
Downloading https://files.pythonhosted.org/packages/07/cb/5f001272b6faeb23c1c9e0acc04d48eaaf5c862c17709d20e3469c6e0139/jmespath-0.10.0-py2.py3-none-any.whl
Collecting s3transfer<0.4.0,>=0.3.0
Downloading https://files.pythonhosted.org/packages/69/79/e6afb3d8b0b4e96cefbdc690f741d7dd24547ff1f94240c997a26fa908d3/s3transfer-0.3.3-py2.py3-none-any.whl (69kB)
|████████████████████████████████| 71kB 7.7MB/s 
Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /usr/local/lib/python3.6/dist-packages (from requests->nnabla) (1.24.3)
Requirement already satisfied: chardet<4,>=3.0.2 in /usr/local/lib/python3.6/dist-packages (from requests->nnabla) (3.0.4)
Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python3.6/dist-packages (from requests->nnabla) (2020.12.5)
Requirement already satisfied: idna<3,>=2.5 in /usr/local/lib/python3.6/dist-packages (from requests->nnabla) (2.10)
Requirement already satisfied: typing-extensions>=3.6.2.1 in /usr/local/lib/python3.6/dist-packages (from onnx<1.9.0->nnabla) (3.7.4.3)
Requirement already satisfied: python-dateutil<3.0.0,>=2.1 in /usr/local/lib/python3.6/dist-packages (from botocore<1.20.0,>=1.19.47->boto3->nnabla) (2.8.1)
ERROR: botocore 1.19.47 has requirement urllib3<1.27,>=1.25.4; python_version != "3.4", but you'll have urllib3 1.24.3 which is incompatible.
Installing collected packages: jmespath, botocore, s3transfer, boto3, configparser, onnx, nnabla
Successfully installed boto3-1.16.47 botocore-1.19.47 configparser-5.0.1 jmespath-0.10.0 nnabla-1.15.0 onnx-1.8.0 s3transfer-0.3.3

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正の依頼

  • max12345

    2021/01/07 15:38

    試してみましたが、エラーがでました。
    Collecting urllib3==1.25.11
    Downloading https://files.pythonhosted.org/packages/56/aa/4ef5aa67a9a62505db124a5cb5262332d1d4153462eb8fd89c9fa41e5d92/urllib3-1.25.11-py2.py3-none-any.whl (127kB)
    |████████████████████████████████| 133kB 11.8MB/s
    ERROR: datascience 0.10.6 has requirement folium==0.2.1, but you'll have folium 0.8.3 which is incompatible.
    Installing collected packages: urllib3
    Found existing installation: urllib3 1.24.3
    Uninstalling urllib3-1.24.3:
    Successfully uninstalled urllib3-1.24.3
    Successfully installed urllib3-1.25.11

    キャンセル

  • jbpb0

    2021/01/07 16:27

    > Successfully installed urllib3-1.25.11

    なので、urllib3-1.25.11は入りましたよ

    > datascience 0.10.6 has requirement folium==0.2.1, but you'll have folium 0.8.3 which is incompatible.

    datascienceというものが、folium==0.2.1じゃないとダメ(新しくても古くてもダメ)って言ってるけど、既にfolium 0.8.3が入ってる、って言ってます
    次から次へと、キリがない

    キャンセル

  • jbpb0

    2021/01/07 16:34

    datascienceは0.17が出てます
    https://pypi.org/project/datascience/
    もしかしたら、新しいのを入れたら、folium 0.8でも許してくれるかもしれません

    あるいは、folium==0.2.1を入れる(バージョンを下げる)か

    どちらをやっても、それに伴って、また何かのバージョンが合わないって怒られるかもしれませんけど

    キャンセル

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.37%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る