質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

受付中

rails newがうまく機能しません

meroa
meroa

総合スコア0

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。

0回答

0評価

0クリップ

4閲覧

投稿2020/11/20 05:07

前提・実現したいこと

ここに質問の内容を詳しく書いてください。
(例)PHP(CakePHP)で●●なシステムを作っています。
■■な機能を実装中に以下のエラーメッセージが発生しました。

発生している問題・エラーメッセージ

rails newをやっても作られません

エラーメッセージ

ec2-user:~/environment $ rails new blog
/home/ec2-user/.rvm/gems/ruby-2.5.1/gems/bundler-2.1.4/lib/bundler/rubygems_ext.rb:17:in remove_method': method source' not defined in Gem::Specification (NameError)
from /home/ec2-user/.rvm/gems/ruby-2.5.1/gems/bundler-2.1.4/lib/bundler/rubygems_ext.rb:17:in <class:Specification>' from /home/ec2-user/.rvm/gems/ruby-2.5.1/gems/bundler-2.1.4/lib/bundler/rubygems_ext.rb:14:in module:Gem'
from /home/ec2-user/.rvm/gems/ruby-2.5.1/gems/bundler-2.1.4/lib/bundler/rubygems_ext.rb:13:in <top (required)>' from /home/ec2-user/.rvm/gems/ruby-2.5.1/gems/bundler-2.1.4/lib/bundler.rb:10:in require_relative'
from /home/ec2-user/.rvm/gems/ruby-2.5.1/gems/bundler-2.1.4/lib/bundler.rb:10:in <top (required)>' from /usr/share/ruby/vendor_ruby/2.0/rubygems/core_ext/kernel_require.rb:135:in require'
from /usr/share/ruby/vendor_ruby/2.0/rubygems/core_ext/kernel_require.rb:135:in rescue in require' from /usr/share/ruby/vendor_ruby/2.0/rubygems/core_ext/kernel_require.rb:144:in require'
from /home/ec2-user/.rvm/gems/ruby-2.5.1@global/gems/bundler-unload-1.0.2/lib/bundler-unload.rb:1:in <top (required)>' from /usr/share/ruby/vendor_ruby/2.0/rubygems/core_ext/kernel_require.rb:55:in require'
from /usr/share/ruby/vendor_ruby/2.0/rubygems/core_ext/kernel_require.rb:55:in require' from /home/ec2-user/.rvm/gems/ruby-2.5.1@global/gems/rubygems-bundler-1.4.5/lib/rubygems-bundler/noexec.rb:82:in setup'
from /home/ec2-user/.rvm/gems/ruby-2.5.1@global/gems/rubygems-bundler-1.4.5/lib/rubygems-bundler/noexec.rb:124:in check' from /home/ec2-user/.rvm/gems/ruby-2.5.1@global/gems/rubygems-bundler-1.4.5/lib/rubygems-bundler/noexec.rb:131:in <top (required)>'
from /usr/share/ruby/vendor_ruby/2.0/rubygems/core_ext/kernel_require.rb:135:in require' from /usr/share/ruby/vendor_ruby/2.0/rubygems/core_ext/kernel_require.rb:135:in rescue in require'
from /usr/share/ruby/vendor_ruby/2.0/rubygems/core_ext/kernel_require.rb:144:in require' from /home/ec2-user/.rvm/gems/ruby-2.5.1@global/gems/rubygems-bundler-1.4.5/lib/rubygems_executable_plugin.rb:4:in block in <top (required)>'
from /home/ec2-user/.rvm/gems/ruby-2.5.1@global/gems/executable-hooks-1.6.0/lib/executable-hooks/hooks.rb:50:in call' from /home/ec2-user/.rvm/gems/ruby-2.5.1@global/gems/executable-hooks-1.6.0/lib/executable-hooks/hooks.rb:50:in block in run'
from /home/ec2-user/.rvm/gems/ruby-2.5.1@global/gems/executable-hooks-1.6.0/lib/executable-hooks/hooks.rb:49:in each' from /home/ec2-user/.rvm/gems/ruby-2.5.1@global/gems/executable-hooks-1.6.0/lib/executable-hooks/hooks.rb:49:in run'
from /home/ec2-user/.rvm/gems/ruby-2.5.1/bin/ruby_executable_hooks:10:in `<main>'

該当のソースコード

ソースコード

試したこと

ここに問題に対して試したことを記載してください。

補足情報(FW/ツールのバージョンなど)

ここにより詳細な情報を記載してください。

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

y_waiwai
y_waiwai

2020/11/20 05:15

コードを提示しましょう コードは、質問を編集し、<code>ボタンを押し、出てくる’’’の枠の中にコードを貼り付けてください
maisumakun
maisumakun

2020/11/20 05:16

Rails本体はバージョンいくつのものを入れていますか?
meroa
meroa

2020/11/20 07:39

railsのバージョンは2\.5\.1だとおもいます。 ターミナルで確認しようとしたのですが上と同じものがターミナルに表示されるだけでした。
maisumakun
maisumakun

2020/11/20 07:47

> railsのバージョンは2\.5\.1だとおもいます。 それはRubyのバージョンではないでしょうか? Railsのバージョンはgem listなどから確認できるかと思います。
meroa
meroa

2020/11/20 07:54

ありがとうございます gem listの結果rails \(5\.2\.4\.4, 5\.2\.1\)と出てきました

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

Ruby on Rails

Ruby on Railsは、オープンソースのWebアプリケーションフレームワークです。「同じことを繰り返さない」というRailsの基本理念のもと、他のフレームワークより少ないコードで簡単に開発できるよう設計されています。