質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.59%

dockerビルド中にvendorやnode_modulesをインストールしたい

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 937

score 144

前提

バージョン

  • Docker version 19.03.13, build 4484c46d9d
  • docker-compose version 1.27.4, build 40524192

問題

dockerコンテナのビルド中に compose install や npm ci を実行すると、
インストール自体は走っているようですが、
CMDのタイミングではなぜか読み込めなくなってしまっています。

vendorやnode_modulesをインストールした状態で、
CMDを動かすようにしたいです。

file

docker-compose.yml

version: '3'
volumes:
  data:  # db用
services:
  node:  # node_modulesインストール用
    container_name:node
    build:
      context: .
      dockerfile: ./docker/node/Dockerfile
    tty: true
    stdin_open: true
    restart: always
    volumes:
      - .:/var/www/html
      - /var/www/html/node_modules  # 永続化
  app:  # メインアプリ
    container_name: app
    build:
      context: .
      dockerfile: ./docker/php/Dockerfile
    tty: true
    stdin_open: true
    volumes:
      - .:/var/www/html
      - /var/www/html/vendor  # 永続化
    volumes_from:
      - node
    ports:
      - "3010:3010"
  db:  # DBコンテナ(略)

docker/node/Dockerfile

FROM node:12

ENV PATH $PATH:/node_modules/.bin
COPY ./package.json .
COPY ./package-lock.json .
RUN npm ci --no-cache && npm cache clean --force

WORKDIR /var/www/html

CMD ["npm", "run", "watch"]

docker/php/Dockerfile

FROM php:7.4-fpm

COPY ./docker/php/files/php.ini /usr/local/etc/php/
COPY ./.env /var/www/html/

RUN apt-get update && apt-get install -y --no-install-recommends \
        libfreetype6-dev libzip-dev \
        libjpeg62-turbo-dev \
        zlib1g-dev mariadb-client procps \
        curl gnupg less git vim\
    && docker-php-ext-configure gd --with-freetype --with-jpeg \
    && docker-php-ext-install -j"$(nproc)" gd zip pdo_mysql \
    && apt-get clean \
    && rm -rf /var/lib/apt/lists/*

SHELL ["/bin/bash", "-o", "pipefail", "-c"]

# appコンテナ側でもnpm使えるよう念の為
RUN curl -sL https://deb.nodesource.com/setup_12.x | bash -
RUN apt-get install -y --no-install-recommends nodejs=12.19.0-1nodesource1

#Composer install
#hadolint ignore=DL3022
COPY --from=composer /usr/bin/composer /usr/bin/composer

ENV COMPOSER_ALLOW_SUPERUSER 1
ENV COMPOSER_HOME /composer
ENV PATH $PATH:/composer/vendor/bin

COPY composer.json composer.lock ./
RN composer install --no-scripts --no-autoloader

WORKDIR /var/www/html

CMD ["php", "artisan", "serve", "--host=0.0.0.0", "--port=3010"]

認識

volumeの適用タイミング

docker-compose.ymlのvolumesでホスト側ディレクトリや仮想volumeを割り当てると、

  1. ビルドでのRUN時
  2. volume割当
  3. CMD、ENTRYPOINT実行

という流れにより、
せっかくビルド時にRUNで compose install 等のインストールを行っても、ホスト側の空vendorディレクトリに2で置き換わってしまう。
そのため、この場合に3で参照しようと思ってもnot foundとなってしまう。

コンテナ内ディレクトリのvolume化

上記のような理由により、コンテナ内でinstall・ファイル生成する場合、
コンテナ内の対象ディレクトリ自体をvolume化し、別コンテナで参照できるように設定する必要がある認識である。
例)

version: '3'
volumes:
  data:  # db用
services:
  node:  # node_modulesインストール用
    :
    volumes:
      :
      - /var/www/html/node_modules  # このディレクトリをvolume化
  app:  # メインアプリ
    :
    volumes:
      :
      - /var/www/html/vendor  # このディレクトリをvolume化
    volumes_from:
      - node  # nodeコンテナのvolumeを参照
    :

これで、vendorとnode_modulesがnot foundになることなく参照できる認識である。
のだが、なぜかできないという状況です。

何かわかる方おりましたらよろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

version: '3'

Docker Compore の仕様で、ご質問で記述された内容はバージョン2相当であれば妥当と思いますが、バージョン3では動作していないか、意図せぬ動作になっている可能性が高いです。

バージョン3のリファレンスにありますように、 volumes: として、どちらのサービスからも参照可能なボリュームを作成されてみてはいかがでしょう。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.59%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る