質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.11%

compass create 出来ない 【助けてください】

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,476

①sassをインストール
②commpassをインストール
③cp−testと言うディレクトリを作成→中に入る
④compass createコマンド実行
⑤20分ぐらい待っても、compass createが終了しない

エラーもなにも出ないので、困っております。
ヒントまたは、調べ方など教えていただけましたら、幸いです。

よろしくお願いいたします。

![イメージ説明](10ce551d431c80aa85d7935dccedb87e.png)
この状態から(20分〜1時間)待っていても動きません!!泣

追記
ctrl + c でコマンド終了時のメッセージを貼り付けておきます。
イメージ説明

追記2
libさんにご指示いただき、
compass create --traceを行いました。
ご回答頂きましてありがとうございます。

⑤同様に、動かない状態が続いたのですが、
ctrl + cを押したときにスタックトレースが表示されました。

こちらを見て頂き、何かわかる方いらっしゃいましたら、助けていただきたいです。
よろしくお願いいたします。

^CInterrupt on line ["18"] of /Users/nakatani_kazuki/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/compass-rails-2.0.0/lib/compass-rails.rb:
  /Users/nakatani_kazuki/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/compass-rails-2.0.0/lib/compass-rails.rb:116:in configuration'   /Users/nakatani_kazuki/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/compass-1.1.0.alpha.3/lib/compass/configuration/helpers.rb:21:in configuration_for'
  /Users/nakatani_kazuki/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/compass-core-1.1.0.alpha.3/lib/compass/configuration.rb:143:in add_configuration'   /Users/nakatani_kazuki/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/compass-1.1.0.alpha.3/lib/compass/configuration/helpers.rb:79:in add_project_configuration'
  /Users/nakatani_kazuki/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/compass-1.1.0.alpha.3/lib/compass/commands/project_base.rb:37:in add_project_configuration'   /Users/nakatani_kazuki/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/compass-1.1.0.alpha.3/lib/compass/commands/installer_command.rb:9:in configure!'
  /Users/nakatani_kazuki/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/compass-1.1.0.alpha.3/lib/compass/commands/project_base.rb:15:in initialize'   /Users/nakatani_kazuki/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/compass-1.1.0.alpha.3/lib/compass/commands/stamp_pattern.rb:69:in initialize'
  /Users/nakatani_kazuki/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/compass-1.1.0.alpha.3/lib/compass/exec/sub_command_ui.rb:42:in new'   /Users/nakatani_kazuki/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/compass-1.1.0.alpha.3/lib/compass/exec/sub_command_ui.rb:42:in perform!'
  /Users/nakatani_kazuki/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/compass-1.1.0.alpha.3/lib/compass/exec/sub_command_ui.rb:15:in run!'   /Users/nakatani_kazuki/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/compass-1.1.0.alpha.3/bin/compass:30:in block in <top (required)>'
  /Users/nakatani_kazuki/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/compass-1.1.0.alpha.3/bin/compass:44:in call'   /Users/nakatani_kazuki/.rbenv/versions/2.1.3/lib/ruby/gems/2.1.0/gems/compass-1.1.0.alpha.3/bin/compass:44:in <top (required)>'
  /Users/nakatani_kazuki/.rbenv/versions/2.1.3/bin/compass:22:in load'   /Users/nakatani_kazuki/.rbenv/versions/2.1.3/bin/compass:22:in <main>'

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

compass help create ってやると英語ですがヘルプはでてきます。
そこで、compass create --traceとやっても何も出ないですか?

追記:
以下コマンドのあと再確認してみてください。

gem list でcompass-railsがあるようであれば、
gem uninstall compass-rails

追記2:
railsとあることから、rails4でも使用されているのですか?

どうも調べると、依存関係のようです。
railsでcompassを使いたいときは利用バージョンの調査と確認が重要のようです。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/03/19 15:46

    当方の環境を追記するの失念しました。
    ruby 2.2.0p0 (2014-12-25 revision 49005) [x86_64-darwin11.0]
    Sass 3.4.21 (Selective Steve)
    Comass 1.0.3 (Polaris)
    ひょっとしたら1.1に上がると困るんですかね?

    キャンセル

  • 2016/03/19 16:07

    ご回答ありがとうございます。
    ご丁寧に説明していただきまして、感謝しております。

    ご指示の通り、compass create --traceを打たせていただきました、
    追記2に現状を追加させていただきましたので、
    引き続き、ヒントいただけましたら、幸いです。

    迅速に回答頂きまして、本当に感謝しております。

    キャンセル

  • 2016/03/19 16:31

    追加検証時、当方の環境で、2.1.3p242 (2014-09-19 revision 47630)の環境で
    compassは、1.0.3でした バージョンを合わせるとよいかもしれません。
    gem search compass #可能なバージョンの確認
    gem install compass --version '>=1.0.3'

    キャンセル

  • 2016/03/19 17:22 編集

    3度目の検証時に提供いただいた環境を合わせてみました。

    gem listの情報をください。
    コマンド以下の情報と異なっていたらcompass*関連を一度gem uninstall してからinstallコマンドを実行してみてください
    ※少なくとも初回インストール時は以下含む9gemのインストールがあるようなので、
    他でインストールしていると依存関係でバッティングしたりするかもしれませんね。
    gem install compass --version '~> 1.1.0.alpha.3'

    compass (1.1.0.alpha.3)
    compass-core (1.1.0.alpha.3)
    compass-import-once (1.0.5)

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.11%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る