質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.40%

  • Ruby

    8479questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Atom (テキストエディタ)

    582questions

ruby webスクレイピングにてSyntaxError

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 778

LukeFukuda

score 61

googl1をwebスクレイピングしたいのですが

:/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require': :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/2.2.0/timeout.rb:74: syntax error, unexpected keyword_def, expecting keyword_end (SyntaxError)
...ent_alias = 'Windows IE 9'  def timeout(sec, klass = nil)   ...
...                               ^
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/2.2.0/net/protocol.rb:22:in `<top (required)>'
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/2.2.0/net/http.rb:22:in `<top (required)>'
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/net-http-digest_auth-1.4/lib/net/http/digest_auth.rb:4:in `<top (required)>'
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/mechanize-2.7.4/lib/mechanize.rb:5:in `<top (required)>'
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:127:in `require'
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:127:in `rescue in require'
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:40:in `require'
    from :/Users/ファイル場所/:in:2 `<main>'


エラーの場所は上から

return gem_original_require(path)
agent.user_agent_alias = 'Windows IE 9'  def
return gem_original_require(path)
require 'timeout'
return gem_original_require(path)
return gem_original_require(path)
return gem_original_require(path)
require 'robotex'
return gem_original_require(path)
return gem_original_require(path)
require 'anemone/core'
return gem_original_require(path)
return gem_original_require(path)


と表示されてしまいます。どうすればいいですか。コードは
下です。

require 'rubygems'
require 'mechanize'

a = Mechanize.new { |agent|
  agent.user_agent_alias = 'Mac Safari'
}

a.get('http://google.com/') do |page|
  search_result = page.form_with(:name => 'gbqf') do |search|
    search.q = 'Ruby'
  end.submit

  search_result.search(".//a[@class='l']").each_with_index.map do |link, i|
    puts "#{i} #{link.content}"
  end
end
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • LukeFukuda

    2016/03/09 17:14 編集

    よく見たら表示されていました。...:rb:ここに行数が表示されている:in

    キャンセル

  • NCC1701

    2016/03/09 18:56

    うまく伝わらなかったようですみません。
    エラーの発生箇所は,「ご自身が作ったコード上」でのことです。
    例えば
    test.rb:15:in `block (2 levels) in <main>': undefined method `q=' for nil:NilClass (NoMethodError)
    from test.rb:13:in `<main>'
    のようにtest.rbの(13行目から呼ばれている)15行目というようにエラーログからわかるのですが。

    キャンセル

  • LukeFukuda

    2016/03/09 19:00 編集

    2行目のrequire 'mechanize'です。ファイル場所を消すときに同時に消してしまったようです。

    キャンセル

回答 1

0

 agent.user_agent_alias = 'Mac Safari'

試しに上の行をコメントアウトしてユーザーエージェントを設定しないで実行してみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/03/09 19:10 編集

    設定しないで実行してもエラーがでます。
    エラー箇所は
    agent.user_agent_alias = 'Windows IE 9'
    require 'net/http'
    require 'net/http/digest_auth'
    RUBYGEMS_ACTIVATION_MONITOR.enter
    が新たに追加されました。

    キャンセル

  • 2016/03/09 19:19

    mechanizeが正しくインストールされていない可能性があります。
    アップデートするか,再インストール(gem uninstall後gem install)してみてください。

    キャンセル

  • 2016/03/09 19:44 編集

    gem uninstall mechanizeを実行すると、
    :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require': :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/2.2.0/timeout.rb:74: syntax error, unexpected keyword_def, expecting keyword_end (SyntaxError)
    ...ent_alias = 'Windows IE 9' def timeout(sec, klass = nil) ...
    ... ^
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/command_manager.rb:97:in `initialize'
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/command_manager.rb:75:in `new'
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/command_manager.rb:75:in `instance'
    from :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/gem_runner.rb:42:in `run'
    from :/Ruby/RailsInstaller/Ruby2.2.0/bin/gem:21:in `<main>'
    と表示されてしまいます。

    キャンセル

  • 2016/03/09 23:03

    require 'mechanize'
    1行だけのスクリプトを実行してみてください。これでエラーが出るなら,「webスクレイピング」の問題ではありません。
    ruby(railsなど)のインストールなどに問題が生じています。問題の所在が,質問とかけ離れますので,この質問は閉じて,改めて,質問をしなおした方が良いでしょう。

    その際には,rubyそのもののインソールの経緯やmechanizeを始めgemのインストール,バージョン等のみならず,実行環境も記載すると良いでしょう。

    キャンセル

  • 2016/03/09 23:12 編集

    require 'mechanize'のみで実行したらC:/Users/ファイル場所:1:in `<main>': undefined method `requre' for main:Object (NoMethodError)と表示されました。

    キャンセル

  • 2016/03/09 23:21

    typoしてます。requreではなくrequire
    焦らずに。

    キャンセル

  • 2016/03/09 23:31

    requireにしたら
    :/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require': D:/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/2.2.0/timeout.rb:74: syntax error, unexpected keyword_def, expecting keyword_end (SyntaxError)
    ...ent_alias = 'Windows IE 9' def timeout(sec, klass = nil) ...
    ... ^
    from D:/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from D:/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/2.2.0/net/protocol.rb:22:in `<top (required)>'
    from D:/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from D:/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from D:/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/2.2.0/net/http.rb:22:in `<top (required)>'
    from D:/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from D:/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from D:/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/net-http-digest_auth-1.4/lib/net/http/digest_auth.rb:4:in `<top (required)>'
    from D:/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from D:/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:55:in `require'
    from D:/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/gems/2.2.0/gems/mechanize-2.7.4/lib/mechanize.rb:5:in `<top (required)>'
    from D:/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:127:in `require'
    from D:/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:127:in `rescue in require'
    from D:/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:40:in `require'
    from C:/Users/���/1:in `<main>'
    と表示されました。

    キャンセル

  • 2016/03/10 00:26

    /Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/2.2.0/timeout.rbの74行目でsyntax errorになっています。
    このライブラリを改変することはないので,エラー解消方法はとても厄介になるはずです。
    timeout.rbのソースコード全文を載せるなどしないと,無理かもしれません。

    キャンセル

  • 2016/03/10 15:50

    agent.user_agent_alias = 'Windows IE 9' def timeout(sec, klass = nil) が/Ruby/RailsInstaller/Ruby2.2.0/lib/ruby/2.2.0/timeout.rbの74行目です。

    キャンセル

同じタグがついた質問を見る

  • Ruby

    8479questions

    Rubyはプログラミング言語のひとつで、オープンソース、オブジェクト指向のプログラミング開発に対応しています。

  • Atom (テキストエディタ)

    582questions