質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.21%

conpassをUnixコマンドでインストールできません........

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 2,466

dialbird

score 342

こんばんは。
Compassをgemでインストールしたいのですが、以下のエラーコマンドが出て失敗してしまいます。

//mkmf.log
package configuration for libffi is not found
"xcrun clang -o conftest -I/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/include/ruby-2.0.0/universal-darwin15 -I/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/include/ruby-2.0.0/ruby/backward -I/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/include/ruby-2.0.0 -I. -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -D_DARWIN_UNLIMITED_SELECT -D_REENTRANT    -g -Os -pipe -DHAVE_GCC_SYNC_BUILTINS conftest.c  -L. -L/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib -L. -L/usr/local/lib   -arch i386 -arch x86_64   -lruby.2.0.0  -lpthread -ldl -lobjc "
In file included from conftest.c:1:
In file included from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/include/ruby-2.0.0/ruby.h:33:
/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/include/ruby-2.0.0/ruby/ruby.h:24:10: fatal error: 'ruby/config.h' file not found
#include "ruby/config.h"
         ^
1 error generated.
checked program was:
/* begin */
1: #include "ruby.h"
2: 
3: int main(int argc, char **argv)
4: {
5:   return 0;
6: }
/* end */


どなたか解決策を教えてください。
お願いいたします

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

0

おそらくgccがないかgccのバージョンが古いはずです。
which gcc
gcc -v
でチェックして,場合によってはHomebrewとかMacPorsあたりでgccのバージョンアップをしてみてください。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/03/05 21:58

    夜分遅くまでお付き合いくださり、本当にありがとうございます!

    突然な話なのですが、以下のサイトを参考にして最後までやったら実現できました!
    http://qiita.com/tokimari/items/feda1ed61f2d8b5b317c

    どうやらsudoの必要な領域にrubyがあったことで面倒臭いことになっていたようで、rbenvを使って色々やったところ、何事もなかったかのように
    gem installでも
    sudo gem installでも
    compassがインストールできるようになりました。

    これで解決........でもよろしいのでしょうか?
    まだUnixの世界に関しては知識が浅いのですが、何か重大な問題から逃げた解決なのでしょうか........

    キャンセル

  • 2016/03/05 22:09

    おつかれさまでした。

    逃げた解決だとは思われません。が,次のようなことは理解しておいたほうが,今後のヒントになると思われます。

    1. 当初はシステムのrubyを使っていた(/System/Library/Frameworks/Ruby.framework/Versions/2.0)
    2. システムのrubyにはヘッダファイルに足りないものがある(今回はconfig.h)
    3. rbenvで別のバージョンのrubyを別の場所にインストールした。(rubyは複数のバージョンを切り替えて使えるようになっています。)
    4. rbenvでインストールしたrubyにはconfig.hが初めから揃っていた。

    ということで,解決できました。(実のところシステムのrubyが怪しそうなので,リンク後もうまくいかなかったら,rvmあたりでruby2.3でも入れましょうと回答する予定でした。)

    キャンセル

  • 2016/03/05 23:20

    ありがとうございます。

    気になる多々ありますが、とりあえず今はそういうことにしておいてこのまま先に進もうと思います。

    詳細な指示を与えてくださり、心より感謝いたします。
    また何かの折には是非ともアドバイスをいただけたら幸いです。

    本当にありがとうございました!

    キャンセル

0

package configuration for libffi is not found

と表示されているので、
$ brew install libffi 
をしてみてから、
$ gem install compass
するとよいと思います。

参考情報:
"package configuration for libffi is not found" compass gem
で google 検索したら、次のページがみつかりました。    

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/03/05 08:52

    ご返信ありがとうございます!

    仰った通り、libffiをインストールしてみたのですが、相変わらず同じエラーが出続けてしまいます........。NCC1701さんのアドバイスも参考にして、gccを最新版(であろう)の4.9にしてみたのですが、やはり変化なしです。一応正しくインストールできていない可能性も鑑みて、gcc -vの結果をNCC1701さんへのコメント欄に挙げておきました。

    それと例の英語のページを見ていて思ったのですが、gccの4.2でないとだめ、というわけではないですよね........?

    よろしくお願いいたします。

    キャンセル

  • 2016/03/05 16:45

    参考として、私のマシン環境を示します。compass は install できてます。
    $ gem install compass => Successfully installed compass-1.0.3

    $ sw_vers => Mac OS X 10.11.3 15D21
    $ xcodebuild -version => Xcode 7.2.1 Build version 7C1002
    $ xcode-select -v => xcode-select version 2343.
    $ gem --version => 2.5.1
    $ brew --version => Homebrew 0.9.5 (git revision 3c89; last commit 2016-03-01)

    $ gcc -v
    Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr --with-gxx-include-dir=/usr/include/c++/4.2.1
    Apple LLVM version 7.0.2 (clang-700.1.81)
    Target: x86_64-apple-darwin15.3.0
    Thread model: posix

    $ gcc-5 -v
    gcc version 5.3.0 (Homebrew gcc 5.3.0)

    キャンセル

  • 2016/03/05 21:11

    返信が遅れました。

    私の環境だと
    $ sw_vers => Mac OS X 10.11.1 15B42
    $ xcodebuild -version => Xcode 7.2.1 Build version 7C1002
    $ xcode-select -v => xcode-select version 2343
    $ gem --version => 2.6.0
    $ brew --version => Homebrew 0.9.5 (git revision 0315; last commit 2016-01-15)

    $ gcc -v
    Using built-in specs.
    COLLECT_GCC=gcc
    COLLECT_LTO_WRAPPER=/usr/local/Cellar/gcc49/4.9.3/libexec/gcc/x86_64-apple-darwin15.2.0/4.9.3/lto-wrapper
    Target: x86_64-apple-darwin15.2.0
    Configured with: ../configure --build=x86_64-apple-darwin15.2.0 --prefix=/usr/local/Cellar/gcc49/4.9.3 --libdir=/usr/local/Cellar/gcc49/4.9.3/lib/gcc/4.9 --enable-languages=c,c++,objc,obj-c++ --program-suffix=-4.9 --with-gmp=/usr/local/opt/gmp4 --with-mpfr=/usr/local/opt/mpfr2 --with-mpc=/usr/local/opt/libmpc08 --with-cloog=/usr/local/opt/cloog018 --with-isl=/usr/local/opt/isl011 --with-system-zlib --enable-libstdcxx-time=yes --enable-stage1-checking --enable-checking=release --enable-lto --with-build-config=bootstrap-debug --disable-werror --with-pkgversion='Homebrew gcc49 4.9.3' --with-bugurl=https://github.com/Homebrew/homebrew-versions/issues --enable-plugin --disable-nls --enable-multilib
    Thread model: posix
    gcc version 4.9.3 (Homebrew gcc49 4.9.3)

    $ gcc-5 -v
    command not found

    となりました。
    最後のが気になります........
    必要なのでしょうか?

    キャンセル

  • 2016/03/05 23:24

    katoyさん

    おかげさまで無事compassをインストールできるようになりました。
    NCC1701さんへのコメントにも記載しましたが、システムのrubyではなく、rbenvで別の場所にインストールしたrubyを使ったところ、うまくいきました。

    結局のところシステムの方のrubyの何が悪かったのかが曖昧なままですが、ひとまず目標は達成したので進もうと思います。

    アドバイスをくださり、誠にありがとうございました!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.21%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる