質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.63%

centosにmysqlがインストール出来ません

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 7,873

uer03108

score 112

cenosにmysqlをインストールすると下記のエラーが出たのですが、原因は何なのでしょうか。

[root@ik1-311-15522 init.d]# yum -y install http://dev.mysql.com/get/mysql57-community-release-el7-7.noarch.rpm

[root@ik1-311-15522 init.d]# yum -y install mysql-community-server
Loaded plugins: fastestmirror, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: ftp.iij.ad.jp
 * epel: ftp.iij.ad.jp
 * extras: ftp.iij.ad.jp
 * updates: ftp.iij.ad.jp
Resolving Dependencies
--> Running transaction check
---> Package mysql-community-server.x86_64 0:5.7.11-1.el7 will be installed
--> Processing Dependency: mysql-community-common(x86-64) = 5.7.11-1.el7 for package: mysql-community-server-5.7.11-1.el7.x86_64
--> Processing Dependency: mysql-community-client(x86-64) = 5.7.11-1.el7 for package: mysql-community-server-5.7.11-1.el7.x86_64
--> Processing Dependency: systemd for package: mysql-community-server-5.7.11-1.el7.x86_64
--> Processing Dependency: systemd for package: mysql-community-server-5.7.11-1.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: mysql-community-server-5.7.11-1.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: mysql-community-server-5.7.11-1.el7.x86_64
--> Running transaction check
---> Package mysql-community-client.x86_64 0:5.7.11-1.el7 will be installed
--> Processing Dependency: mysql-community-libs(x86-64) = 5.7.11-1.el7 for package: mysql-community-client-5.7.11-1.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: mysql-community-client-5.7.11-1.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: mysql-community-client-5.7.11-1.el7.x86_64
---> Package mysql-community-common.x86_64 0:5.7.11-1.el7 will be installed
---> Package mysql-community-server.x86_64 0:5.7.11-1.el7 will be installed
--> Processing Dependency: systemd for package: mysql-community-server-5.7.11-1.el7.x86_64
--> Processing Dependency: systemd for package: mysql-community-server-5.7.11-1.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: mysql-community-server-5.7.11-1.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: mysql-community-server-5.7.11-1.el7.x86_64
--> Running transaction check
---> Package mysql-community-client.x86_64 0:5.7.11-1.el7 will be installed
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: mysql-community-client-5.7.11-1.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: mysql-community-client-5.7.11-1.el7.x86_64
---> Package mysql-community-libs.x86_64 0:5.7.11-1.el7 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: mysql-community-libs-5.7.11-1.el7.x86_64
---> Package mysql-community-server.x86_64 0:5.7.11-1.el7 will be installed
--> Processing Dependency: systemd for package: mysql-community-server-5.7.11-1.el7.x86_64
--> Processing Dependency: systemd for package: mysql-community-server-5.7.11-1.el7.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) for package: mysql-community-server-5.7.11-1.el7.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.17)(64bit) for package: mysql-community-server-5.7.11-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: mysql-community-server-5.7.11-1.el7.x86_64 (mysql57-community)
           Requires: systemd
Error: Package: mysql-community-client-5.7.11-1.el7.x86_64 (mysql57-community)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: mysql-community-client-5.7.11-1.el7.x86_64 (mysql57-community)
           Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
Error: Package: mysql-community-server-5.7.11-1.el7.x86_64 (mysql57-community)
           Requires: libc.so.6(GLIBC_2.17)(64bit)
Error: Package: mysql-community-server-5.7.11-1.el7.x86_64 (mysql57-community)
           Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
Error: Package: mysql-community-libs-5.7.11-1.el7.x86_64 (mysql57-community)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


追記
osのバージョンは、CentOS release 6.7 (Final)
でした。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

checkベストアンサー

+2

インストール対象の MySQL は CentOS 7 用にビルドされたものですが、インストールしようとしている OS が CentOS 7 ではないため、MySQL が必要としているパッケージがなかったり、ライブラリバージョンが合わずにエラーとなっています。

もし、CentOS 6 であれば、yum remove mysql57-community-release-el7-7 で削除し、mysql57-community-release-el6-7.noarch.rpm をインストールしてから mysql-community-server をインストールします。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

こちらの環境では問題なくインストールできましたよ。
お使いの CentOS のバージョンはなんですか?

$ cat /etc/redhat-release
CentOS Linux release 7.2.1511 (Core) 

$ sudo yum -y install http://dev.mysql.com/get/mysql57-community-release-el7-7.noarch.rpm 
[sudo] password for centosuser: 
読み込んだプラグイン:fastestmirror, langpacks
Repodata is over 2 weeks old. Install yum-cron? Or run: yum makecache fast
mysql57-community-release-el7-7.noarch.rpm               | 8.8 kB     00:00     
/var/tmp/yum-root-8LwYma/mysql57-community-release-el7-7.noarch.rpm を調べています: mysql57-community-release-el7-7.noarch
/var/tmp/yum-root-8LwYma/mysql57-community-release-el7-7.noarch.rpm をインストール済みとして設定しています
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> パッケージ mysql57-community-release.noarch 0:el7-7 を インストール
--> 依存性解決を終了しました。
base/7/x86_64                                                                                                                                                     | 3.6 kB  00:00:00     
extras/7/x86_64                                                                                                                                                   | 3.4 kB  00:00:00     
extras/7/x86_64/primary_db                                                                                                                                        | 101 kB  00:00:00     
updates/7/x86_64                                                                                                                                                  | 3.4 kB  00:00:00     
updates/7/x86_64/primary_db                                                                                                                                       | 3.1 MB  00:00:02     

依存性を解決しました

=========================================================================================================================================================================================
 Package                                           アーキテクチャー               バージョン                       リポジトリー                                                     容量
=========================================================================================================================================================================================
インストール中:
 mysql57-community-release                         noarch                         el7-7                            /mysql57-community-release-el7-7.noarch                         7.8 k

トランザクションの要約
=========================================================================================================================================================================================
インストール  1 パッケージ

合計容量: 7.8 k
インストール容量: 7.8 k
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  インストール中          : mysql57-community-release-el7-7.noarch                                                                                                                   1/1 
  検証中                  : mysql57-community-release-el7-7.noarch                                                                                                                   1/1 

インストール:
  mysql57-community-release.noarch 0:el7-7                                                                                                                                               

完了しました!

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.63%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る