質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.93%

[React Native]Apple StoreからのITMS-90809のエラーを解決したい

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 495

score 0

前提・実現したいこと

現在ReactNativeを用いたネイティブアプリケーションを開発しています。
TestFlightを用いたベータテストを行うために、Apple Storeへのアップロードを行いたいと考えています。

発生している問題・エラーメッセージ

ストアへのアップロード時、メールにて以下のエラーメッセージが届きました。
プロジェクトにUIWebViewが含まれており、アプリがリジェクトされてしまったという内容でした。

ITMS-90809: Deprecated API Usage - New apps that use UIWebView are no longer accepted. Instead, use WKWebView for improved security and reliability. Learn more (https://developer.apple.com/documentation/uikit/uiwebview).


GitHubのissueや他のサイトを閲覧し解決方法を探したのですが、行き詰まってから2ヶ月ほど経つ現在なお直らず困っています。

試したこと

プロジェクトでは直接UIWebViewを使用していません。(React Native Webviewなど)
ですので、使用しているライブラリの内部でUIWebViewが使われているのではないかと考えました。

まず、バージョンが最新ではなかったライブラリのアップデートを行いました。(react-nativeはバージョンによる依存が大きかったため変更していません)

それでは解決しなかったので次に、以下のコマンドをターミナルで実行しプロジェクト全体の要素を検索しました。

$ grep -ril UIWebView .
./node_modules/react-native-maps/.gradle/4.10.3/taskHistory/taskHistory.bin
./node_modules/jsc-android/dist/include/JSContextPrivate.h
./node_modules/fbjs/lib/UserAgent.js.flow
./node_modules/fbjs/lib/UserAgent.js
./node_modules/create-react-class/node_modules/fbjs/lib/UserAgent.js.flow
./node_modules/create-react-class/node_modules/fbjs/lib/UserAgent.js


該当するファイルを確認したところ、直接UIWebViewを使用している箇所はありませんでした。

その後、Xcodeのプロジェクト内にて"UIWebView"について検索をしましたが、検索結果には何も出力されませんでした。
そこで、生成されたアプリのどの部分でUIWebViewが使われているかを確認するために内部コードに検索をかけ、"UIWebView"が含まれる前後3行を抽出しました。

Sign in
Sign in with Google
T@"UIWebView",W,N,V_webView
T@"<GIDSignInWebViewDelegate>",W,N,V_delegate
GIDSignInWebViewControllerErrorDomain
--
--
rightBarButtonItem
T@"UIBarButtonItem",&,N,VrightBarButtonItem_
T@"UIWebView",&,N,VwebView_
popViewBlock
T@?,C,N,VpopViewBlock_
--
--
GIDSignInStrings
GIDSignInWebView
UIWebViewDelegate
GIDSignInWebViewController
GIDSignInWebViewDelegate
--
--
@"<GIDSignInDelegate>"
@"<GIDSignInUIDelegate>"
c20@0:4@"UIWebView"8@"NSURLRequest"12i16
v12@0:4@"UIWebView"8
v16@0:4@"UIWebView"8@"NSError"12
@"<GIDSignInWebViewDelegate>"
--
@"<GIDSignInWebViewDelegate>"
@"UIWebView"
c20@0:4@"GIDSignInWebView"8@"NSURLRequest"12i16
v16@0:4@"GIDSignInWebView"8@"NSError"12
--
--
��K��
��$��
@_OBJC_CLASS_$_UIWebView
�������
@_OBJC_CLASS_$_UIWindow
--
--
_OBJC_CLASS_$_UIView
_OBJC_CLASS_$_UIViewController
_OBJC_CLASS_$_UIWebView
_OBJC_CLASS_$_UIWindow
_OBJC_CLASS_$_UIWindowScene
--
--
Sign in
Sign in with Google
T@"UIWebView",W,N,V_webView
T@"<GIDSignInWebViewDelegate>",W,N,V_delegate
GIDSignInWebViewControllerErrorDomain
--
--
rightBarButtonItem
T@"UIBarButtonItem",&,N,VrightBarButtonItem_
T@"UIWebView",&,N,VwebView_
popViewBlock
T@?,C,N,VpopViewBlock_
--
--
GIDSignInStrings
GIDSignInWebView
UIWebViewDelegate
GIDSignInWebViewController
GIDSignInWebViewDelegate
--
--
@"<GIDSignInUIDelegate>"
B40@0:8@16@24q32
B40@0:8@"UIWebView"16@"NSURLRequest"24q32
v24@0:8@"UIWebView"16
v32@0:8@"UIWebView"16@"NSError"24
@"<GIDSignInWebViewDelegate>"
--
@"<GIDSignInWebViewDelegate>"
@"UIWebView"
B40@0:8@"GIDSignInWebView"16@"NSURLRequest"24q32
v32@0:8@"GIDSignInWebView"16@"NSError"24
--
--
��������
���B�
@_OBJC_CLASS_$_UIWebView
���������
@_OBJC_CLASS_$_UIWindow
--
--
_OBJC_CLASS_$_UIView
_OBJC_CLASS_$_UIViewController
_OBJC_CLASS_$_UIWebView
_OBJC_CLASS_$_UIWindow
_OBJC_CLASS_$_UIWindowScene


しかし、どのライブラリが原因であるのか特定をすることができませんでした。
GIDSignInWebViewが少し怪しそうだなと思いました)

どこに原因があるかわかる方はいらっしゃいませんでしょうか?
または、何らか原因を特定する手法をご存知の方はいらっしゃいますか?
もしわかる方がいらっしゃれば、ご教授いただけると幸いです🙇‍♂️

補足情報(FW/ツールのバージョンなど)

npm list --depth=0で表示されるライブラリの一覧です。

babel/core: 7.5.5
babel/runtime: 7.5.5
firebase/firestore: 1.16.2
react-native-community/eslint-config: 0.0.3
react-native-community/geolocation: 2.0.2
babel-jest: 24.8.0
deprecated-react-native-listview: 0.0.6
eslint: 6.1.0
firebase: 7.17.1
jest: 24.8.0
metro-react-native-babel-preset: 0.61.0
react: 16.13.1
react-native: 0.60.4
react-native-action-button: 2.8.5
react-native-background-timer: 2.2.0
react-native-beacons-manager: 1.1.0
react-native-bluetooth-state: 2.0.0
react-native-elements: 2.0.4
react-native-firebase: 5.6.0
react-native-gps-state: 2.0.3
react-native-maps: 0.27.1
react-native-splash-screen: 3.2.0
react-native-vector-icons: 7.0.0
react-test-renderer: 16.8.6
unstated: 2.1.1

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

react-native-firebaseが少し古いので関連があるのではないかと思ったのですがどうでしょうか?
https://github.com/invertase/react-native-firebase/issues/2535

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.93%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る