質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.37%

Futter runでiOSシミュレータを立ち上げた時にでたエラーです(回答お願いいたします)

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,998

score 0

前提・実現したいこと

ここに質問の内容を詳しく書いてください。
現在、Flutter(名前はdirectです)でアプリ開発をしています。
flutter pub getの後にFlutter runでiOSシミュレータを立ち上げる際にエラーメッセージが発生し立ち上がりません。

発生している問題・エラーメッセージ

utsunomiya@utsunomiyanoMacBook-Pro direct % flutter run
Launching lib/main.dart on iPhone 11 in debug mode...
Running pod install...                                              1.3s
Running Xcode build...                                                  
Xcode build done.                                            4.3s
Failed to build iOS app
Error output from Xcode build:
↳
    ** BUILD FAILED **


Xcode's output:
↳
    note: Using new build system
    note: Building targets in parallel
    note: Planning build
    note: Constructing build description
    error: /Users/utsunomiya/development/direct/ios/Flutter/Debug.xcconfig: unable to open file (in target "Runner" in project "Runner") (in
    target 'Runner' from project 'Runner')
    error: /Users/utsunomiya/development/direct/ios/Flutter/Debug.xcconfig: unable to open file (in target "Runner" in project "Runner") (in
    target 'Runner' from project 'Runner')
    error: /Users/utsunomiya/development/direct/ios/Flutter/Debug.xcconfig: unable to open file (in target "Runner" in project "Runner") (in
    target 'Runner' from project 'Runner')
    warning: Capabilities for Signing & Capabilities may not function correctly because its entitlements use a placeholder team ID. To resolve this,
    select a development team in the Runner editor. (in target 'Runner' from project 'Runner')
    warning: Mapping architecture armv7 to i386. Ensure that this target's Architectures and Valid Architectures build settings are configured correctly
    for the iOS Simulator platform. (in target 'camera' from project 'Pods')
    warning: Mapping architecture arm64 to x86_64. Ensure that this target's Architectures and Valid Architectures build settings are configured
    correctly for the iOS Simulator platform. (in target 'camera' from project 'Pods')

Could not build the application for the simulator.
Error launching application on iPhone 11.

試したこと

1.rm ios/Podfile

パッケージをupgradeするために以下を記入しました。
2.pub upgrade 

3.pub run


参考にしたもの;https://stackoverflow.com/questions/59921997/could-not-build-the-application-for-the-simulator-error-launching-application-o

しかし、2の実行時に以下のエラーが生じてしおります。

utsunomiya@utsunomiyanoMacBook-Pro direct % pub upgrade
Resolving dependencies... 
Because direct depends on flutter_test any from sdk which doesn't exist (the Flutter SDK is not available),
  version solving failed.

Flutter users should run `flutter pub get` instead of `pub get`.

このエラーからpub getを行いました。 
しかし結果として上記のエラーと同じになります。

pubに原因があると思いCocoaPods インストールをしてflutter runをしてもXcodeのビルドエラーが生じてしまいました。

補足情報(FW/ツールのバージョンなど)

チュートリアルとして公式Flutterホームページは動きました。
しかし,directでは上記のようなエラーが生じてしまいます。

何かアドバイス頂けると幸いです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

+1

私もiOS向けにflutter runで実行しようとした時に下記のエラー(Xcode's output:以下に出ます)が起こることがありますが、下記2つの方法どちらかでこのエラーは解決するようですので、お試しください。
unable to open file (in target "Runner" in project "Runner") (in target 'Runner' from project 'Runner')

方法1. flutter create . を行う

flutter create . を実行
これにより設定ファイルへの参照が再設定されて動くことがあるようです。(なお、本来はプロジェクト作成用のコマンドだと思いますが、実行してもすでにあるプロジェクトの内容は消えませんでした)
参考: https://github.com/flutter/flutter/issues/22886#issuecomment-447651116

方法2. pod installを手動で行う

cd ios && pod installを実行
今回は関連は薄いように思いますが、CocoaPodsで入るパッケージの参照が途切れて動かなくなっている場合に有効のようです。
参考: https://github.com/X-Wei/flutter_catalog/issues/26#issuecomment-533885733

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.37%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る