質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.33%

Ruby on Rails 環境構築する際のエラーについて

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 252

kaji120

score 13

前提・実現したいこと

Ruby on Railsの環境構築をしたいのですが躓いてしまいました。どなたかわかる方いらっしゃいましたら御回答お願い致します。

発生している問題・エラーメッセージ

下記の gem install rails 

gem install rails --nodocument


実行後、sqliteのエラーが出てしまいました。

Could not find gem 'sqlite3 (~> 1.3.6)' in any of the gem sources listed in your Gemfile.
Run `bundle install` to install missing gems.


その後、Gemfileのgem 'sqlite3'→gem 'sqlite3', '~> 1.3.6'に書き換えbundle installしましたが、またしてもエラーが出てしまいました。

Fetching sassc 2.4.0
Installing sassc 2.4.0 with native extensions

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.
An error occurred while installing sassc (2.4.0), and Bundler cannot continue.
Make sure that `gem install sassc -v '2.4.0' --source 'https://rubygems.org/'` succeeds
before bundling.


ターミナルエラー画面

試したこと

Gemfaileの書き換え'sqlite3'→gem 'sqlite3', '~> 1.3.6'
qiitaの記事で検索

補足情報(FW/ツールのバージョンなど)

バージョン情報
ruby      2.6.5p114 (2019-10-01 revision 67812) [x86_64-linux]
sqlite3   3.6.20
gcc version  4.4.7 20120313 (Red Hat 4.4.7-23) (GCC)

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • maisumakun

    2020/08/04 09:15

    「Failed to build gem native extension.」の前後に、もう少し詳しい情報は出ていませんか?

    キャンセル

  • maisumakun

    2020/08/04 09:27

    「gcc -v」のようにして、GCCのバージョンは確認できますか?

    キャンセル

  • kaji120

    2020/08/04 09:28 編集

    ご指摘有難う御座います。
    写真で追加させて頂きました。
    まだまだ至らない点だらけだと思いますので他にご指摘など御座いましたら御願い致します。

    キャンセル

  • kaji120

    2020/08/04 09:34

    早速のご指摘有難う御座います。GCCバージョン追加させて頂きました!

    キャンセル

回答 1

checkベストアンサー

0

-std=c++11に対応できないほど古いGCCが使われているのが原因です。

ディストリビューションなどがわからないので具体的手順はコメントできませんが、もっと新しいGCC(4.8以上)を入れてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/08/04 11:31 編集

    返信遅くなり申し訳ございません。
    ディストリビューションはCentOS release 6.10 (Final)
    です。

    調べてたところHomebrewに行き当たりましたがこちらをインストールすればGCCもアップデートされると認識しておりましたが、如何でしょうか。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.33%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る