質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.48%

ポスグレが正しくインストールできない

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 735

score 34

お世話になっております。
pythonの仮想環境を作成して、postgresをインストールしたいのですが、正しくインストールができていないようです。
なにが問題なのでしょうか?

実行したコマンド

brew install postgresql@10

==> Downloading https://homebrew.bintray.com/bottles/postgresql%4010-10.13_3.catalina.bottle.tar.gz
Already downloaded: /Users/ユーザー
名/Library/Caches/Homebrew/downloads/3a476bd36901a4a56c4c3bd5712adbb54082db45b1aeb2dc144ec45d099f2f90--postgresql@10-10.13_3.catalina.bottle.tar.gz
==> Pouring postgresql@10-10.13_3.catalina.bottle.tar.gz
==> Caveats
To migrate existing data from a previous major version of PostgreSQL run:
brew postgresql-upgrade-database

postgresql@10 is keg-only, which means it was not symlinked into /usr/local,
because this is an alternate version of another formula.

If you need to have postgresql@10 first in your PATH run:
echo 'export PATH="/usr/local/opt/postgresql@10/bin:$PATH"' >> /Users/akizuki/.bash_profile

For compilers to find postgresql@10 you may need to set:
export LDFLAGS="-L/usr/local/opt/postgresql@10/lib"
export CPPFLAGS="-I/usr/local/opt/postgresql@10/include"

For pkg-config to find postgresql@10 you may need to set:
export PKG_CONFIG_PATH="/usr/local/opt/postgresql@10/lib/pkgconfig"

To have launchd start postgresql@10 now and restart at login:
brew services start postgresql@10
Or, if you don't want/need a background service you can just run:
pg_ctl -D /usr/local/var/postgresql@10 start

🍺  /usr/local/Cellar/postgresql@10/10.13_3: 1,709 files, 21.7MB 

psql --version

bash: /usr/local/bin/psql: No such file or directory

・which psql

何も表示されません。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

If you need to have postgresql@10 first in your PATH run:
echo 'export PATH="/usr/local/opt/postgresql@10/bin:$PATH"' >> /Users/akizuki/.bash_profile

これは実施したのですか?

ちなみシェルがZSHでしたら.zprofileファイルになります。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/07/28 13:08

    確実にpsqlコマンドが存在するディレクトリを確認してください。
    →申し訳御座いません。qsqlが存在するディレクトリ方法はどうしたらよろしいでしょうか?
     whichコマンドで、確認できないのですが、他に確認する方法がいろいろしらべてみましたが、見つからなくて。。。

    キャンセル

  • 2020/07/28 13:15

    lsコマンドで一覧を表示させたりfindコマンドで検索するなど、基本中の基本です。
    それすらできないなら、Finderでフォルダとして開いて下さい。

    キャンセル

  • 2020/08/01 21:32

    ありがとうございます。解決しましt

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.48%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る