質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

新規登録して質問してみよう
ただいま回答率
87.20%
PHP

PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

Laravel 5

Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。

解決済

laravel5.8.38でbensampo/laravel-enumインストール時にエラーが発生

ryau
ryau

総合スコア0

PHP

PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

Laravel 5

Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。

1回答

0評価

0クリップ

1064閲覧

投稿2020/07/25 05:21

前提・実現したいこと

laravel5.8.38でbensampo/laravel-enumインストール時にエラーが発生。
解決方法についてご教示頂きたいです。

発生している問題・エラーメッセージ

root@ae2290ee090e:/var/www/test-app# composer require bensampo/laravel-enum Do not run Composer as root/super user! See https://getcomposer.org/root for details Using version ^2.1 for bensampo/laravel-enum ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages. Problem 1 - Installation request for bensampo/laravel-enum ^2.1 -> satisfiable by bensampo/laravel-enum[v2.1.0]. - Conclusion: remove laravel/framework v5.8.38 - Conclusion: don't install laravel/framework v5.8.38 - bensampo/laravel-enum v2.1.0 requires illuminate/support ^7.5 -> satisfiable by illuminate/support[7.x-dev, v7.10.0, v7.10.1, v7.10.2, v7.10.3, v7.11.0, v7.12.0, v7.13.0, v7.14.0, v7.14.1, v7.15.0, v7.16.0, v7.16.1, v7.17.0, v7.17.1, v7.17.2, v7.18.0, v7.19.0, v7.19.1, v7.20.0, v7.21.0, v7.5.0, v7.5.1, v7.5.2, v7.6.0, v7.6.1, v7.6.2, v7.7.0, v7.7.1, v7.8.0, v7.8.1, v7.9.0, v7.9.1, v7.9.2]. - don't install illuminate/support 7.x-dev|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.10.0|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.10.1|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.10.2|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.10.3|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.11.0|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.12.0|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.13.0|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.14.0|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.14.1|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.15.0|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.16.0|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.16.1|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.17.0|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.17.1|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.17.2|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.18.0|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.19.0|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.19.1|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.20.0|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.21.0|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.5.0|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.5.1|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.5.2|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.6.0|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.6.1|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.6.2|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.7.0|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.7.1|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.8.0|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.8.1|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.9.0|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.9.1|don't install laravel/framework v5.8.38 - don't install illuminate/support v7.9.2|don't install laravel/framework v5.8.38 - Installation request for laravel/framework (locked at v5.8.38, required as 5.8.*) -> satisfiable by laravel/framework[v5.8.38]. Installation failed, reverting ./composer.json to its original content.

試したこと

composer update実行後、再度インストールを試みましたが失敗しました。

補足情報(FW/ツールのバージョンなど)

composer.lock抜粋

"name": "laravel/framework", "version": "v5.8.38",

良い質問の評価を上げる

以下のような質問は評価を上げましょう

  • 質問内容が明確
  • 自分も答えを知りたい
  • 質問者以外のユーザにも役立つ

評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

気になる質問をクリップする

クリップした質問は、後からいつでもマイページで確認できます。

またクリップした質問に回答があった際、通知やメールを受け取ることができます。

teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

  • プログラミングに関係のない質問
  • やってほしいことだけを記載した丸投げの質問
  • 問題・課題が含まれていない質問
  • 意図的に内容が抹消された質問
  • 過去に投稿した質問と同じ内容の質問
  • 広告と受け取られるような投稿

評価を下げると、トップページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

まだ回答がついていません

会員登録して回答してみよう

15分調べてもわからないことは
teratailで質問しよう!

ただいまの回答率
87.20%

質問をまとめることで
思考を整理して素早く解決

テンプレート機能で
簡単に質問をまとめる

質問する

関連した質問

同じタグがついた質問を見る

PHP

PHPは、Webサイト構築に特化して開発されたプログラミング言語です。大きな特徴のひとつは、HTMLに直接プログラムを埋め込むことができるという点です。PHPを用いることで、HTMLを動的コンテンツとして出力できます。HTMLがそのままブラウザに表示されるのに対し、PHPプログラムはサーバ側で実行された結果がブラウザに表示されるため、PHPスクリプトは「サーバサイドスクリプト」と呼ばれています。

composer

Composerとは、PHP5.3.2以上で使用可能なパッケージ管理ツールです。指定ディレクトリ内だけでパッケージ管理します。

Laravel 5

Laravel 5は、PHPフレームワークLaravelの最新バージョンで、2014年11月に発表予定です。ディレクトリ構造がが現行版より大幅に変更されるほか、メソッドインジェクションやFormRequestの利用が可能になります。