質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

90.34%

ビューとコントローラーが作れないのはどうしてでしょうか?

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 2,742

manman

score 266

OS:windows10

http://openbook4.me/projects/92/sections/488
を見ながら、
rails g controller users index show
を実行したところ、

Could not find gem 'sass-rails (~> 5.0) x64-mingw32' in any of the gem sources listed in your Gemfile or available on this machine.
Run `bundle install` to install missing gems.

というメッセージが出たので、
bundle install
を実行したのですが、再び

Could not find gem 'sass-rails (~> 5.0) x64-mingw32' in any of the gem sources listed in your Gemfile or available on this machine.
Run `bundle install` to install missing gems.


というエラーが出てきます。
どのようにビューとコントローラーを作ればよいか教えてください。

(追記)
bundle install を繰り返すと以下のエラーがでてきました。

Fetching gem metadata from https://rubygems.org/...........
Fetching version metadata from https://rubygems.org/...
Fetching dependency metadata from https://rubygems.org/..
Resolving dependencies.............
Using rake 10.5.0
Using i18n 0.7.0
Installing json 1.8.3 with native extensions

Gem::InstallError: The 'json' native gem requires installed build tools.

Please update your PATH to include build tools or download the DevKit
from 'http://rubyinstaller.org/downloads' and follow the instructions
at 'http://github.com/oneclick/rubyinstaller/wiki/Development-Kit'
Using minitest 5.8.4
Using thread_safe 0.3.5
Using builder 3.2.2
Using erubis 2.7.0
Using mini_portile2 2.0.0
Using rack 1.6.4
Using mime-types 2.99
Using arel 6.0.3
Installing debug_inspector 0.0.2 with native extensions

Gem::InstallError: The 'debug_inspector' native gem requires installed build tools.

Please update your PATH to include build tools or download the DevKit
from 'http://rubyinstaller.org/downloads' and follow the instructions
at 'http://github.com/oneclick/rubyinstaller/wiki/Development-Kit'
Using bundler 1.11.2
Installing byebug 8.2.2 with native extensions

Gem::InstallError: The 'byebug' native gem requires installed build tools.

Please update your PATH to include build tools or download the DevKit
from 'http://rubyinstaller.org/downloads' and follow the instructions
at 'http://github.com/oneclick/rubyinstaller/wiki/Development-Kit'
Using coffee-script-source 1.10.0
Using execjs 2.6.0
Using thor 0.19.1
Using concurrent-ruby 1.0.0
Using multi_json 1.11.2
Using sass 3.4.21
Using tilt 2.0.2
Using sqlite3 1.3.11
An error occurred while installing json (1.8.3), and Bundler cannot continue.
Make sure that `gem install json -v '1.8.3'` succeeds before bundling.

DEVELOPMENT KITインストール後

C:\devkit>ruby dk.rb init

Initialization complete! Please review and modify the auto-generated
'config.yml' file to ensure it contains the root directories to all
of the installed Rubies you want enhanced by the DevKit.

C:\devkit>ruby dk.rb install
Invalid configuration or no Rubies listed. Please fix 'config.yml'
and rerun 'ruby dk.rb install'

C:\devkit>


というエラーが出ています。config.yml をどう編集すればよいでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+2

下記のサイトを参考にDevKitをインストール(展開して、config.ymlを編集して、ruby devkit.rb installを実行)して下さい。DevKitはRuby Installerのサイトからダウンロードできます。
http://qiita.com/shimoju/items/41035b213ad0ac3a979e
http://www.rubylife.jp/railsinstall/rails/index4.html
http://yohshiy.blog.fc2.com/blog-entry-240.html
※ 64bit版をお使いのようですので、DevKitは DevKit-mingw64-64-4.7.2-20130224-1432-sfx.exe を入れて下さい。


疑問についての解説していきます。

bundle installはRailsで必要になるRubyの拡張ライブラリをインストールするコマンドです。Gemfilesというファイルに必要なライブラリが記載されており、その依存関係を含めて自動で全てインストールしてくれます。逆に言うと必要なライブラリが欠けていると、正常に動作することが出来ません。bundle installが成功しない限り、Railsが動くことはないでしょう。

Rubyの拡張ライブラリの作りには大きく二種類あります。Rubyのみで書かれたライブラリと、C言語※で書かれたライブラリです。Rubyのみで書かれたライブラリはすぐに利用可能ですが、C言語で書かれたライブラリはコンパイルする必要があります。ライブラリによってはコンパイル済みのファイルも配付されている場合がありますが、ほとんどの場合は、必ずC言語のコンパイラが必要になります。例えば、Linuxではyumやapt-get等でgcc等をインストールしておく必要がありますし、MacであればXcodeをインストールしておく必要があります。
※ C言語だけでなくC++言語等の任意の言語で作成可能ですが、インターフェース部分はC言語です。またJRuby用のJavaで書かれたライブラリも存在します。

Windowsの場合は更にちょっと複雑です。WindowsでC言語をコンパイルする場合、主に3つのコンパイラがあります。

  • Visual C++ (Visual Studioについてきます)
  • Mingw版 GCC (いくつか種類があります)
  • Cygwin版 GCC

Ruby本体もこれらのコンパイラのどれか一つを用いて、コンパイルされています。そして、拡張ライブラリはRuby本体に使用したコンパイラと同じコンパイラでコンパイルする必要があります。Ruby Installerの場合は、DevKitとして配付されているMingw版 GCCですのでDevKitが必要になります。もし、ActiveScriptRubyでしたら、Visual C++を使用していますので、Visual C++が必要になります。これらはどのRubyをインストールしたかによって異なるため、注意して下さい。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/02/14 11:18

    後、config.yml にrubyのパスを書き込むとうまくいきました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 90.34%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る