質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.11%

ubuntu:コマンドからどのパッケージかを知るコマンドが知りたい

解決済

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 1,634

score 280

既存の使えるコマンドからどのパッケージに含まれていたかを知るのではなく。調べたらたくさんでてきました(笑)
まだ使えないコマンドからどのパッケージに含まれているかをコマンドで知りたいです。

apt-add-repositoryというコマンドを使いたいときに、どのパッケージを入れたら使えるかを表示してくれるコマンドを知りたいです。
例えば、apt-add-repositoryコマンドを使うため必要なパッケージを入れていないときに、このコマンドを実行しようとすると、エラー文に「apt-get install software-properties-commonを実行して下さい」と出てきます。
これをコマンドで 〇〇〇 apt-add-repository と実行したら「software-properties-commonのパッケージが必要です」と表示してくれるコマンドが知りたいです。

よろしくお願いします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

こんな感じでしょうか?

$ which apt-file
/usr/bin/apt-file

$ apt-file find /usr/bin/apt-file
apt-file: /usr/bin/apt-file

$ which docker
/usr/bin/docker

$ apt-file find /usr/bin/docker
docker-compose: /usr/bin/docker-compose
docker.io: /usr/bin/docker

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/02/12 18:15

    回答ありがとうございます。

    whichコマンドで探せるものは既に必要なパッケージが入っていますよね。
    コマンドだけ知っていてどのパッケージか知らない場合に
    そのコマンドはこのパッケージですと教えてくれるコマンドが知りたいですm(__)m

    キャンセル

  • 2016/02/12 21:29 編集

    上記ご回答させて戴いました、 apt-file をお試しください。
    whichで見つからない例にすればよかったのでしょうか。。。

    $ which /usr/bin/yum
    $ apt-file find /usr/bin/yum
    yum: /usr/bin/yum
    yum-utils: /usr/bin/yum-builddep
    yum-utils: /usr/bin/yum-config-manager
    yum-utils: /usr/bin/yum-groups-manager
    yum-utils: /usr/bin/yumdownloader

    キャンセル

  • 2016/02/15 22:35

    返信ありがとうございます。
    試してみました。
    # dokcer
    bash: docker: command not found
    #apt-file find /etc/init.d/docker
    docker.io :/etc/init.d/docker

    dokcerコマンドを使用したかったらdocker.ioパッケージを入れてくださいということですね。

    いつもありがとうございます。解決できましたm(__)m

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.11%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る