質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.61%

Pythonのモジュールimportについてのエラー

解決済

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 1,316

score 2

前提・実現したいこと

Python1年生という書籍で勉強している初心者です

ここに質問の内容を詳しく書いてください。
表題の書籍で初歩的な勉強をしています。
135ページに記載のコードを書いておりますが、エラーが出てしまいます。
ターミナルでpip3 install pillowを入れると以下のコードが返ってきます。

Requirement already satisfied: pillow in ./.pyenv/versions/3.6.5/lib/python3.6/site-packages
You are using pip version 9.0.3, however version 20.1.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

発生している問題・エラーメッセージ

Traceback (most recent call last):
File "/Users/XXX/Documents/dispimage1.py", line 3, in <module>
import PIL.Image
ModuleNotFoundError: No module named 'PIL'

該当のソースコード

import tkinter as tk
import tkinter.filedialog as fd
import PIL.Image
import PIL.ImageTk

def dispPhoto(path):
newImage=PIL.Image.open(path).resize((300,300))
imageData=PIL.ImageTk.PhotoImage(newImage)
imageLabel.configure(image=imageData)
imageLabel.image=imageData

def openFile():
fpath=fd.askopenfilename()
if fpath:
dispPhoto(fpath)

root=tk.Tk()
root.geometry("400x350")

btn=tk.Button(text="ファイルを開く",command=openFile)
imageLabel=tk.Label()
btn.pack()
imageLabel.pack()
tk.mainloop()

試したこと

モジュールをimportするところでエラーメッセージが出てしまいます。
恥ずかしながら超初心者なので、解決できませんでした。

補足情報(FW/ツールのバージョンなど)

ご教示のほどよろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • yakitorii

    2020/06/11 00:14

    ターミナルで
    python -V
    python
    と打つと結果はどうなりますか?

    キャンセル

  • akito.h

    2020/06/11 01:07 編集

    それぞれ、
    Python 3.7.6



    Python 3.7.6 (default, Jan 8 2020, 13:42:34)
    [Clang 4.0.1 (tags/RELEASE_401/final)] :: Anaconda, Inc. on darwin
    Type "help", "copyright", "credits" or "license" for more information.
    >>>

    とでます。
    idleでは、Python3.8.3 shellとなるので、この辺りが原因でしょうか?

    キャンセル

  • yakitorii

    2020/06/11 01:38

    あれ、anacondaのpythonが実行されてますね。
    実行している環境とpillowをインストールしている環境が違うのでは?
    https://teratail.com/questions/262543
    anacondaの方にpillowを入れたら上手くいくかもしれません。

    キャンセル

  • akito.h

    2020/06/11 23:13

    ありがとうございます。その記事は以前見ました。
    ただ、どうにも以下の部分のやり方がわからず・・・

    コマンドプロンプトから実行すればPillowが認識されるはずです。
    また、IDLEでも起動するシェルをPython3.8の方に切り替えられればエラーは解消すると思います。私はIDLEを使ってないのでシェルの切り替えについては調べてみてください。

    キャンセル

回答 2

checkベストアンサー

+2

pyenvでpythonをインストールしているのでしたら、コマンド名は
pythonとpipで良いです。わざわざ「3」をつける必要はありません。

python is /Users/ユーザ名/.pyenv/shims/python
pip is /Users/ユーザ名/.pyenv/shims/pip

python3とかpip3と実行すると、別の場所にインストールされている
pythonが実行される可能性がありますので、やめたほうがいいです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/06/11 23:21

    pythonもpipも、anaconda3のコマンドが最優先になってますのでOKです。
    pyenvを環境変数PATHから外しましょう。

    ちなみに、/usr/bin/pythonはMacOS標準のPythonです。
    /usr/binはPATHに含める必要があるので、これは外しようがないです。

    anacondaの場合、パッケージはcondaコマンドを使うのが基本です。
    condaコマンドでインストールできない場合に限り、pipコマンドでインストールします。

    キャンセル

  • 2020/06/11 23:26

    ありがとうございます。調べながら見様見真似でpyenvをアンインストールしたら、無事importができるようになりました。今後コマンドについても頭に入れておきます。ありがとうございました。

    キャンセル

  • 2020/06/11 23:32

    >pyenvをアンインストールしたら
    アンインストールだけでなく、pyenvを環境変数PATHから外しましたか?
    余計なPATHを残しておくとトラブルの元ですから。

    キャンセル

+1

PILはPython本体には含まれないパッケージなのでこれに従って入れてみてください。

pip自体のバージョンが古すぎるようなので、pip3 install --upgrade pipを先に実行してみてください。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/06/11 00:05

    idleはpyenv経由で起動してます?(ライブラリ自体は入っているみたいなので疑うならこのへんかなと思います)

    キャンセル

  • 2020/06/11 01:05

    ごめんなさい、pyenv経由の起動方法がわからないのですが、アプリケーション一覧のpythonから入って起動しています。

    キャンセル

  • 2020/06/11 01:10

    pyenvが有効になっているターミナルでpython -m idlelib.idleを立ち上げてそこから実行するか、直接スクリプトを実行したら上手くいかないでしょうか。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.61%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る