質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.62%

Railsチュートリアル1章でHerokuへデプロイ出来ない

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 235

kii_log

score 5

前提・実現したいこと

Railsチュートリアル1章でHerokuへデプロイ出来ずつまっています。

発生している問題・エラーメッセージ

$ git push heroku master した時以下のエラーメッセージが出ます。

remote:  !
remote:  !     Could not detect rake tasks
remote:  !     ensure you can run `$ bundle exec rake -P` against your app
remote:  !     and using the production group of your Gemfile.
remote:  !     rake aborted!
remote:  !     ActiveRecord::DatabaseConfigurations::InvalidConfigurationError: '{ default =>  }' is not a valid configuration. Expected '' to be a URL string or a Hash.
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/activerecord-6.0.3/lib/active_record/database_configurations.rb:152:in `build_db_config_from_raw_config'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/activerecord-6.0.3/lib/active_record/database_configurations.rb:126:in `block in build_configs'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/activerecord-6.0.3/lib/active_record/database_configurations.rb:122:in `each'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/activerecord-6.0.3/lib/active_record/database_configurations.rb:122:in `flat_map'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/activerecord-6.0.3/lib/active_record/database_configurations.rb:122:in `build_configs'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/activerecord-6.0.3/lib/active_record/database_configurations.rb:18:in `initialize'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/activerecord-6.0.3/lib/active_record/tasks/database_tasks.rb:159:in `new'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/activerecord-6.0.3/lib/active_record/tasks/database_tasks.rb:159:in `for_each'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/activerecord-6.0.3/lib/active_record/railties/databases.rake:28:in `block (2 levels) in <main>'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/rake-12.3.3/lib/rake/task_manager.rb:225:in `in_namespace'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/rake-12.3.3/lib/rake/dsl_definition.rb:141:in `namespace'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/activerecord-6.0.3/lib/active_record/railties/databases.rake:23:in `block in <main>'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/rake-12.3.3/lib/rake/task_manager.rb:225:in `in_namespace'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/rake-12.3.3/lib/rake/dsl_definition.rb:141:in `namespace'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/activerecord-6.0.3/lib/active_record/railties/databases.rake:7:in `<main>'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:69:in `load'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:69:in `rescue in load'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.4.5/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:52:in `load'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/activesupport-6.0.3/lib/active_support/dependencies.rb:318:in `block in load'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/activesupport-6.0.3/lib/active_support/dependencies.rb:291:in `load_dependency'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/activesupport-6.0.3/lib/active_support/dependencies.rb:318:in `load'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/activerecord-6.0.3/lib/active_record/railtie.rb:49:in `block in <class:Railtie>'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/railties-6.0.3/lib/rails/railtie.rb:245:in `instance_exec'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/railties-6.0.3/lib/rails/railtie.rb:245:in `block in run_tasks_blocks'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/railties-6.0.3/lib/rails/railtie.rb:253:in `each'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/railties-6.0.3/lib/rails/railtie.rb:253:in `each_registered_block'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/railties-6.0.3/lib/rails/railtie.rb:245:in `run_tasks_blocks'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/railties-6.0.3/lib/rails/application.rb:517:in `block in run_tasks_blocks'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/railties-6.0.3/lib/rails/engine/railties.rb:15:in `each'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/railties-6.0.3/lib/rails/engine/railties.rb:15:in `each'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/railties-6.0.3/lib/rails/application.rb:517:in `run_tasks_blocks'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/railties-6.0.3/lib/rails/engine.rb:459:in `load_tasks'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/Rakefile:6:in `<top (required)>'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/rake-12.3.3/lib/rake/rake_module.rb:29:in `load'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/rake-12.3.3/lib/rake/rake_module.rb:29:in `load_rakefile'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/rake-12.3.3/lib/rake/application.rb:703:in `raw_load_rakefile'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/rake-12.3.3/lib/rake/application.rb:104:in `block in load_rakefile'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/rake-12.3.3/lib/rake/application.rb:186:in `standard_exception_handling'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/rake-12.3.3/lib/rake/application.rb:103:in `load_rakefile'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/rake-12.3.3/lib/rake/application.rb:82:in `block in run'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/rake-12.3.3/lib/rake/application.rb:186:in `standard_exception_handling'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/rake-12.3.3/lib/rake/application.rb:80:in `run'
remote:  !     /tmp/build_00af613d29d2adf087b6031ec55215d8/vendor/bundle/ruby/2.6.0/gems/rake-12.3.3/exe/rake:27:in `<top (required)>'
remote:  !     ./vendor/bundle/bin/rake:29:in `load'
remote:  !     ./vendor/bundle/bin/rake:29:in `<main>'
remote:  !     
remote:  !     Caused by:
remote:  !     Bootsnap::LoadPathCache::FallbackScan:
remote:  !
remote: /app/tmp/buildpacks/b7af5642714be
 ! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to 'https://git.heroku.com/enigmatic-falls-64866.git'


また、$ heroku run rails consoleで確認すると以下のようになります。

Running rails console on ⬢ enigmatic-falls-64866... up, run.1013 (Free)
bash: rails: command not found


Gemfile

source 'https://rubygems.org'
git_source(:github) { |repo| "https://github.com/#{repo}.git" }

gem 'rails',      '6.0.3'
gem 'puma',       '4.3.4'
gem 'sass-rails', '5.1.0'
gem 'webpacker',  '4.0.7'
gem 'turbolinks', '5.2.0'
gem 'jbuilder',   '2.9.1'
gem 'bootsnap',   '1.4.5', require: false

group :development, :test do
  gem 'sqlite3', '1.4.1'
  gem 'byebug',  '11.0.1', platforms: [:mri, :mingw, :x64_mingw]
end

group :development do
  gem 'web-console',           '4.0.1'
  gem 'listen',                '3.1.5'
  gem 'spring',                '2.1.0'
  gem 'spring-watcher-listen', '2.0.1'
end

group :test do
  gem 'capybara',           '3.28.0'
  gem 'selenium-webdriver', '3.142.4'
  gem 'webdrivers',         '4.1.2'
end

group :production do
  gem 'pg', '1.1.4'
end

試したこと

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

エラーメッセージにpre-receive hook declinedとありますので、git pushする手前の処理でエラーが起きていると推測されます。

そしてエラーメッセージを改めて見てみると、

ActiveRecord::DatabaseConfigurations::InvalidConfigurationError: '{ default =>  }' is not a valid configuration. Expected '' to be a URL string or a Hash.

とありますので、データベース定義周りに何か問題がありそうな気がします。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.62%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る