質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.61%

VscodeのRemote-Containerを使用したときAn error occurred setting up the containerと出る。

受付中

回答 0

投稿

  • 評価
  • クリップ 0
  • VIEW 921

score 34

DockerでVueの環境構築をして、VscodeのRemote-Containerで開こうとした際に「An error occurred setting up the container」と出てしまいました。

実際にやった手順
Vscodeの左下の緑のマークをクリック→Open Folder in Containerをクリック→appディレクトリを選択→上記のエラー
そもそもの問題でDockerfile自体に問題があるのでしょうか?
どうかご享受お願いします。

OS:Win10Home
DockerToolbox使用

ディレクトリ構造
app
├─docker-compose.yml
├─.devcontainer
│  ├─devcontainer
│ └─docker-compose.yml
├─docker
│  └─Dockerfile

├─server
│  ├─src
│  ├─node_modules
│  ├─dist
│  ├─myapp
│  ├─static
│  ├─.babelrc
│  ├─index.html
│  ├─.babelrc
│  └─package.json

Dockerfile

FROM node:8.11.3-alpine
WORKDIR /myapp
RUN apk update && \
    npm install && \
    npm install -g npm && \
    npm install -g vue-cli


docker-compose.yml

**version: '3'
services: 
 zatubako:
  container_name: zatubako
  build: ./docker
  ports:
   - 8080:8080
  privileged: true
  volumes:
   - ./server:/myapp
  tty: true
  stdin_open: true
  command: /bin/sh**
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正の依頼

  • zembutsu

    2020/06/05 08:33

    ありがとうございます。1.24.1 であれば、去年6月にリリースされたものですので、Compose のバージョンが古いのが原因ではなさそうですね。

    そうしましたら、次は、もっとシンプルな docker-compose.yaml を記述して、動作するかどうかの確認をされてみてはいかがでしょうか。限りなく簡単なコンテナの起動でもエラーが起こるようであれば、VScode まわりの設定確認が必要になりそうです。

    キャンセル

  • Tikka123456

    2020/06/06 00:23

    シンプルなdocker-compose.ymlとはどのような感じでしょうか?

    キャンセル

  • zembutsu

    2021/04/11 05:23

    「build: ./docker」を使わずに、単純な公式イメージを実行するだけでもエラーが出るかどうかが確認ポイントの1つです。それと、VSCodeのターミナル上で何かエラーが出ていれば、それが原因解決につながります。

    キャンセル

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.61%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る