質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.09%

zshシェルへの変更に伴うエラー

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 169

Q-tip

score 13

よろしくお願いいたします。

PCはMacBookPro 2019モデル(Catalina 10.15.4)です。

先日、シェルの変更をしておこうと思い、bashよりもzshが推奨されていたため、デフォルトシェルをzshへ切り替えました。

その後、ターミナルにて特定のコマンドを行うと理解し難いエラーが発生してしまい、困っております。

pwdやlsなどのコマンドは問題なく動作いたしますが、
php -v
laravel new

などを行うと以下のエラーが出現してしまいます。

MacBook-Pro:~ admin$ php -v
dyld: Library not loaded: /usr/local/opt/icu4c/lib/libicui18n.64.dylib
  Referenced from: /usr/local/opt/php@7.2/bin/php
  Reason: image not found
Abort trap: 6


MacBook-Pro:Desktop admin$ laravel new ******(ディレクトリ名)
dyld: Library not loaded: /usr/local/opt/icu4c/lib/libicui18n.64.dylib
  Referenced from: /usr/local/opt/php@7.2/bin/php
  Reason: image not found
Abort trap: 6

これまで、bashシェルでの運用時にはこのようなエラーが発生していなかったので、zshシェルへの変更によるものなのか不明です。

また、Reason: image not foundへの対応がググったところ、記事ごとに違っているため、シェル変更など以外の
関連情報の提示が必要かどうかもわかりません。

情報が不十分かもしれませんが、何かアドバイスいただけますと幸いです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

0

bashでは、.bash_profileや.bashrcファイルにPATHなどの環境変数を記述しますが、
zshでは、.zprofile、.zshrcファイルに記述します。

必要な設定の記述を移し替えてみてください。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/05/23 19:29

    ご回答ありがとうございました。

    どうやら、原因と思われるのはzshの環境変数SHELL設定、手持ちのPHPが7.2のバージョンであったことと、Pathの通し忘れ、またその後composer installを実行したところ解決いたしました。

    まず、サーバーを立ち上げようとしたら、上述のエラーが出ていたのでご指摘の環境変数よりシェルを確認したところ、/bin/bashになっておりました....

    なので、こちらを

    SHELL=/usr/local/bin/zshへ修正
    (vimのinsertでこちらのpath記述がなかったため、追記したと思います(記憶曖昧))

    その後、homebrewでphpの7.3をインストール(yumが使えなかったのでbrewより取得)

    exportコマンドよりPathを通し、php7.3を反映(php -v でバージョン変更を確認)

    composer installを実行。
    解決しました。

    *そもそもphp7.3にバージョンアップしたのは別のエラーでartisanファイルのautolodedをphpバージョンが7.2以下のため要求できないと出ていたためでした。結果的にはバージョンを7.3にしても別エラーが出ていたので、問題がどこに起因するかわかりにくかったです。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.09%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる