質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.81%

Windows10 「rails s」を起動できない。localhost:3000にアクセスできない

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 1
  • VIEW 360

uclowx

score 2

初学者です。初歩的な質問だと思いますが、環境構築のところで躓いてしまったのでご教示頂けたら助かります。
Windows10環境下でRails serverを起動しようとトライしています。

コマンドプロンプトから

ruby -vで実行すると、
ruby 2.3.3p222 (2016-11-21 revision 56859) [i386-mingw32]

rails -vで実行すると
Rails 5.1.7

と返ってきています。アプリケーション名を「book」にする予定だったので、

rails new book

と実行し、C:\Users\81804の中に「book」というフォルダが生成されました。

cmdから「cd book」と実行し、bookディレクトリまで移動し、そこで「rails s」と実行したところ以下のようなエラーが表示されました。

Could not find gem 'turbolinks (~> 5) x86-mingw32' in any of the gem sources listed in your Gemfile.
Run `bundle install` to install missing gems.

ここで「bundle install」とコマンドプロンプトで実行してみました。するとしばらく文字列が綴られ、テキスト下部のほうを読んでみると、エラーを起こしていることがわかりました。エラーメッセージはこのような内容でした。

An error occurred while installing sqlite3 (1.4.2), and Bundler cannot continue.
Make sure that `gem install sqlite3 -v '1.4.2' --source 'https://rubygems.org/'`
succeeds before bundling.

In Gemfile:
  sqlite3

このような内容でした。エラー文から「gem install sqlite3 -v '1.4.2' --source 'https://rubygems.org/」とコマンドプロンプトで実行すればいいのか?と解釈し、こちらを入力してみると

Gem files will remain installed in C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/sqlite3-1.4.2 for inspection.
Results logged to C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/extensions/x86-mingw32/2.3.0/sqlite3-1.4.2/gem_make.out

と書かれ、何やら成功しているようにみえるのですが、いざ改めて「rails s」を実行してみると

Could not find gem 'turbolinks (~> 5) x86-mingw32' in any of the gem sources listed in your Gemfile.
Run `bundle install` to install missing gems.

また同じエラーが発生する、という状況に陥ってます。
関係ないかもしれませんが、ウイルスバスターは無効にしてあります。

どなたかご助言いただけないでしょうか。

使用PC環境は以下の通りです。
・Windows10 Home
・Intel Corei7-8550U CPU 1.80GHz 1.99GHz
・実装メモリ16.0GB
・64ビットオペレーティングシステム,×64ベースプロセッサ

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

【まだ解決していません】
https://teratail.com/questions/176355
こちらのご質問内容に非常に近しかったので早速トライしてみました。有効と思われる回答↓
「sqlite3の1.4.0と言うバージョンはrailsと相性が悪く、使えません。Gemfile内で以下のようにバージョンを指定してください」

gem 'sqlite3', '~> 1.3.6'


私には「gemfile」が何なのかわからなかったのですが、新たに生成したディレクトリ内に「Gemfile」という2KBくらいのファイルがあったので、これをVS Codeで開き、

gem 'sqlite3' と書かれていたところを
→gem 'sqlite3', '~> 1.3.6'
に書き換えて上書き保存してみました。

そして、もう一度コマンドプロンプトで、こちらのディレクトリまで移動し「Rails s」と実行してみましたが、やはり

Could not find gem 'turbolinks (~> 5) x86-mingw32' in any of the gem sources listed in your Gemfile.
Run `bundle install` to install missing gems.

というエラーが返ってきてしまいます...。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/05/17 21:58

    >ruby -vで実行すると、
    >ruby 2.3.3p222 (2016-11-21 revision 56859) [i386-mingw32]
    4年前のRubyですか?
    こんな古いRubyを使う理由があるのでしょうか?
    RubyInstallersの推奨はRuby+Devkit 2.6.X (x64)ですし、
    2.5系ならRuby+Devkit 2.5.8-1 (x64)です。
    もう少し新しいRubyを使った方が良いと思いますが。
    https://rubyinstaller.org/downloads/

    キャンセル

  • 2020/05/17 22:39

    本当ですね...。
    インストールしたときは「 Ruby+Devkit 2.6.6-1 (x64)」を選択したはずなんですが...なぜでしょう。
    ちなみにインストールした後で、RubyのVersionをアップデートする方法などご存知ではないでしょうか?

    キャンセル

  • 2020/05/17 22:58 編集

    Linux/MacOSならrbenvというツールで複数のRubyをインストールして
    切り替えられます。
    $ rbenv versions
     system
     2.5.8
     2.6.6
    * 2.7.1 (set by /Users/xxxx/.rbenv/version)

    Windows用の切り替えツールを探してみてはいかがでしょう。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.81%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る