質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.36%

pipがアップグレードできません

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 12K+

score 8

Python初心者です。
pipをアップグレードしようとすると下記のようなエラーが出てしまいます。
色々なサイトで調べたのですが解決できず困っています。
教えいただけるとありがたいです。よろしくお願い致します。
因みに

windows10
Python2.7.11

を使っています。
C:\Users\翼>python -m pip install --upgrade pip
Collecting pip
Exception:
Traceback (most recent call last):
  File "c:\python27\lib\site-packages\pip\basecommand.py", line 211, in main
    status = self.run(options, args)
  File "c:\python27\lib\site-packages\pip\commands\install.py", line 294, in run
    requirement_set.prepare_files(finder)
  File "c:\python27\lib\site-packages\pip\req\req_set.py", line 334, in prepare_files
    functools.partial(self._prepare_file, finder))
  File "c:\python27\lib\site-packages\pip\req\req_set.py", line 321, in _walk_req_to_install
    more_reqs = handler(req_to_install)
  File "c:\python27\lib\site-packages\pip\req\req_set.py", line 491, in _prepare_file
    session=self.session)
  File "c:\python27\lib\site-packages\pip\download.py", line 825, in unpack_url
    session,
  File "c:\python27\lib\site-packages\pip\download.py", line 673, in unpack_http_url
    from_path, content_type = _download_http_url(link, session, temp_dir)
  File "c:\python27\lib\site-packages\pip\download.py", line 884, in _download_http_url
    file_path = os.path.join(temp_dir, filename)
  File "c:\python27\lib\ntpath.py", line 85, in join
    result_path = result_path + p_path
UnicodeDecodeError: 'ascii' codec can't decode byte 0x97 in position 7: ordinal not in range(128)
You are using pip version 7.1.2, however version 8.0.2 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' command.

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

check解決した方法

0

長らくpipを使わず放置していたのですが、先日解決したので方法を載せたいと思います。

以前は下記のようなエラーが出て、pipが使えませんでした。
C:\Users\翼>python -m pip install --upgrade pip 
Collecting pip 
Exception: 
Traceback (most recent call last): 
File "c:\python27\lib\site-packages\pip\basecommand.py", line 211, in main 
status = self.run(options, args) 
File "c:\python27\lib\site-packages\pip\commands\install.py", line 294, in run 
requirement_set.prepare_files(finder) 
File "c:\python27\lib\site-packages\pip\req\req_set.py", line 334, in prepare_files 
functools.partial(self._prepare_file, finder)) 
File "c:\python27\lib\site-packages\pip\req\req_set.py", line 321, in _walk_req_to_install 
more_reqs = handler(req_to_install) 
File "c:\python27\lib\site-packages\pip\req\req_set.py", line 491, in _prepare_file 
session=self.session) 
File "c:\python27\lib\site-packages\pip\download.py", line 825, in unpack_url 
session, 
File "c:\python27\lib\site-packages\pip\download.py", line 673, in unpack_http_url 
from_path, content_type = _download_http_url(link, session, temp_dir) 
File "c:\python27\lib\site-packages\pip\download.py", line 884, in _download_http_url 
file_path = os.path.join(temp_dir, filename) 
File "c:\python27\lib\ntpath.py", line 85, in join 
result_path = result_path + p_path 
UnicodeDecodeError: 'ascii' codec can't decode byte 0x97 in position 7: ordinal not in range(128) 
You are using pip version 7.1.2, however version 8.0.2 is available. 
You should consider upgrading via the 'python -m pip install --upgrade pip' command.

下記のエラーを解決するには
UnicodeDecodeError: 'ascii' codec can't decode byte 0x97 in position 7: ordinal not in range(128)

File "c:\python27\lib\site-packages\の下にsitecustomize.pyを作成し、

import sys
sys.defaultencoding("utf-8")


その後コマンドプロントで

import sys
sys.setdefaultencoding("utf-8")


と入力すると、pipが使えるようになるそうです。
私の場合、これでも解決しなかったので("utf-8")のところを("mbcs")に変えたら使えるようになりました。
因みにデフォルトエンコーディングを確認するにはコマンドプロントで下記を入力すると確認できます。

import sys
sys.getdefaultencoding()


拙い説明で申し訳ございません。
参考ページ
(http://d.hatena.ne.jp/shu223/20111201/1328334689)
(http://yukihir0.hatenablog.jp/entry/20110131/1296478348)
(http://programmemo.hatenadiary.jp/entry/2014/11/30/161603) 

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

コマンドプロントを管理者権限で実行して"python -m pip install --upgrade pip"

もしくは

カレントディレクトリがC:\Users\翼と「翼」という漢字が入っているので、漢字の入っていないディレクトリで"python -m pip install --upgrade pip"を実行してみてはいかがでしょうか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/01/31 15:30

    ご回答ありがとうございます。
    どちらもやってみたのですが同じようにエラーが出てしまいました...

    キャンセル

  • 2016/01/31 21:17 編集

    'ascii' codec can't decode byte 0x97 in position 7 のエラー原因は「翼」
    http://interscript.sourceforge.net/interscript/doc/en_shiftjis_0028.html
    のようです。

    一度、windowsで「英語名のユーザ」を作成してpip version 7.1.2をインストールして、同じように
    python -m pip install --upgrade pip
    してみてはいかがでしょうか?

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.36%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る