質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.77%

Vagrant fileが生成できません。

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 584

score 4

vagrantからosを起動したいのですが、上手くいきません汗

$ cd /Users/***/Desktop/
$ mkdir pacificmall
$ cd pacificamall
とここまでこれたのですが、下記のコマンドを記述すると作成されないうえに本来1.0-versionと表示される箇所が["ox-version"]となってしまいます。reinstallや再起動は試しましたがダメでした。

最終ゴールとしてはKUSANAGIを起動したいです。そのvagrantのboxもhttps://app.vagrantup.com/prime-strategy/boxes/kusanagi-wp5/versions/1.0
ここで入手出来る様なのですがDLボタンが見当たりません汗

初学者で取るに足らない事でもご迷惑をおかけしますが何卒ご回答の程よろしくお願い申し上げます。

動作環境はMac Catalina 10.15.4です。

$ vagrant init praime-strategy/kusanagi-wp5 --box-version 1.0

/opt/vagrant/embedded/lib/ruby/2.4.0/rubygems/requirement.rb:101:in parse': Illformed requirement ["ox-version"] (Gem::Requirement::BadRequirementError)     from /opt/vagrant/embedded/lib/ruby/2.4.0/rubygems/requirement.rb:131:in block in initialize'
from /opt/vagrant/embedded/lib/ruby/2.4.0/rubygems/requirement.rb:131:in map!'     from /opt/vagrant/embedded/lib/ruby/2.4.0/rubygems/requirement.rb:131:in initialize'
from /opt/vagrant/embedded/gems/2.2.7/gems/vagrant-2.2.7/lib/vagrant/box_collection.rb:277:in new'     from /opt/vagrant/embedded/gems/2.2.7/gems/vagrant-2.2.7/lib/vagrant/box_collection.rb:277:in block in find'
from /opt/vagrant/embedded/gems/2.2.7/gems/vagrant-2.2.7/lib/vagrant/box_collection.rb:276:in map'     from /opt/vagrant/embedded/gems/2.2.7/gems/vagrant-2.2.7/lib/vagrant/box_collection.rb:276:in find'
from /opt/vagrant/embedded/gems/2.2.7/gems/vagrant-2.2.7/lib/vagrant/vagrantfile.rb:201:in block in machine_config'     from /opt/vagrant/embedded/gems/2.2.7/gems/vagrant-2.2.7/lib/vagrant/vagrantfile.rb:237:in machine_config'
from /opt/vagrant/embedded/gems/2.2.7/gems/vagrant-2.2.7/lib/vagrant/environment.rb:958:in block in find_configured_plugins'     from /opt/vagrant/embedded/gems/2.2.7/gems/vagrant-2.2.7/lib/vagrant/environment.rb:956:in each'
from /opt/vagrant/embedded/gems/2.2.7/gems/vagrant-2.2.7/lib/vagrant/environment.rb:956:in find_configured_plugins'     from /opt/vagrant/embedded/gems/2.2.7/gems/vagrant-2.2.7/lib/vagrant/environment.rb:983:in process_configured_plugins'
from /opt/vagrant/embedded/gems/2.2.7/gems/vagrant-2.2.7/lib/vagrant/environment.rb:178:in initialize'     from /opt/vagrant/embedded/gems/2.2.7/gems/vagrant-2.2.7/bin/vagrant:145:in new'
from /opt/vagrant/embedded/gems/2.2.7/gems/vagrant-2.2.7/bin/vagrant:145:in `<main>'

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

check解決した方法

0

vagrant fileが削除されていなかったためキチンと全て削除しやり直したらうまくいきました。

お世話になりました。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.77%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る