質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.25%

Rcmdrパッケージがインストールできない

受付中

回答 0

投稿

  • 評価
  • クリップ 0
  • VIEW 662

pudding_orz

score 4

前提・実現したいこと

Rcmdrのパッケージをインストールしたいがエラーが起こりパッケージのインストールができない。

発生している問題・エラーメッセージ

Rcmdrのインストールを試みたがエラーメッセージが出てインストールできません。
以下はinstall.packages("Rcmdr", dependencies = TRUE)を実行した直後に表示されたメッセージです。

> install.packages("Rcmdr", dependencies = TRUE)
 --- このセッションで使うために、CRAN のミラーサイトを選んでください --- 
 依存対象 (dependency) ‘desc’, ‘pkgbuild’, ‘rprojroot’, ‘ps’, ‘pkgload’, ‘praise’, ‘processx’, ‘clipr’, ‘BH’, ‘purrr’, ‘zip’, ‘DBI’, ‘testthat’, ‘farver’, ‘labeling’, ‘munsell’, ‘backports’, ‘assertthat’, ‘utf8’, ‘callr’, ‘coda’, ‘forcats’, ‘hms’, ‘readr’, ‘rlang’, ‘tidyselect’, ‘SparseM’, ‘MatrixModels’, ‘sp’, ‘curl’, ‘openxlsx’, ‘numDeriv’, ‘mitools’, ‘digest’, ‘glue’, ‘isoband’, ‘scales’, ‘withr’, ‘png’, ‘jpeg’, ‘RColorBrewer’, ‘checkmate’, ‘rstudioapi’, ‘viridisLite’, ‘stringi’, ‘rematch’, ‘cli’, ‘crayon’, ‘ellipsis’, ‘fansi’, ‘lifecycle’, ‘pillar’, ‘pkgconfig’, ‘vctrs’, ‘prettyunits’, ‘R6’, ‘httpuv’, ‘xtable’, ‘sourcetools’, ‘later’, ‘promises’, ‘fastmap’, ‘lazyeval’, ‘miniUI’, ‘webshot’, ‘arm’, ‘sandwich’, ‘haven’, ‘readstata13’, ‘carData’, ‘pbkrtest’, ‘quantreg’, ‘maptools’, ‘rio’, ‘survey’, ‘estimability’, ‘minqa’, ‘nloptr’, ‘Rcpp’, ‘RcppEigen’, ‘Formula’, ‘ggplot2’, ‘latticeExtra’, ‘acepack’, ‘gtable’, ‘gridExtra’, ‘data.table’, ‘htmlTable’, ‘viridis’, ‘htmltools’, ‘base64enc’, ‘evaluate’, ‘highr’, ‘stringr’, ‘yaml’, ‘xfun’, ‘zoo’, ‘mime’, ‘mvtnorm’, ‘TH.data’, ‘cellranger’, ‘tibble’, ‘progress’, ‘htmlwidgets’, ‘jsonlite’, ‘shiny’, ‘magrittr’, ‘crosstalk’, ‘manipulateWidget’, ‘tinytex’, ‘matrixcalc’, ‘mi’, ‘RcmdrMisc’, ‘car’, ‘effects’, ‘tcltk2’, ‘abind’, ‘relimp’, ‘lme4’, ‘aplpack’, ‘colorspace’, ‘e1071’, ‘Hmisc’, ‘knitr’, ‘leaps’, ‘lmtest’, ‘markdown’, multcomp’, ‘nortest’, ‘readxl’, ‘rgl’, ‘rmarkdown’, ‘sem’ もインストールします 

 警告:   リポジトリー https://cran.ism.ac.jp/bin/macosx/el-capitan/contrib/3.6 に対する索引にアクセスできません :
   URL 'https://cran.ism.ac.jp/bin/macosx/el-capitan/contrib/3.6/PACKAGES' を開けません 
ソースコードの形でのみ利用可能なパッケージです,C/C++/Fortran でコンパイルの必要があるかもしれません : ‘ps’ ‘pkgload’ ‘processx’ ‘purrr’ ‘zip’ ‘testthat’ ‘farver’ ‘backports’
  ‘utf8’ ‘readr’ ‘rlang’ ‘tidyselect’ ‘SparseM’ ‘sp’ ‘curl’ ‘openxlsx’ ‘digest’ ‘glue’ ‘isoband’ ‘png’ ‘jpeg’ ‘checkmate’ ‘stringi’ ‘ellipsis’ ‘fansi’
  ‘vctrs’ ‘httpuv’ ‘sourcetools’ ‘later’ ‘promises’ ‘fastmap’ ‘lazyeval’ ‘haven’ ‘readstata13’ ‘quantreg’ ‘maptools’ ‘minqa’ ‘nloptr’ ‘Rcpp’ ‘RcppEigen’
  ‘acepack’ ‘data.table’ ‘htmltools’ ‘base64enc’ ‘yaml’ ‘zoo’ ‘mime’ ‘mvtnorm’ ‘tibble’ ‘jsonlite’ ‘lme4’ ‘colorspace’ ‘e1071’ ‘Hmisc’ ‘leaps’ ‘lmtest’
  ‘markdown’ ‘readxl’ ‘rgl’ ‘sem’
Do you want to attempt to install these from sources? (Yes/no/cancel) Yes
 ソースパッケージ ‘desc’, ‘pkgbuild’, ‘rprojroot’, ‘ps’, ‘pkgload’, ‘praise’, ‘processx’, ‘clipr’, ‘BH’, ‘purrr’, ‘zip’, ‘DBI’, ‘testthat’, ‘farver’, ‘labeling’, ‘munsell’, ‘backports’, ‘assertthat’, ‘utf8’, ‘callr’, ‘coda’, ‘forcats’, ‘hms’, ‘readr’, ‘rlang’, ‘tidyselect’, ‘SparseM’, ‘MatrixModels’, ‘sp’, ‘curl’, ‘openxlsx’, ‘numDeriv’, ‘mitools’, ‘digest’, ‘glue’, ‘isoband’, ‘scales’, ‘withr’, ‘png’, ‘jpeg’, ‘RColorBrewer’, ‘checkmate’, ‘rstudioapi’, ‘viridisLite’, ‘stringi’, ‘rematch’, ‘cli’, ‘crayon’, ‘ellipsis’, ‘fansi’, ‘lifecycle’, ‘pillar’, ‘pkgconfig’, ‘vctrs’, ‘prettyunits’, ‘R6’, ‘httpuv’, ‘xtable’, ‘sourcetools’, ‘later’, ‘promises’, ‘fastmap’, ‘lazyeval’, ‘miniUI’, ‘webshot’, ‘arm’, ‘sandwich’, ‘haven’, ‘readstata13’, ‘carData’, ‘pbkrtest’, ‘quantreg’, ‘maptools’, ‘rio’, ‘survey’, ‘estimability’, ‘minqa’, ‘nloptr’, ‘Rcpp’, ‘RcppEigen’, ‘Formula’, ‘ggplot2’, ‘latticeExtra’, ‘acepack’, ‘gtable’, ‘gridExtra’, ‘data.table’, ‘htmlTable’, ‘viridis’, ‘htmltools’, ‘base64enc’, ‘evaluate’, ‘highr’, ‘stringr’, ‘yaml’, ‘xfun’, ‘zoo’, ‘mime’, ‘mvtnorm’, ‘TH.data’, ‘cellranger’, ‘tibble’, ‘progress’, ‘htmlwidgets’, ‘jsonlite’, ‘shiny’, ‘magrittr’, ‘crosstalk’, ‘manipulateWidget’, ‘tinytex’, ‘matrixcalc’, ‘mi’, ‘RcmdrMisc’, ‘car’, ‘effects’, ‘tcltk2’, ‘abind’, ‘relimp’, ‘lme4’, ‘aplpack’, ‘colorspace’, ‘e1071’, ‘Hmisc’, ‘knitr’, ‘leaps’, ‘lmtest’, ‘markdown’, multcomp’, ‘nortest’, ‘readxl’, ‘rgl’, ‘rmarkdown’, ‘sem’, ‘Rcmdr’ をインストール中です 

該当のソースコード

以下はinstall.packages("Rcmdr", dependencies = TRUE)を実行した後に表示されたエラー文とその警告文です。

ERROR: dependencies ‘pbkrtest’, ‘quantreg’, ‘rio’, ‘lme4’ are not available for package ‘car’
* removing ‘/Library/Frameworks/R.framework/Versions/3.6/Resources/library/car’
ERROR: dependencies ‘latticeExtra’, ‘acepack’, ‘data.table’ are not available for package ‘Hmisc’
* removing ‘/Library/Frameworks/R.framework/Versions/3.6/Resources/library/Hmisc’
ERROR: dependencies ‘car’, ‘Hmisc’, ‘haven’, ‘readstata13’, ‘readxl’ are not available for package ‘RcmdrMisc’
* removing ‘/Library/Frameworks/R.framework/Versions/3.6/Resources/library/RcmdrMisc’
ERROR: dependencies ‘RcmdrMisc’, ‘car’, ‘effects’, ‘tcltk2’, ‘lme4’ are not available for package ‘Rcmdr’
* removing ‘/Library/Frameworks/R.framework/Versions/3.6/Resources/library/Rcmdr’

 ダウンロードされたパッケージは、以下にあります 
     ‘/private/var/folders/ym/7tgt6q1d0y54vy5_1_4hwbb80000gn/T/Rtmp9vkFdN/downloaded_packages’ 
 38 件の警告がありました (警告を見るには warnings() を使って下さい) 
> warnings()
 警告メッセージ: 
1: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘SparseM’ のインストールは、ゼロでない終了値をもちました 
2: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘png’ のインストールは、ゼロでない終了値をもちました 
3: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘jpeg’ のインストールは、ゼロでない終了値をもちました 
4: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘acepack’ のインストールは、ゼロでない終了値をもちました 
5: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘data.table’ のインストールは、ゼロでない終了値をもちました 
6: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘mvtnorm’ のインストールは、ゼロでない終了値をもちました 
7: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘tcltk2’ のインストールは、ゼロでない終了値をもちました 
8: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘aplpack’ のインストールは、ゼロでない終了値をもちました 
9: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘leaps’ のインストールは、ゼロでない終了値をもちました 
10: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘later’ のインストールは、ゼロでない終了値をもちました 
11: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘readstata13’ のインストールは、ゼロでない終了値をもちました 
12: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘quantreg’ のインストールは、ゼロでない終了値をもちました 
13: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘minqa’ のインストールは、ゼロでない終了値をもちました 
14: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘RcppEigen’ のインストールは、ゼロでない終了値をもちました 
15: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘latticeExtra’ のインストールは、ゼロでない終了値をもちました 
16: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘lmtest’ のインストールは、ゼロでない終了値をもちました 
17: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘promises’ のインストールは、ゼロでない終了値をもちました 
18: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘survey’ のインストールは、ゼロでない終了値をもちました 
19: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘lme4’ のインストールは、ゼロでない終了値をもちました 
20: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘multcomp’ のインストールは、ゼロでない終了値をもちました 
21: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘httpuv’ のインストールは、ゼロでない終了値をもちました 
22: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘arm’ のインストールは、ゼロでない終了値をもちました 
23: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘pbkrtest’ のインストールは、ゼロでない終了値をもちました 
24: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘effects’ のインストールは、ゼロでない終了値をもちました 
25: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘shiny’ のインストールは、ゼロでない終了値をもちました 
26: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘mi’ のインストールは、ゼロでない終了値をもちました 
27: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘readr’ のインストールは、ゼロでない終了値をもちました 
28: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘miniUI’ のインストールは、ゼロでない終了値をもちました 
29: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘sem’ のインストールは、ゼロでない終了値をもちました 
30: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘haven’ のインストールは、ゼロでない終了値をもちました 
31: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘manipulateWidget’ のインストールは、ゼロでない終了値をもちました 
32: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘readxl’ のインストールは、ゼロでない終了値をもちました 
33: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘rio’ のインストールは、ゼロでない終了値をもちました 
34: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘rgl’ のインストールは、ゼロでない終了値をもちました 
35: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘car’ のインストールは、ゼロでない終了値をもちました 
36: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘Hmisc’ のインストールは、ゼロでない終了値をもちました 
37: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘RcmdrMisc’ のインストールは、ゼロでない終了値をもちました 
38: In install.packages("Rcmdr", dependencies = TRUE) :
   パッケージ ‘Rcmdr’ のインストールは、ゼロでない終了値をもちました 
> library(Rcmdr)
 library(Rcmdr) でエラー:  ‘Rcmdr’ という名前のパッケージはありません 

試したこと

試したことは2つあります。
まず1つめは
ダウンロードされたパッケージは、以下にあります 
‘/private/var/folders/ym/7tgt6q1d0y54vy5_1_4hwbb80000gn/T/Rtmp9vkFdN/downloaded_packages’
といったメッセージがあったのでPC内を探してみると確かにそのファイルは存在しその中には多数のtar.gz形式のジップファイルとともにRcmdrと書かれたディレクトリがありました。
しかしこれらのファイルをどう活用していいかわからずこれ以降の対応はできませんでした。

2つめはMacOS X版のインストール方法が紹介されているサイト(http://www.jichi.ac.jp/saitama-sct/SaitamaHP.files/statmedOSX.html)を調べたところ
install.packages("RcmdrPlugin.EZR", dependencies=TRUE)
を実行するとRcmdrがインストールされるそうだったので実行してみましたが結果は変わりませんでした。

補足情報(FW/ツールのバージョンなど)

使用しているPCは2019年モデルのmacbookairです。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正の依頼

  • KojiDoi

    2020/04/02 16:10

    MacOSでは、XQuartzというものが必要らしいですが、インストールされていますか?

    キャンセル

  • pudding_orz

    2020/04/02 16:28

    XQuartzはすでにインストール済みです。

    キャンセル

  • nasudeng

    2020/04/22 00:05

    mac環境には疎く的外れでしたら申し訳ありません。
    http://funizou.hatenablog.com/entry/2015/08/02/115415
    のようなサイトも見かけましたが、どうでしょうか。

    キャンセル

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.25%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る