質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.48%

Rails バージョンアップ時の bundle update におけるバージョンコンフリクト解消方法について

解決済

回答 1

投稿

  • 評価
  • クリップ 1
  • VIEW 1,635

score 5

前提・実現したいこと

Ruby on Rails で Rails のバージョンアップを行おうと思っています。
現行:4.2.11.1 から、最終的には最新バージョンへと考えていますが
とりあえずは直近のメジャーバージョンの 5.0.0 へアップデートしようとしています。
bundle update rails を実施した際に、以下の依存関係のエラーが発生しました。

5.0.0 へのアップデートを考えたときに、メッセージに指定されているバージョン指定では
不整合は無いようにも見えますが、どのあたりが問題でしょうか。
アドバイスまたは解決に向けたヒント等ご指摘いただけると助かります。
よろしくお願いいたします。

発生している問題・エラーメッセージ

Bundler could not find compatible versions for gem "actionpack":
  In Gemfile:
    haml-rails was resolved to 1.0.0, which depends on
      actionpack (>= 4.0.1)

    rails (= 5.0.0) was resolved to 5.0.0, which depends on
      actionpack (= 5.0.0)

    devise (~> 4.3.0) was resolved to 4.3.0, which depends on
      responders was resolved to 2.4.1, which depends on
        actionpack (>= 4.2.0, < 6.0)

    rspec-rails (~> 3.7.1) was resolved to 3.7.2, which depends on
      actionpack (>= 3.0)

    simple_form was resolved to 3.5.1, which depends on
      actionpack (> 4, < 5.2)

Bundler could not find compatible versions for gem "activemodel":
  In Gemfile:
    paperclip (~> 5.2.0) was resolved to 5.2.1, which depends on
      activemodel (>= 4.2.0)

    rails (= 5.0.0) was resolved to 5.0.0, which depends on
      activemodel (= 5.0.0)

    simple_form was resolved to 3.5.1, which depends on
      activemodel (> 4, < 5.2)

    web-console (~> 2.1.1) was resolved to 2.1.3, which depends on
      activemodel (>= 4.0)

Bundler could not find compatible versions for gem "activesupport":
  In Gemfile:
    haml-rails was resolved to 1.0.0, which depends on
      activesupport (>= 4.0.1)

    jbuilder (~> 2.0) was resolved to 2.7.0, which depends on
      activesupport (>= 4.2.0)

    rails (= 5.0.0) was resolved to 5.0.0, which depends on
      activesupport (= 5.0.0)

    rspec-rails (~> 3.7.1) was resolved to 3.7.2, which depends on
      activesupport (>= 3.0)

Bundler could not find compatible versions for gem "railties":
  In Gemfile:
    rails (= 5.0.0) was resolved to 5.0.0, which depends on
      railties (= 5.0.0)

    rails-i18n was resolved to 4.0.9, which depends on
      railties (~> 4.0)

試したこと

一部のものについては、バージョン指定の修正等を実施しましたが
actionpack, activemodel, activesupport, railties について、rails とともに
5.0.0 になれば問題ないようにも見えています。

知識や経験不足で勘違い等しているところもあるかと思いますので
併せてアドバイスいただけると助かります。
よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

Bundler could not find compatible versions for gem "actionpack":
  In Gemfile:
    haml-rails was resolved to 1.0.0, which depends on
      actionpack (>= 4.0.1)

    rails (= 5.0.0) was resolved to 5.0.0, which depends on
      actionpack (= 5.0.0)

    devise (~> 4.3.0) was resolved to 4.3.0, which depends on
      responders was resolved to 2.4.1, which depends on
        actionpack (>= 4.2.0, < 6.0)

    rspec-rails (~> 3.7.1) was resolved to 3.7.2, which depends on
      actionpack (>= 3.0)

    simple_form was resolved to 3.5.1, which depends on
      actionpack (> 4, < 5.2)

これの意味を噛み砕いて説明すると

  • haml-rails は Gemfile.lock によって 1.0.0 が指定されている

  • その haml-rails は actionpack の 4.x 系に依存している

  • 一方 rails は 5.0.0 に update される

  • その rails は actionpack の 5.0.0 に依存している

haml-rails が 4.x の actionpack に依存しているのに対して、 rails は 5.0.0 の actionpack に依存して矛盾しているため、 actionpack のバージョンを決めることができない、というエラーです

そのため、基本的には rails が依存する actionpack のバージョンに対応する haml-rails のバージョンにアップデートする必要があります。

単に通すのであれば 
bundle update rails haml-rails devise rspec-rails ...出ているGemすべてを 

必要であれば

  • それぞれの gem の必要なバージョン指定を Gemfile に加える
  • bundle update rails 

すればよいかと思います。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/03/15 09:09

    あと、関係はないですがメジャーバージョンを上げるのであれば、 `5.0.0` ではなくセキュリティパッチ等が適用されている最新の `5.x.x` を入れたほうが良いかと思われます

    キャンセル

  • 2020/03/15 17:29

    ありがとうございます!

    >haml-rails was resolved to 1.0.0, which depends on
    > actionpack (>= 4.0.1)

    ここについては、actionpack は 4.0.1 以上だったら(いくらでも)良い、のではなく、
    4.x までという解釈となるでしょうか。
    そのあたりが曖昧というか理解できていませんでした。
    アドバイスいただきありがとうございます。

    いただいた内容をもとに進めてみます。ありがとうございます。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.48%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • トップ
  • Rubyに関する質問
  • Rails バージョンアップ時の bundle update におけるバージョンコンフリクト解消方法について