質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.21%

【rails】【Docker】Docker buildエラー

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 930

ryouya

score 8

お世話になっております。

Dcoker build実行時にエラーが出力されます。
bundlerのバージョン違いによるものだと思うのですが、バージョンはあっている認識です。

エラーメッセージ中のCould not find 'bundler' (2.1.2) required by your /app/Gemfile.lock.
ここのGemfile.lockのパス指定に誤りがあるのでしょうか。

ご確認をお願いいたいします。

実行時のコード

docker build -t rails ./rails

エラーメッセージ

Step 7/11 : RUN bundle install
 ---> Running in c62076fb1f11
/usr/local/lib/ruby/2.6.0/rubygems.rb:283:in `find_spec_for_exe': Could not find 'bundler' (2.1.2) required by your /app/Gemfile.lock. (Gem::GemNotFoundException)
To update to the latest version installed on your system, run `bundle update --bundler`.
To install the missing version, run `gem install bundler:2.1.2`
    from /usr/local/lib/ruby/2.6.0/rubygems.rb:302:in `activate_bin_path'
    from /usr/local/bin/bundle:23:in `<main>'

Dockerfile

# Rubyをインストール
FROM ruby:2.6

# 必要なパッケージをインストール
RUN curl -sL https://deb.nodesource.com/setup_10.x | bash - \
    && apt-get install -y nodejs

# 公式では以下のコマンドを推奨しているが、nodeのバージョンが低くBootstrapが使え>ない
# RUN apt-get update -qq && apt-get install -y nodejs

# 環境変数を設定
ENV APP_HOME /app

# ディレクトリの作成と移動
WORKDIR $APP_HOME

# ホストのGemfileなどをコンテナへコピー
COPY Gemfile $APP_HOME/Gemfile
COPY Gemfile.lock $APP_HOME/Gemfile.lock

# BundlerでGemをインストール
RUN bundle install

# Railsアプリを作成(新規でアプリを作成する場合のみ)
RUN rails new . --database=mysql

# DBの設定ファイル書き換え(新規でアプリを作成する場合のみ)
COPY ./config $APP_HOME/config

# 3000番ポート解放
EXPOSE 3000

# コンテナ起動時にRailsサーバを起動
CMD ["rails", "server", "-b", "0.0.0.0"]

Gemfile.lock

〜略〜
BUNDLED WITH
   2.1.2

確認事項

$ bundle -v
Bundler version 2.1.2

$ gem list bundler

*** LOCAL GEMS ***

bundler (2.1.2)
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • t_obara

    2020/02/18 18:49

    Dockerfileもご提示された方が、回答が得られやすいかと思います。

    キャンセル

  • ryouya

    2020/02/18 19:09

    ご指摘ありがとうございます。
    上記質問内容に追記いたしました。

    キャンセル

  • t_obara

    2020/02/19 09:38

    確認事項に記載の内容はホスト側で実施したのですか?そうでない場合、どのように確認したのかを記載されるとよろしいかと。

    キャンセル

回答 1

check解決した方法

0

自己解決いたしました。
参考にしているサイトのコードを書き直したら実行に成功しました。
お手数おかけしました。

参考サイトURL
https://kitsune.blog/docker-network

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.21%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る