質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.62%

rubyのバージョンアップをしたらJSONのエラーが出る

解決済

回答 1

投稿

  • 評価
  • クリップ 2
  • VIEW 1,541

izumi

score 13

昨日rubyのバージョンを、「2.0.0-p451」から「ruby 2.2.4p230」にバージョンアップをしたところ、jsonが利用される処理の際に、画面もしくはターミナルのログに以下のようなエラーが表示される。

TypeError - [bug] frozen object (JSON::Ext::Generator::State) allocated:
  json (1.8.3) lib/json/common.rb:211:in `generate'

どなたかお分かりいただけますでしょうか。
よろしくお願いいたします。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

+1

確認ですが、ralisおよびGemfileにある各ライブラリも最新にバージョンアップしているでしょうか?Rubyは2.0.xから2.2.xへなるべく互換性が保たれているようになっていますが、完全に互換性があるわけではありません。そのため、ライブラリによってはバージョンを上げないと2.2.xでエラーになる場合があります。

全てのライブラリを上げるのが難しい場合は、スタックトレースをみてどのライブラリからの呼び出しでエラーが起きているのか確認してみてください。そのライブラリのバグ情報等に対応方法が載っている場合があります。トレースの情報全てを出していただければ、何かわかるかも知れません。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2016/01/09 10:54

    ご丁寧に回答していただき、誠にありがとうございます。

    ralisおよびGemfileにある各ライブラリも最新にバージョンアップしております。本番環境ではエラーせず、プルしたローカルのブランチでエラーが出ます。

    rubyのバージョンアップは、以下のコマンドを実行しました。
    $ rbenv install 2.2.4
    $ rbenv local 2.2.4
    $ gem install bundler
    $ bundle install

    スタックトレースについて教えていただけないでしょうか。「binding.pry」「raise」で例外処理発生させてコンソールいじって、render jsonの処理の際にエラーが発生するということは把握できました。

    キャンセル

  • 2016/01/09 12:58

    pryを使っているなら、下記の方法でおえるようです。
    http://xoyip.hatenablog.com/entry/2014/05/16/200000
    他にも下記にデバッグの仕方が載っていますのでご参考を。
    http://railsguides.jp/debugging_rails_applications.html

    後考えられるのは、Gemfile.lockでライブラリが古いままかも知れません。
    bundle update
    でGemfile.lockを無視して最新を取ってくればいけるかも知れないです。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.62%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る