質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.36%

heroku push でrejectされます。Precompiling assets failed.ということですが、どのように直したらいいのかが分からず困っています。

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 416

tori315

score 21

これは、Sass::SyntaxError: File to import not found or unreadable: home.scss.以下すべてエラーの原因ということなのでしょうか。すいません、知識不足で分かりません。どなたかご教授ください。

 !     Warning: Multiple default buildpacks reported the ability to handle this app. The first buildpack in the list below will be used.
            Detected buildpacks: Ruby,Node.js
            See https://devcenter.heroku.com/articles/buildpacks#buildpack-detect-order
-----> Ruby app detected
-----> Compiling Ruby/Rails
-----> Using Ruby version: ruby-2.6.5
-----> Vendoring libpq 5.12.1
-----> Removing BUNDLED WITH version in the Gemfile.lock
###### WARNING:
       Removing `Gemfile.lock` because it was generated on Windows.
       Bundler will do a full resolve so native gems are handled properly.
       This may result in unexpected gem versions being used in your app.
       In rare occasions Bundler may not be able to resolve your dependencies at all.
       https://devcenter.heroku.com/articles/bundler-windows-gemfile
-----> Installing dependencies using bundler 2.0.2
       Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4
       Your Gemfile lists the gem tzinfo-data (>= 0) more than once.
       You should probably keep only one of them.
       Remove any duplicate entries and specify the gem only once (per group).
       While it's not a problem now, it could cause errors if you change the version of one of them later.
       The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x86-mswin32, x64-mingw32, java. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java`.
       Fetching gem metadata from https://rubygems.org/..........
       Fetching gem metadata from https://rubygems.org/.

      省略

       Bundle complete! 34 Gemfile dependencies, 86 gems now installed.
       Gems in the groups development and test were not installed.
       Bundled gems are installed into `./vendor/bundle`
       Post-install message from i18n:

       HEADS UP! i18n 1.1 changed fallbacks to exclude default locale.
       But that may break your application.

       If you are upgrading your Rails application from an older version of Rails:

       Please check your Rails app for 'config.i18n.fallbacks = true'.
       If you're using I18n (>= 1.1.0) and Rails (< 5.2.2), this should be
       'config.i18n.fallbacks = [I18n.default_locale]'.
       If not, fallbacks will be broken in your app by I18n 1.1.x.

       If you are starting a NEW Rails application, you can ignore this notice.

       For more info see:
       https://github.com/svenfuchs/i18n/releases/tag/v1.1.0

       Post-install message from sass:

       Ruby Sass has reached end-of-life and should no longer be used.

       * If you use Sass as a command-line tool, we recommend using Dart Sass, the new
         primary implementation: https://sass-lang.com/install

       * If you use Sass as a plug-in for a Ruby web framework, we recommend using the
         sassc gem: https://github.com/sass/sassc-ruby#readme

       * For more details, please refer to the Sass blog:
         https://sass-lang.com/blog/posts/7828841

       Bundle completed (218.22s)
       Cleaning up the bundler cache.
-----> Installing node-v10.15.3-linux-x64
-----> Detecting rake tasks
-----> Preparing app for Rails asset pipeline
       Running: rake assets:precompile
       Yarn executable was not detected in the system.
       Download Yarn at https://yarnpkg.com/en/docs/install
       I, [2020-02-06T01:24:52.135927 #1795]  INFO -- : Writing /tmp/build_440d3a97b32159ce086c0c26cbb0439a/public/assets/rails_admin/rails_admin-4d540b308ec792e61b7cd24122824d74adc52d5622e8fb7fdb58854fc89dec8b.js
       I, [2020-02-06T01:24:52.136264 #1795]  INFO -- : Writing /tmp/build_440d3a97b32159ce086c0c26cbb0439a/public/assets/rails_admin/rails_admin-4d540b308ec792e61b7cd24122824d74adc52d5622e8fb7fdb58854fc89dec8b.js.gz
       I, [2020-02-06T01:25:02.668343 #1795]  INFO -- : Writing /tmp/build_440d3a97b32159ce086c0c26cbb0439a/public/assets/rails_admin/rails_admin-96d597cbe7642ce04bf3c53b9ef0bc48de7678e415dc3643402cfbb8b1a35399.css
       I, [2020-02-06T01:25:02.668555 #1795]  INFO -- : Writing /tmp/build_440d3a97b32159ce086c0c26cbb0439a/public/assets/rails_admin/rails_admin-96d597cbe7642ce04bf3c53b9ef0bc48de7678e415dc3643402cfbb8b1a35399.css.gz
       I, [2020-02-06T01:25:02.669043 #1795]  INFO -- : Writing 
       省略
       I, [2020-02-06T01:25:55.041763 #1795]  INFO -- : Writing /tmp/build_440d3a97b32159ce086c0c26cbb0439a/public/assets/application-970452107e253506cf9aca8119d0801a1c3ebac2fdee4ec54ad992b2ca009d61.js
       I, [2020-02-06T01:25:55.042068 #1795]  INFO -- : Writing /tmp/build_440d3a97b32159ce086c0c26cbb0439a/public/assets/application-970452107e253506cf9aca8119d0801a1c3ebac2fdee4ec54ad992b2ca009d61.js.gz
       rake aborted!
       Sass::SyntaxError: File to import not found or unreadable: home.scss.
       (sass):1796
       /tmp/build_440d3a97b32159ce086c0c26cbb0439a/vendor/bundle/ruby/2.6.0/gems/sass-3.7.4/lib/sass/tree/import_node.rb:67:in `rescue in import'
       /tmp/build_440d3a97b32159ce086c0c26cbb0439a/vendor/bundle/ruby/2.6.0/gems/sass-3.7.4/lib/sass/tree/import_node.rb:44:in `import'
       /tmp/build_440d3a97b32159ce086c0c26cbb0439a/vendor/bundle/ruby/2.6.0/gems/sass-3.7.4/lib/sass/tree/import_node.rb:28:in `imported_file'
       /tmp/build_440d3a97b32159ce086c0c26cbb0439a/vendor/bundle/ruby/2.6.0/gems/sass-3.7.4/lib/sass/tree/import_node.rb:37:in `css_import?'
       /tmp/build_440d3a97b32159ce086c0c26cbb0439a/vendor/bundle/ruby/2.6.0/gems/sass-processor_utils.rb:57:in `block in call_processors'
       省略

       /tmp/build_440d3a97b32159ce086c0c26cbb0439a/vendor/bundle/ruby/2.6.0/gems/sprockets-rails-3.2.1/lib/sprockets/rails/task.rb:68:in `block (3 levels) in define'
       /tmp/build_440d3a97b32159ce086c0c26cbb0439a/vendor/bundle/ruby/2.6.0/gems/sprockets-3.7.2/lib/rake/sprocketstask.rb:147:in `with_logger'
       /tmp/build_440d3a97b32159ce086c0c26cbb0439a/vendor/bundle/ruby/2.6.0/gems/sprockets-rails-3.2.1/lib/sprockets/rails/task.rb:67:in `block (2 levels) in define'
       /tmp/build_440d3a97b32159ce086c0c26cbb0439a/vendor/bundle/ruby/2.6.0/gems/rake-13.0.1/exe/rake:27:in `<top (required)>'


       Caused by:
       Sass::SyntaxError: File to import not found or unreadable: home.scss.
       /tmp/build_440d3a97b32159ce086c0c26cbb0439a/vendor/bundle/ruby/2.6.0/gems/sass-3.7.4/lib/sass/tree/import_node.rb:65:in `import'
       /tmp/build_440d3a97b32159ce086c0c26cbb0439a/vendor/bundle/ruby/2.6.0/gems/sass-3.7.4/lib/sass/tree/import_node.rb:28:in `imported_file'
       /tmp/build_440d3a97b32159ce086c0c26cbb0439a/vendor/bundle/ruby/2.6.0/gems/sass-3.7.4/lib/sass/tree/import_node.rb:37:in `css_import?'
       /tmp/build_440d3a97b32159ce086c0c26cbb0439a/vendor/bundle/ruby/2.6.0/gems/sass-
             省略

       /tmp/build_440d3a97b32159ce086c0c26cbb0439a/vendor/bundle/ruby/2.6.0/gems/sprockets-3.7.2/lib/rake/sprocketstask.rb:147:in `with_logger'
       /tmp/build_440d3a97b32159ce086c0c26cbb0439a/vendor/bundle/ruby/2.6.0/gems/sprockets-rails-3.2.1/lib/sprockets/rails/task.rb:67:in `block (2 levels) in define'
       /tmp/build_440d3a97b32159ce086c0c26cbb0439a/vendor/bundle/ruby/2.6.0/gems/rake-13.0.1/exe/rake:27:in `<top (required)>'
       Tasks: TOP => assets:precompile
       (See full trace by running task with --trace)
 !
 !     Precompiling assets failed.
 !
 !     Push rejected, failed to compile Ruby app.
 !     Push failed
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • no1knows

    2020/02/06 11:18

    下記が気になりますね。バージョンによる書き方の違いでしょうか?
    Please check your Rails app for 'config.i18n.fallbacks = true'.
    If you're using I18n (>= 1.1.0) and Rails (< 5.2.2), this should be
    'config.i18n.fallbacks = [I18n.default_locale]'.
    If not, fallbacks will be broken in your app by I18n 1.1.x.

    キャンセル

  • tori315

    2020/02/06 12:01

    ご回答ありがとうございます。
    ご指摘のところ、また、今回adminを入れようとしてcancanに関する部分を見つけました。あと、scssで、require_treeの辺りで直したところ、Verifying deploy... done.herokuへのpushは成功するのですが、ページが表示されません。

    heroku logsでは、以下が表示されます。
    2020-02-06T02:52:06.379539+00:00 heroku[router]: at=error code=H10 desc="App crashed" method=GET path="/" host=00000000.com request_id=12bbc612-e0e0-4994-9daf-187d00000 fwd=" " dyno= connect= service= status=503 bytes= protocol=https
    2020-02-06T02:52:07.064179+00:00 heroku[router]: at=error code=H10 desc="App crashed" method=GET path="/favicon.ico" host=00000.com request_id=ae988ee2-91ee-4eb7-b8e0-df0000 fwd="    " dyno= connect= service= status=503 bytes= protocol=https


    /favicon.icoの辺りに問題があるのでしょうか?

    キャンセル

  • tori315

    2020/02/06 12:08

    あと、
    bundler: failed to load command: puma (/app/vendor/bundle/ruby/2.6.0/bin/puma)
    Errno::ENOENT: No such file or directory @ rb_sysopen - tmp/pids/server.pid
    これも原因っぽいのですが、よく分かりません。。
    すいません。

    キャンセル

  • tori315

    2020/02/06 13:19

    追加

    tmp/socketsとtmp/pids/server.pidのフォルダを作ってみてもだめでした。

    キャンセル

回答 1

checkベストアンサー

+1

A crashed web dyno or a boot timeout on the web dyno will present this error.
https://devcenter.heroku.com/articles/error-codes#h10-app-crashed

とのことなのですが、これだ!という解決策がなさそうなので、上記キーワードで調べてみて下さい。

下記などではいかがでしょうか?
https://note.com/sa070935/n/n702ee9357a4f

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/02/06 19:16

    ありがとうございます。
    検索して調べたところ、
    #environment ENV.fetch("RAILS_ENV") { "development" }
    これをコメントアウトすることで表示されるようになりました。

    キャンセル

  • 2020/02/06 19:40

    それは良かったです!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.36%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • トップ
  • Ruby on Rails 5に関する質問
  • heroku push でrejectされます。Precompiling assets failed.ということですが、どのように直したらいいのかが分からず困っています。