質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.03%

Androidアプリのライブラリの依存関係で、とあるライブラリと他のライブラリがどのバージョンで組み合わせるのが正しいのかをどう調べたらいいですか?

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 666

score 38

目的

Firebaseのバージョン更新(変更)しようとしています。

訂正しました。

行ったこと。

実際に更新するとビルドエラーが出るようになりました。

10.0.x から 20.0.0にしました。 implementation 'com.google.firebase:firebase-messaging:20.0.0

firebaseを(10)から(20)にしました。
play-servicesを(15)から(17)にしました。

implementation 'com.google.android.gms:play-services-auth:17.0.0'
implementation 'com.google.firebase:firebase-messaging:20.0.0

そして以下のエラーになりました。
Program type already present: android.support.v4.app.INotificationSideChannel

調べた所。
「Androidx」というやつに置き換えられていることがわかりました。そのため、プログラムが重複したようです。
com.android.supportを28にすれば良さそうなんですが、他のアプリとの兼ね合いでまだ控えたいので
firebaseをダウングレードしようとしました。

これはFirebaseの版をダウングレードすればいいと思ってたんですが、
Androidxはplay-servicesの版が

しかし、適当に戻してもまた別なところで
「Program type already present: 〜〜〜」などのエラーがでそうです。

そこでなんですが、
Firebaseの古いバージョンの一覧が載っているところと、
それが対応している
com.google.android.gms:play-servicesのバージョンを調べたいと思いますが、どこかにマニュアルがありますか?

Firebaseのリリースノートはこれですが、Androidxに対応以前と以後の境目がよくわからないですし。
https://firebase.google.com/support/release-notes/android

Maven repository. なるほど、ここを見ると既存のバージョンがわかりますね。
https://mvnrepository.com/artifact/com.google.firebase/firebase-messaging

これはもしかして既に手動でplay-servicesのそれぞれのバージョンを記述する必要がなくなったと言うことでしょうか?
あるバージョンに対応する依存関係のあるライブラリバージョンがわかれば良い・・・。
com.google.gms:google-services:3.3.1に対応するライブラリのバージョンがわかれば、エラー回避できそう・・・
https://developers.google.com/android/guides/google-services-plugin?hl=ja

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

-1

rocketさんの実現したいことが理解できておらず、この回答が的を射ているかわからないのですが、、
まず、今回発生しているエラーとFirebaseは無関係なのではないかな、と考えています。

android.support.v4
これはサポートライブラリと呼ばれているものでして、
今まではこれが使われていたのですが、
このサポートライブラリの後継ライブラリがAndroidXです。

サポートライブラリとAndroidXは両方導入することはできません。どちらか一方だけです。
rocketさんはAndroidXを導入したのかな、と想像しています。

使いたい機能がAndroidXに含まれているわけですので、
サポートライブラリの記述はgradleファイルから削除しなければいけません。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2020/02/21 21:09

    ご回答ありがとうございます。
    AndroidX導入前のものにFirebase-messagingを組み込みたかったものですので少し違うのですが、
    こちら自己解決いたしまして。
    Firebase-messaging 17
    Firebase-core 16
    にてかいけつできました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.03%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る

  • トップ
  • Androidに関する質問
  • Androidアプリのライブラリの依存関係で、とあるライブラリと他のライブラリがどのバージョンで組み合わせるのが正しいのかをどう調べたらいいですか?