質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.10%

progateのrails環境構築の記事を参考にやってみたが、rails sのところでエラーがでた。

受付中

回答 2

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 587

kobaryo04ysh

score 14

前提・実現したいこと

rails sを実行しrailsを使える状態にしたいです。

Progateにあるrailsの環境構築の記事(https://prog-8.com/docs/rails-env)を参考にrailsの環境構築を進めていたところ、rails sでいかのようなエラーが出ました。

発生している問題・エラーメッセージ

rails s(railsのコマンド全般)を実行すると以下のようなエラーが出ます。
また、エラー文を元にgem install bundlerなど色々試した結果rails -vすらできなくなってしまい、以下のようなエラーにたどり着きました。

$ rails s
Traceback (most recent call last):
    5: from /Users/ryota/.rbenv/versions/2.5.0/bin/rails:23:in `<main>'
    4: from /Users/ryota/.rbenv/versions/2.5.0/bin/rails:23:in `load'
    3: from /Users/ryota/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/railties-6.0.2.1/exe/rails:10:in `<top (required)>'
    2: from /Users/ryota/.rbenv/versions/2.5.0/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:39:in `require'
    1: from /Users/ryota/.rbenv/versions/2.5.0/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:135:in `rescue in require'
/Users/ryota/.rbenv/versions/2.5.0/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:135:in `require': cannot load such file -- rails/cli (LoadError)


rails -vのエラーコードは以下の通りです。

$rails -v
Traceback (most recent call last):
    5: from /Users/ryota/.rbenv/versions/2.5.0/bin/rails:23:in `<main>'
    4: from /Users/ryota/.rbenv/versions/2.5.0/bin/rails:23:in `load'
    3: from /Users/ryota/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/railties-6.0.2.1/exe/rails:10:in `<top (required)>'
    2: from /Users/ryota/.rbenv/versions/2.5.0/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:39:in `require'
    1: from /Users/ryota/.rbenv/versions/2.5.0/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:135:in `rescue in require'
/Users/ryota/.rbenv/versions/2.5.0/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:135:in `require': cannot load such file -- rails/cli (LoadError)

試したこと

・railsの再インストール
・gem install bundler

補足情報

progate通りのrails、rubyのバージョンをインストールしています。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 2

0

rails s 時のエラー (Gem::GemNotFoundException)

gem install bundler
bundle install


で解決できるかも?

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/12/26 01:05

    その方法も試してみたのですが、結局できませんでした。
    railsに関するコマンドを打つと、上記のようなエラーが毎回出てしまいます。。。

    キャンセル

0

gem install railsで入りませんか?

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/12/26 10:34

    $ gem install rails
    ERROR: While executing gem ... (Errno::EACCES)
    Permission denied @ rb_sysopen - /Users/ryota/.rbenv/versions/2.5.0/lib/ruby/gems/2.5.0/gems/rails-6.0.2.1/README.md

    このようになってしまいました。。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.10%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる