質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.23%

Pyinstallerやpy2appでビルド後実行できない。

受付中

回答 0

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 447

コードを直接実行すると何もエラーははかないのですが、ビルドするとエラーがでてしまいます。

↓のエラーが出たので、

/Users/teratail/app/pyside/dist/main ; exit;
Traceback (most recent call last):
  File "main.py", line 2, in <module>
  File "/usr/local/lib/python3.7/site-packages/PyInstaller/loader/pyimod03_importers.py", line 627, in exec_module
    exec(bytecode, module.__dict__)
  File "module.py", line 3, in <module>
  File "/usr/local/lib/python3.7/site-packages/PyInstaller/loader/pyimod03_importers.py", line 627, in exec_module
    exec(bytecode, module.__dict__)
  File "cv2/__init__.py", line 3, in <module>
ImportError: dlopen(/var/folders/f_/rdrw1x9x5ml9rb7mhj95cz5r0000gp/T/_MEItA4VRc/cv2/cv2.cpython-37m-darwin.so, 2): Library not loaded: @loader_path/libpng16.16.dylib
  Referenced from: /private/var/folders/f_/rdrw1x9x5ml9rb7mhj95cz5r0000gp/T/_MEItA4VRc/libfreetype.6.dylib
  Reason: Incompatible library version: libfreetype.6.dylib requires version 54.0.0 or later, but libpng16.16.dylib provides version 38.0.0
[2868] Failed to execute script main

CMakeでopencvをビルドした後、再度試すと別のエラーがでました。

  File "/Users/teratail/app/pyside/dist/main.app/Contents/Resources/__boot__.py", line 153, in <module>
    _run()
  File "/Users/teratail/app/pyside/dist/main.app/Contents/Resources/__boot__.py", line 82, in _run
    exec(compile(source, path, 'exec'), globals(), globals())
  File "/Users/teratail/app/pyside/dist/main.app/Contents/Resources/main.py", line 2, in <module>
    import app_module
  File "app_module.pyc", line 2, in <module>
  File "cv2/__init__.pyc", line 96, in <module>
  File "cv2/__init__.pyc", line 58, in bootstrap
  File "cv2/__init__.pyc", line 56, in load_first_config
ImportError: OpenCV loader: missing configuration file: ['config.py']. Check OpenCV installation.

cv2フォルダ内には、config.py,config-3.7.pyはあります。
よろしくお願いします。

環境

macOS 10.12.6
python 3.7.5

pyinstaller 3.5
opencv-python(contrib-python,python-headless含む) 4.1.2.30
py2app 0.19

試したこと

opencvのバージョンをさげる。
brew docterでWARNINGがでないようにする。
brew update upgradeで全て最新バージョンに更新

追記

import cv2
print(cv2.__file__)


で確認すると、

/usr/local/lib/python3.7/site-packages/cv2/python-3.7/cv2.cpython-37m-darwin.so


と出力されたので、

pyinstaller main.py --paths='/usr/local/lib/python3.7/site-packages/cv2/python-3.7'  --onefile --noconsole


この設定でビルドすると、また最初のエラー(参照できないopencvを参照しようとする)に戻ります。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

まだ回答がついていません

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.23%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる