質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.10%

bundle installで 9): Library not loaded:  というエラーが発生する

受付中

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 626

kenken0413

score 4

前提・実現したいこと

rails6でアプリを作成中、bundle installを行うと9): Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib (LoadError)
というエラーが発生するようになりました。

実現したいこと

1.bundle installが正常に行うことができて、アプリ作成作業に戻る
(2.可能であれば同様の案件について知識を習得できる方法で、おすすめの書籍や勉強方法、学習サイトなどについてご教示いただきたい)

発生している問題・エラーメッセージ

bundle installが実行できない

該当のソースコード

Ignoring bcrypt-3.1.13 because its extensions are not built. Try: gem pristine bcrypt --version 3.1.13
Ignoring bigdecimal-1.4.4 because its extensions are not built. Try: gem pristine bigdecimal --version 1.4.4
(中略)
Ignoring zlib-1.1.0 because its extensions are not built. Try: gem pristine zlib --version 1.1.0
Traceback (most recent call last):
        33: from /Users/Ken/.rbenv/versions/2.5.1/bin/bundle:23:in `<main>'
        32: from /Users/Ken/.rbenv/versions/2.5.1/bin/bundle:23:in `load'
        31: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.2/exe/bundle:22:in `<top (required)>'
        30: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.2/lib/bundler/friendly_errors.rb:124:in `with_friendly_errors'
        29: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.2/exe/bundle:30:in `block in <top (required)>'
        28: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.2/lib/bundler/cli.rb:18:in `start'
        27: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.2/lib/bundler/vendor/thor/lib/thor/base.rb:466:in `start'
        26: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.2/lib/bundler/cli.rb:27:in `dispatch'
        25: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.2/lib/bundler/vendor/thor/lib/thor.rb:387:in `dispatch'
        24: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.2/lib/bundler/vendor/thor/lib/thor/invocation.rb:126:in `invoke_command'
        23: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.2/lib/bundler/vendor/thor/lib/thor/command.rb:27:in `run'
        22: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.2/lib/bundler/cli.rb:234:in `install'
        21: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.2/lib/bundler/settings.rb:144:in `temporary'
        20: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.2/lib/bundler/cli.rb:235:in `block in install'
        19: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.2/lib/bundler/cli/install.rb:53:in `run'
        18: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/site_ruby/2.5.0/rubygems/core_ext/kernel_require.rb:54:in `require'
        17: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/site_ruby/2.5.0/rubygems/core_ext/kernel_require.rb:54:in `require'
        16: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.2/lib/bundler/fetcher.rb:8:in `<top (required)>'
        15: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.2/lib/bundler/fetcher.rb:10:in `<module:Bundler>'
        14: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.2/lib/bundler/fetcher.rb:217:in `<class:Fetcher>'
        13: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/site_ruby/2.5.0/rubygems/core_ext/kernel_require.rb:54:in `require'
        12: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/site_ruby/2.5.0/rubygems/core_ext/kernel_require.rb:54:in `require'
        11: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.2/lib/bundler/fetcher/index.rb:4:in `<top (required)>'
        10: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/site_ruby/2.5.0/rubygems/core_ext/kernel_require.rb:54:in `require'
         9: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/site_ruby/2.5.0/rubygems/core_ext/kernel_require.rb:54:in `require'
         8: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/site_ruby/2.5.0/rubygems/remote_fetcher.rb:5:in `<top (required)>'
         7: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/site_ruby/2.5.0/rubygems/core_ext/kernel_require.rb:54:in `require'
         6: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/site_ruby/2.5.0/rubygems/core_ext/kernel_require.rb:54:in `require'
         5: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/site_ruby/2.5.0/rubygems/s3_uri_signer.rb:3:in `<top (required)>'
         4: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/site_ruby/2.5.0/rubygems/core_ext/kernel_require.rb:54:in `require'
         3: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/site_ruby/2.5.0/rubygems/core_ext/kernel_require.rb:54:in `require'
         2: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/openssl-2.1.2/lib/openssl.rb:13:in `<top (required)>'
         1: from /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/site_ruby/2.5.0/rubygems/core_ext/kernel_require.rb:54:in `require'
/Users/Ken/.rbenv/versions/2.5.1/lib/ruby/site_ruby/2.5.0/rubygems/core_ext/kernel_require.rb:54:in `require': dlopen(/Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/openssl-2.1.2/lib/openssl.bundle, 9): Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib (LoadError)
  Referenced from: /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/openssl-2.1.2/lib/openssl.bundle
  Reason: image not found - /Users/Ken/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/openssl-2.1.2/lib/openssl.bundle

試したこと

  • brew update ,brew upgrade(下記記事ほか多数)
    エラー文に変化もなく変わらず。
    https://qiita.com/utsu_jimmy/items/a35437faea1c0d2f357d

  • opensslにて再設定
    opensslに関する別の設定エラー?が起きた上、解決せず。
    libresslがmacの標準であるという知識が不足しており、問題が複雑化すると考えたため以後libresslに戻しました。
    https://github.com/kelaberetiv/TagUI/issues/86

  • homebrewの再インストール

  • brew link libressl --force

Warning: Refusing to link macOS-provided software: libressl
If you need to have libressl first in your PATH run:
  echo 'export PATH="/usr/local/opt/libressl/bin:$PATH"' >> ~/.zshrc
For compilers to find libressl you may need to set:
  export LDFLAGS="-L/usr/local/opt/libressl/lib"
  export CPPFLAGS="-I/usr/local/opt/libressl/include"
For pkg-config to find libressl you may need to set:
  export PKG_CONFIG_PATH="/usr/local/opt/libressl/lib/pkgconfig"


というエラーメッセージが出たためexport 以下4つをzshrcに保存し、sourceで反映しましたが変化なし。

補足情報(FW/ツールのバージョンなど)

mac os : catalina10.15.2(作業途中にmojavaから移行してしまったため、bashをzshに置き換えて作業しています)
ruby : 2.5.1p57 (2018-03-29 revision 63029) [x86_64-darwin19]
rails : 6.0.1
libressl,homebrew,rbenv

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • winterboum

    2019/12/18 07:09

    compileが必要なgemのcompileが出来ないという問題ですが、この場合OSやLinuxの場合destributionによって対処の方法が異なるので、OS環境を追加してください。
    気になるのは
    because its extensions are not built
    そのOSでは使っていない拡張子でのcompileを行おうとしているような??

    キャンセル

  • kenken0413

    2019/12/18 08:29

    ありがとうございます!
    OS情報を追記いたしましたが、他に不足する情報等はありますか?

    キャンセル

回答 1

+1

Mac使いではないので最終的な壁を越える時のお手伝いができるかは不安ですが、いまの段階で2点
1) エラーメッセージに障害解決の助言が書かれていることが多いです。
今回 「Try: gem pristine 。。。」というのがいくつかあります。それらを実行してからもう一度やってみてください
2) 今回のエラーメッセージには無いようですが、「logがあるから読め」というのが出ることもあります。そのlogにも助言や何が足りないかなどが書かれていることが多いので、それに従ってください。
具体的なやり方で行き詰まったらそのlogも提示するのが良いです

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/12/18 09:31

    ご回答ありがとうございます、ご指摘いただいた内容について実行するようにします!
    また、ご丁寧に教えていただきありがとうざいます!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.10%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

同じタグがついた質問を見る