質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.10%

rubyがインストールできない

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 261

story_aniki

score 187

ruby on rails の学習のため環境構築をしているのですが
仮想マシンの構築に成功しrubyをインストールしようとしたところで詰まりました

OS:  CentOS Linux release 7.7.1908 (Core)

以下は行ったことです

rbenv のインストール

$ git clone https://github.com/sstephenson/rbenv.git ~/.rbenv
$ echo 'export PATH="$HOME/.rbenv/bin:$PATH"' >> ~/.bash_profile
$ echo 'eval "$(rbenv init -)"' >> ~/.bash_profile
$ source ~/.bash_profile

ruby-build のインストール

$ git clone git://github.com/sstephenson/ruby-build.git ~/.rbenv/plugins/ruby-build
$ cd ~/.rbenv/plugins/ruby-build
$ sudo ./install.sh

必要なパッケージのインストール

sudo yum install -y openssl-devel readline-devel zlib-devel

インストール可能なRUBYのバージョン確認

$ rbenv install -l
 :
2.6.2
2.6.3
2.6.4
2.6.5
2.7.0-dev
2.7.0-preview1
2.7.0-preview2
2.7.0-preview3
jruby-1.5.6
jruby-1.6.3
 :

2.7.0-devを入れることに決め、インストールしようとする(本題とは外れますが-devの意味も教えていただければ幸いです。development(開発)の略だとは思うのですが、これを選択するのはお勧めなのかどうか)

[vagrant@localhost ruby-build]$ rbenv install 2.7.0-dev
Cloning https://github.com/ruby/ruby.git...
Installing ruby-master...

BUILD FAILED (CentOS Linux 7 using ruby-build 20191205)

Inspect or clean up the working tree at /tmp/ruby-build.20191212162945.4983.FDwda8
Results logged to /tmp/ruby-build.20191212162945.4983.log

Last 10 log lines:
/tmp/ruby-build.20191212162945.4983.FDwda8 ~/.rbenv/plugins/ruby-build
Cloning into 'ruby-master'...
/tmp/ruby-build.20191212162945.4983.FDwda8/ruby-master /tmp/ruby-build.20191212162945.4983.FDwda8 ~/.rbenv/plugins/ruby-build
/home/vagrant/.rbenv/plugins/ruby-build/bin/ruby-build: line 622: autoconf: command not found

ビルドに失敗
ログの最後の行を見るとコマンドが見つけられなかったことが原因のように見えます
ruby-buildに何か不具合があるのでしょうか?
解決法を教えていただきたいです
ちなみに、rbenvはバージョンが表示されるので実装できています

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

checkベストアンサー

+1

-devは、開発途中でまだリリースされていないバージョンです。Rubyの開発に参加している人や、バグ発見に協力したい人が使うバージョンです。

一般の人はリリースされているバージョンを使います。今だと最新は2.6.5です。

autoconfが無いということですが、プログラム開発に必要なコマンド群をインストールしていないのでは?
sudo yum groupinstall "Development Tools"してみてください。
ごそっと入るので、Rubyのインストールになくてもいいものまでインストールされます。

最小限のインストールにしたい場合は、エラーになる都度、足りないものをインストールしてください。
yum provides */autoconfとかで、必要なパッケージがわかります。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/12/13 02:06

    ありがとうございました
    開発途中のバージョンであったために、プログラム開発に必要なコマンド群が不足していてエラーが出ていたという事になるのでしょうか
    ご指摘の通り開発ツールをインストールし、やはり開発中では不安なので最新である2.6.5をインストールしたところうまくいきました(開発中でないバージョンなために開発ツールは不要だったのかも)
    ありがとうございました

    キャンセル

  • 2019/12/13 02:12

    > 開発途中のバージョンであったために、プログラム開発に必要なコマンド群が不足していてエラーが出ていたという事になるのでしょうか

    いいえ。
    どのバージョンであれ、Rubyをソースからインストールするには、開発ツールが必要です。
    バージョンの違いは、プログラムの中身であって、インストール方法に違いは無いです。

    キャンセル

  • 2019/12/13 02:15

    わざわざ回答ありがとうございます
    勉強になりました

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.10%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる