質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.48%

WindowsにてWSGIを連携させたいが、Apacheが起動しない

解決済

回答 1

投稿 編集

  • 評価
  • クリップ 0
  • VIEW 3,948

score 9

前提・実現したいこと

WindowsにてWSGIとApacheを連携させたいです
(目的はDjangoでWebアプリを作成したいです)

■環境
OS:Windows Server 2012 64bit
Python: ver.3.8 (venv環境)
Apache: ver.2.4

発生している問題・エラーメッセージ

Apacheを起動させようとすると、起動しません。
エラーメッセージも出力されずに、終了してしまいます。
エラーメッセージが出ないので、何が悪いのかわからず困っています。。

C:\Apache24\bin>httpd.exe -k start

C:\Apache24\bin>httpd -k stop
The 'Apache2.4' service is not started.

C:\Apache24\bin>


※上記は、起動時にはエラーが出ないが、実際には起動できていない様子です。

error_logファイルには、起動時の下記のメッセージしか出力されていません。
【error_log】

Starting the 'Apache2.4' service
The 'Apache2.4' service is running.

該当のソースコード

下記設定ファイルのLoadModule以下を削除するとApacheが正常に起動するので、
下記記述のどこかに問題があるかと思います。
パスに間違いがないことは確認済みです。

httpd.conf

LoadModule wsgi_module "c:/~~~/mod_wsgi.cp38-win_amd64.pyd"

WSGIPythonHome "c:/~~~/venv"
WSGIScriptAlias / "c:/~~~/wsgi.py"
WSGIPythonPath "c:/~~~"

<Directory "c:/~~~">
<Files wsgi.py>
Require all granted
</Files>
</Directory>

試したこと

mod_wsgi-express module-configにて出力された情報を、上記httpd.confに記載しています。

■Apache
httpd-2.4.41-win64-VC15
■mod_wsgi
mod_wsgi-4.6.8+ap24vc15-cp38-cp38-win_amd64.whl
→Apacheのバージョン(2.4 VC15)、Pythonのバージョン(3.8)、OSのビット数(64)も全て一致しております

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • take88

    2019/12/12 01:00

    mod_wsgi の GithubのReadmeを見ると、Cコンパライラのバージョンが重要らしいです。Apacheとmod_wsgiはVC15でビルドされてるっぽいですが、Python 3.8 が VC15でコンパイルされてるかわかりますか?

    キャンセル

  • take88

    2019/12/12 01:19

    あと、LoadModule の引数から クォートを外すとどうなりますか?

    キャンセル

  • take88

    2019/12/12 02:44

    色々書きましたが、回答に書きましたのでご確認ください。

    キャンセル

回答 1

checkベストアンサー

0

mod_wsgi-express.exe module-config を実行すると 設定が表示されるのでそのまま httpd.conf にペーストすれば良いと思います。

C:\~\Python38\Scripts>mod_wsgi-express.exe module-config
LoadFile "c:/~/python38/python38.dll"
LoadModule wsgi_module "c:/~/python38/lib/site-packages/mod_wsgi/server/mod_wsgi.cp38-win_amd64.pyd"
WSGIPythonHome "c:/~/python38"

たぶん、LoadFile で python38.dll をロードすれば良さそうです。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/12/12 11:27

    仰る通り、LoadFileでpython38.dllを追加したところ正常にApache が起動することを確認しました!
    二日くらいずっと詰まっていたので、非常に助かりました!ありがとうございます!

    taka88さんの技術力の高さに感謝します!

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.48%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る