質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

89.13%

OpenCVをWSLにインストールでcmake..を実行するとfind_package(OpenCV REQUIRED)でエラーが発生

解決済

回答 2

投稿

  • 評価
  • クリップ 0
  • VIEW 730

mercurian-teto

score 75

環境

windows10 pro
WLS

やりたいこと

WSLにC++のopencvをインストールしようとしています。
以下のサイトのとおりに手順を進めました。

(CMake)WSLに公式OpenCVをやさしくインストール (C/C++, Python2, Python3)
OpenCVを使ったC++コードをコンパイルする(CMake, GCC, pkg-config)
すると、

~/opencv/cpp_version_test/build$ cmake ..


と実行すると、

CMake Error at CMakeLists.txt:12 (find_package):
  By not providing "FindOpenCV.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "OpenCV", but
  CMake did not find one.

  Could not find a package configuration file provided by "OpenCV" with any
  of the following names:

    OpenCVConfig.cmake
    opencv-config.cmake

  Add the installation prefix of "OpenCV" to CMAKE_PREFIX_PATH or set
  "OpenCV_DIR" to a directory containing one of the above files.  If "OpenCV"
  provides a separate development package or SDK, be sure it has been
  installed.


-- Configuring incomplete, errors occurred!
See also "/home/***/opencv/cpp_version_test/build/CMakeFiles/CMakeOutput.log".


というようなエラーが発生しました。
CMakeLists.txtのfind_packageが原因だそうです。
何かpathらしきものが失敗しているそうですが、調べてもよくわかりません。
どこをどのように確認して修正すればいいでしょうか。
回答よろしくお願いします。

CMakeLists.txtの内容は下のとおりです。

# 変数SOURCE_CORDEを宣言し、opencv_testという値を入れる。
# cmake -D SOURCE_CODE=(ソース名)で上書き可
set(SOURCE_CODE opencv_test CACHE NAME "Target object name")

# CMakeの最低バージョンを記述
cmake_minimum_required(VERSION 2.8)

# ソリューション名を指定
project( ${SOURCE_CODE} )

# OpenCVのパッケージを探す 
find_package( OpenCV REQUIRED ) 

#ヘッダファイルのパスを指定
include_directories( ${OpenCV_INCLUDE_DIRS} )

# 実行ファイル名とソース指定(ここではソースと同じ名前の実行ファイルを作ります)
add_executable( ${SOURCE_CODE} ${SOURCE_CODE}.cpp )

#リンク先のライブラリを指定
target_link_libraries( ${SOURCE_CODE} ${OpenCV_LIBS} )

現在のディレクトリの状態は以下のとおりです。

~/opencv/cpp_version_test$ tree

├── CMakeLists.txt
├── build
│   ├── CMakeCache.txt
│   └── CMakeFiles
│       ├── 3.10.2
│       │   ├── CMakeCCompiler.cmake
│       │   ├── CMakeCXXCompiler.cmake
│       │   ├── CMakeDetermineCompilerABI_C.bin
│       │   ├── CMakeDetermineCompilerABI_CXX.bin
│       │   ├── CMakeSystem.cmake
│       │   ├── CompilerIdC
│       │   │   ├── CMakeCCompilerId.c
│       │   │   ├── a.out
│       │   │   └── tmp
│       │   └── CompilerIdCXX
│       │       ├── CMakeCXXCompilerId.cpp
│       │       ├── a.out
│       │       └── tmp
│       ├── CMakeOutput.log
│       ├── CMakeTmp
│       ├── cmake.check_cache
│       ├── feature_tests.bin
│       ├── feature_tests.c
│       └── feature_tests.cxx
└── opencv_test.cpp
  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • nanami12

    2019/11/29 16:15

    CMakeOutput.logはご覧になりましたか?

    キャンセル

  • tiitoi

    2019/11/29 16:17

    OpenCV はどのようにインストールしましたか?

    キャンセル

回答 2

check解決した方法

0

自己解決しました。
cd ~を入力して、opencv,opencv_contribを削除してもう一度、先ほど示したサイトの通り手順を進めるとopencvがインストールできました。
先ほどの手順でインストールしたopencvのバージョンは

pkg-config --modversion opencv
3.2.0


でした。

投稿

編集

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

0

参考にされているサイトを見ましたが、OpenCVのインストールで、

$ cmake -D CMAKE_BUILD_TYPE=Release -D CMAKE_INSTALL_PREFIX=/usr/local -D WITH_TBB=ON -D WITH_OPENGL=ON -D OPENCV_EXTRA_MODULES_PATH=~/opencv_contrib/modules -D OPENCV_GENERATE_PKGCONFIG=ON ..

というように実行しているので、「/usr/local」以下にインストールされています。
そのせいで、OpenCVのcmake用モジュールを見つけてもらえないのではないですか。

おそらく、「/usr/local/share/cmake-<なんちゃら> /Modules」以下に「OpenCV<なんちゃら>.cmake」とかそれっぽいファイルがあると思うので、そのディレクトリを「CMAKE_MODULE_PATH」に設定してみてください。
やり方は、「CMAKE_MODULE_PATH」でググれば出てくると思います。

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/12/04 17:40

    回答ありがとうございます。
    cd ~を入力して、opencv,opencv_contribを削除してもう一度、先ほど示したサイトの通り手順を進めるとopencvがインストールできました。原因がわからずとりあえず解決してしまいました。申し訳ありません。
    /usr/local/shareディレクトリにはcmake-<******>は存在しませんでした。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 89.13%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる