質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

87.50%

Macにて、pythonのpip installができません

解決済

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 2,612

score 16

前提・実現したいこと

macでpipのinstallができません。

ここに質問の内容を詳しく書いてください。
(例)PHP(CakePHP)で●●なシステムを作っています。
■■な機能を実装中に以下のエラーメッセージが発生しました。
pythonでpip installを実行すると以下のようなエラーが発生します。
色んなサイトで調べたのですが、解決しなかったので、質問させてもらいました。

発生している問題・エラーメッセージ

pythonのシェルにて、pip installと打つと、

エラーメッセージ```ERROR: Command errored out with exit status 1:  
command: /usr/bin/python -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/private/var/folders/51/z424zzr1373fllfjqvh42h6r0000gn/T/pip-install-oZ5Nug/bottle/setup.py'"'"'; __file__='"'"'/private/var/folders/51/z424zzr1373fllfjqvh42h6r0000gn/T/pip-install-oZ5Nug/bottle/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /private/var/folders/51/z424zzr1373fllfjqvh42h6r0000gn/T/pip-record-zYQeHw/install-record.txt --single-version-externally-managed --compile  
cwd: /private/var/folders/51/z424zzr1373fllfjqvh42h6r0000gn/T/pip-install-oZ5Nug/bottle/  
Complete output (13 lines):  
running install  
running build  
running build_py  
creating build  
creating build/lib  
copying bottle.py -> build/lib  
running build_scripts  
creating build/scripts-2.7  
copying and adjusting bottle.py -> build/scripts-2.7  
changing mode of build/scripts-2.7/bottle.py from 644 to 755  
running install_lib  
copying build/lib/bottle.py -> /Library/Python/2.7/site-packages  
error: [Errno 13] Permission denied: '/Library/Python/2.7/site-packages/bottle.py'  
----------------------------------------  
ERROR: Command errored out with exit status 1: /usr/bin/python -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/private/var/folders/51/z424zzr1373fllfjqvh42h6r0000gn/T/pip-install-oZ5Nug/bottle/setup.py'"'"'; __file__='"'"'/private/var/folders/51/z424zzr1373fllfjqvh42h6r0000gn/T/pip-install-oZ5Nug/bottle/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /private/var/folders/51/z424zzr1373fllfjqvh42h6r0000gn/T/pip-record-zYQeHw/install-record.txt --single-version-externally-managed --compile Check the logs for full command output.  

### 該当のソースコード  
pip install bottle  

ここに言語名を入力 ソースコード ```

試したこと

公式サイトにpipをインストールするためのコマンドが書いていたので、試したのですが、できませんでした。
python -m ensurepip --default-pip

補足情報(FW/ツールのバージョンなど)

python -Vと打つと、Python 2.7.10と出てきます。
しかし、idleにはpython3.8と書いてあります。

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

質問への追記・修正、ベストアンサー選択の依頼

  • ym1111

    2019/11/27 19:50

    which python → /usr/bin/python
    which python3 → /Library/Frameworks/Python.framework/Versions/3.8/bin/python3
    which pip → /usr/local/bin/pip
    which pip3 →/Library/Frameworks/Python.framework/Versions/3.8/bin/pip3
    です。

    pipはおそらくインストールできていると思うので、例えばbottleをインストールしたい時に、pip install bottleなどと打った時に上記のようなエラーを無くせるようにしたいです。

    キャンセル

  • ym1111

    2019/11/27 19:53

    pip -Vも書き忘れていました。
    pip -V → pip 19.3.1 from /Library/Python/2.7/site-packages/pip-19.3.1-py2.7.egg/pip (python 2.7)
    pip3 -V →
    pip 19.2.3 from/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/site-packages/pip (python 3.8)

    キャンセル

  • quickquip

    2019/11/27 21:10

    情報はこの欄ではなく質問に追記してください

    キャンセル

回答 1

checkベストアンサー

+1

初めまして。
自分はpythonを初めて間もないので、参考になるかわかりませんが、

copying build/lib/bottle.py -> /Library/Python/2.7/site-packages  
error: [Errno 13] Permission denied: '/Library/Python/2.7/site-packages/bottle.py'  


と/Library/Python/2.7/site-packages へのコピーがパーミッションエラーになっていると思われます。
実行ユーザーを確認してみてはいかがでしょうか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/12/29 18:28

    返信が遅くなって申し訳ございません。
    実行ユーザーを変えてみたところできました。
    解答ありがとうございました。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 87.50%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る