質問をすることでしか得られない、回答やアドバイスがある。

15分調べてもわからないことは、質問しよう!

ただいまの
回答率

88.20%

ラズベリーパイにopencvがインストールできない

受付中

回答 1

投稿

  • 評価
  • クリップ 0
  • VIEW 1,889

soepu

score 41

ラズベリーパイにopencvをインストールしようとしています。
(ラズベリーパイ4 SDカードはOS書き込み済みのものを使用)

以前、別のラズベリーパイにインストールしたことがあり、
下記コードを使った記憶があります。

sudo apt-get install libopencv-dev
sudo apt-get install python-opencv


今回はなぜか、上記コマンドを実行すると、
E: http://raspbian.raspberrypi.org/raspbian/pool/main/m/mariadb-10.3/libmariadb3_10.3.15-1_armhf.deb の取得に失敗しました  404  Not Found [IP: 93.93.128.193 80]
E: http://raspbian.raspberrypi.org/raspbian/pool/main/g/gdcm/libgdcm2.8_2.8.8-6_armhf.deb の取得に失敗しました  404  Not Found [IP: 93.93.128.193 80]
E: いくつかのアーカイブを取得できません。apt-get update を実行するか --fix-missing オプションを付けて試してみてください。

といったエラーがでます。
apt-get update は何回も試みました。

上記エラー内容、解決方法をご教授頂けますでしょうか?

  • 気になる質問をクリップする

    クリップした質問は、後からいつでもマイページで確認できます。

    またクリップした質問に回答があった際、通知やメールを受け取ることができます。

    クリップを取り消します

  • 良い質問の評価を上げる

    以下のような質問は評価を上げましょう

    • 質問内容が明確
    • 自分も答えを知りたい
    • 質問者以外のユーザにも役立つ

    評価が高い質問は、TOPページの「注目」タブのフィードに表示されやすくなります。

    質問の評価を上げたことを取り消します

  • 評価を下げられる数の上限に達しました

    評価を下げることができません

    • 1日5回まで評価を下げられます
    • 1日に1ユーザに対して2回まで評価を下げられます

    質問の評価を下げる

    teratailでは下記のような質問を「具体的に困っていることがない質問」、「サイトポリシーに違反する質問」と定義し、推奨していません。

    • プログラミングに関係のない質問
    • やってほしいことだけを記載した丸投げの質問
    • 問題・課題が含まれていない質問
    • 意図的に内容が抹消された質問
    • 過去に投稿した質問と同じ内容の質問
    • 広告と受け取られるような投稿

    評価が下がると、TOPページの「アクティブ」「注目」タブのフィードに表示されにくくなります。

    質問の評価を下げたことを取り消します

    この機能は開放されていません

    評価を下げる条件を満たしてません

    評価を下げる理由を選択してください

    詳細な説明はこちら

    上記に当てはまらず、質問内容が明確になっていない質問には「情報の追加・修正依頼」機能からコメントをしてください。

    質問の評価を下げる機能の利用条件

    この機能を利用するためには、以下の事項を行う必要があります。

回答 1

0

おす!

E: http://raspbian.raspberrypi.org/raspbian/pool/main/g/gdcm/libgdcm2.8_2.8.8-6_armhf.deb の取得に失敗しました  404  Not Found [IP: 93.93.128.193 80]

ってぇ事だけんどもよう。

http://raspbian.raspberrypi.org/raspbian/pool/main/g/gdcm/

を見てみっと、libgdcm2.8_2.8.8-6_armhf.deb はもう、無ぇみてぇだぞ。

代わりになりそうなのは

  1. libgdcm2.8_2.8.8-9_armhf.deb    13-Jun-2019 22:08
  2. libgdcm2.8_2.8.8-9+b1_armhf.deb    15-Aug-2019 01:27
  3. libgdcm3.0_3.0.4-2_armhf.deb    12-Nov-2019 09:26

みてぇだから、一番新しい libgdcm3.0_3.0.4-2_armhf.deb でやってみたらいいんじゃねぇか?

投稿

  • 回答の評価を上げる

    以下のような回答は評価を上げましょう

    • 正しい回答
    • わかりやすい回答
    • ためになる回答

    評価が高い回答ほどページの上位に表示されます。

  • 回答の評価を下げる

    下記のような回答は推奨されていません。

    • 間違っている回答
    • 質問の回答になっていない投稿
    • スパムや攻撃的な表現を用いた投稿

    評価を下げる際はその理由を明確に伝え、適切な回答に修正してもらいましょう。

  • 2019/11/22 12:11

    ご返信ありがとうございます。
    一番新しい libgdcm3.0_3.0.4-2_armhf.deb でやる、とは
    具体的にどのようにすれば良いのでしょうか?
    お手数おかけしますが、ご回答宜しくお願い致します。

    キャンセル

  • 2019/11/22 12:40 編集

    おす!

    手元に稼働させてるRasPiねぇし、時間もねぇから確認してねぇんだけんどもさぁ、

    Debian 系であえて古い APT パッケージをインストールする方法
    https://qiita.com/kitsuyui/items/d8940e093fa41b58fe71

    これでいけねぇかな? 逆に新しい方のパッケージを指定すりゃあいいと思うんだが。
    もっというと、 apt-get update でリスト更新したら解決しねぇかな?

    雑な回答で悪ぃな。

    キャンセル

15分調べてもわからないことは、teratailで質問しよう!

  • ただいまの回答率 88.20%
  • 質問をまとめることで、思考を整理して素早く解決
  • テンプレート機能で、簡単に質問をまとめられる

関連した質問

同じタグがついた質問を見る